Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Hardware - Troubleshooting and Discussion > iPhone, iPad & iPod > iPhone WiFi connection problems

iPhone WiFi connection problems
Thread Tools
Fresh-Faced Recruit
Join Date: Mar 2004
Status: Offline
Reply With Quote
Jun 30, 2007, 09:40 AM
 
Posts starting to show up at other forums with my problem. I can get an IP address fine from my WiFi router but nothing will connect. Safari returns "Can't find server". Google maps and weather just sit and spin. Now the odd thing. I shut off Wifi and can connect via edge. Google maps appear on edge. Turned wifi back on. I can use wifi to go back to those specific maps but no others. Same with web pages. Connect to Amazon via Edge. Turn wifi back on. Now I can connect to Amazon's main page but no deeper to books, etc. "Can't Find the Server".
Factoids: Belkin router with open network (I live far from road and neighbors), moved iphone IP to DMZ-no help; turned off router firewall-no change.
Any ideas?
     
Mac Elite
Join Date: Apr 2003
Location: Southern, NJ (near Philly YO!)
Status: Offline
Reply With Quote
Jun 30, 2007, 11:03 AM
 
Same problem here...it shows up on my router as a connected device but it fails when trying to do anything, web, email, maps. I'm sure its a glitch soon to be fixed! Linksys router
MacBook Pro 15" i7 ~ Snow Leopard ~ iPhone 4 - 16Gb
     
Mac Elite
Join Date: Jun 2001
Location: NYNY
Status: Offline
Reply With Quote
Jun 30, 2007, 12:00 PM
 
Yup. I got the same problem. So did my friend in another Boston.

I have a linksys. Was b/g mixed. Tried changing to G only. No luck.

Still sweet ass though
     
Mac Elite
Join Date: Jun 2001
Location: NYNY
Status: Offline
Reply With Quote
Jun 30, 2007, 01:18 PM
 
I fixed my problem by turning off security. No password no problem. I had wep before. maybe wpa is better dunno.
     
Mac Elite
Join Date: Apr 2003
Location: Southern, NJ (near Philly YO!)
Status: Offline
Reply With Quote
Jun 30, 2007, 01:29 PM
 
Originally Posted by Moderator View Post
I fixed my problem by turning off security. No password no problem. I had wep before. maybe wpa is better dunno.
I tried my network wide open and the phones MAC address is showing up in my connected list but still no go..I have a Linksys WRT300n set to BG mixed WiFi
MacBook Pro 15" i7 ~ Snow Leopard ~ iPhone 4 - 16Gb
     
Dedicated MacNNer
Join Date: Aug 2005
Location: NJ
Status: Offline
Reply With Quote
Jun 30, 2007, 01:33 PM
 
Eek...I don't feel comfortable having a network with security totally off...
MBP 15" 2.33 ghz 256Video Card
40 Gig iPod, Airport Extreme
     
Mac Elite
Join Date: Apr 2003
Location: Southern, NJ (near Philly YO!)
Status: Offline
Reply With Quote
Jun 30, 2007, 02:09 PM
 
Originally Posted by NateEssex View Post
Eek...I don't feel comfortable having a network with security totally off...
Well this was to try to just get it to connect im usually all secure
MacBook Pro 15" i7 ~ Snow Leopard ~ iPhone 4 - 16Gb
     
Addicted to MacNN
Join Date: Jan 2002
Location: PDX
Status: Offline
Reply With Quote
Jun 30, 2007, 02:18 PM
 
Mine worked fine with security on. Entered my PW and I was in. And its pretty quick.
     
Fresh-Faced Recruit
Join Date: Mar 2004
Status: Offline
Reply With Quote
Jun 30, 2007, 03:35 PM
 
Fixed it!! For me at least it was a DNS issue. The iphone was getting the router's ip on top of the dns address. I noticed the web pages hung up at the first contact when the IP address is usually looked up on the DNS. I deleted the dns numbers on the dhcp panel then looked up my DNS numbers on my router. (For a belkin, point your browser to 192.168.2.1) I typed in the DNS ip address manually in the dhcp panel and I'm back online. And this is after adding in WPA security.
     
Professional Poster
Join Date: Feb 2002
Location: Why do you care?
Status: Offline
Reply With Quote
Jun 30, 2007, 03:44 PM
 
Originally Posted by ::maroma:: View Post
Mine worked fine with security on. Entered my PW and I was in. And its pretty quick.
Ditto. Airport Extreme router.
2.3GHz i7 15" Retina Macbook Pro (Late 2013)
     
Addicted to MacNN
Join Date: Jan 2002
Location: PDX
Status: Offline
Reply With Quote
Jun 30, 2007, 04:03 PM
 
Originally Posted by Mrjinglesusa View Post
Ditto. Airport Extreme router.
Airport Express here.
     
Professional Poster
Join Date: Sep 2000
Location: San Francisco
Status: Offline
Reply With Quote
Jun 30, 2007, 05:45 PM
 
I can't connect to a friend's wireless router. He thinks it is a linksys or netgear. The iPhone sees it and suggests "WEP Encryption". I found the password on his MacBook in the Network security pane, but the iPhone won't connect. It just says "Unable to join sbob network". Does this have something to do with that funny hexadecimal thing that used to happen with WEP? The password began with a "$" if that signifies something; although that could have just been the password.

I can connect to my Airport without problems.

Any help?
thanks,
kman
     
Dedicated MacNNer
Join Date: Aug 2005
Location: NJ
Status: Offline
Reply With Quote
Jul 1, 2007, 12:31 AM
 
I have added 3 WiFi networks as I visit people and for some reason, the iPhone drops the Wifi and goes with the Edge ?!?! I don't know how to MAKE it try/use WiFi first or exclusively.

Any suggestions?
MBP 15" 2.33 ghz 256Video Card
40 Gig iPod, Airport Extreme
     
Mac Elite
Join Date: May 2001
Location: type 13 planet
Status: Offline
Reply With Quote
Jul 1, 2007, 12:48 AM
 
Having problems with Linksys here. Reminded me of issues I had with old airport cards. Changed the connection from WEP Password to WEP Hex/ASCII and entered string. Works great. A pain, but it works.

New, Improved and Legal in 50 States
     
Dedicated MacNNer
Join Date: Aug 2005
Location: NJ
Status: Offline
Reply With Quote
Jul 1, 2007, 01:56 PM
 
Here is what I've noticed:

After I sync my phone, I get the Wifi Icon and it will stay up for my home wireless. As soon as I select an app that uses Internet, it disappears and goes back to Edge.

Any ideas?!?!
MBP 15" 2.33 ghz 256Video Card
40 Gig iPod, Airport Extreme
     
Fresh-Faced Recruit
Join Date: Oct 2006
Status: Offline
Reply With Quote
Jul 1, 2007, 02:59 PM
 
I have a Linksys router we use at work (no key) and a Netgear at home (no key either) and set up the Netgear router first. One of my neighbors has a Linksys that is keyed, and when I'm at home, for some reason it constantly wants to be connected to the Linksys. It's not mine, I don't know the key, and wish it would stop trying to connect. That's my only real gripe with the phone so far. Maybe it's got something to do with Apple and Cisco's agreement on the iPhone name.
     
Junior Member
Join Date: Jun 2007
Status: Offline
Reply With Quote
Jul 1, 2007, 03:06 PM
 
Originally Posted by rclay6612 View Post
Fixed it!! For me at least it was a DNS issue. The iphone was getting the router's ip on top of the dns address. I noticed the web pages hung up at the first contact when the IP address is usually looked up on the DNS. I deleted the dns numbers on the dhcp panel then looked up my DNS numbers on my router. (For a belkin, point your browser to 192.168.2.1) I typed in the DNS ip address manually in the dhcp panel and I'm back online. And this is after adding in WPA security.
I had to enter my WEP pasword under WEP Hex or ASCII instead of plain WEP. Almost every house around me has an Access Point so I have to have some kind of password. I have Verizon FIOS and when they installed it they gave me bigger wireless ActionTec router and asked me to use it instead of my old one. That ActionTec works great with every laptop but I am having lot of problems connecting iPhone to WiFi and staying on it, it is very inconsistent.
Same experience: when it finally connects (I have to reenter SSID and password every time iPhone goes to sleep) and I get all the bands showing WiFi in range I go to Safari and it times out saying it can not find a server. I have to I added DNS once and now it remembers it.
When I shut the iPhone off, turn it on and then enter WiFi settings everything works perfectly. I just hate to do that every time. It seems that I will have to rely on WiFi and going through that procedure is really annoying. I live and work in Sarasota, FL and my Edge speed tests on iPhone showed only between 80 and 140 kbit/s. Some other people reported Edge running at 360+ kbit/s in different parts of the country.
When I drove past Tampa my wife's new Nokia N75 was flying on 3G and they are supposed to upgrade our area within 6 months. Hopefully when they upgrade to 3G infrastructure Edge would get a bump as well.
     
Fresh-Faced Recruit
Join Date: Jul 2007
Status: Offline
Reply With Quote
Jul 1, 2007, 05:23 PM
 
After 24 hours of trying to get my wife's Iphone to connect to our D-Link Wireless Access Point, I found a thread on the Apple Support that fixed the problem.

The thread indicated the IPhone apparently has problems resolving DNS names, to look up the DNS name and manually enter the address into the Iphone.

I found the DNS Address for my web company, manually entered it into the phone and WHAM it connected immediately and works much better over DSL than on the ATT Edge Network.

We are using DSL to a D-Link Router to a D-Link WAP. I have never had trouble with my MacMini, MacBook or WIndows PC with this set up, but the Iphone would not work before I manually entered the DNS Address.
     
Dedicated MacNNer
Join Date: Aug 2005
Location: NJ
Status: Offline
Reply With Quote
Jul 1, 2007, 08:36 PM
 
Okay, I've been able to get two wireless networks to work by putting the password but first changing the Security setting from WEP Password to "WEP hex or ASCII".

Since I've been doing that, 2 out of 2 WiFi's have worked for me.
MBP 15" 2.33 ghz 256Video Card
40 Gig iPod, Airport Extreme
     
Fresh-Faced Recruit
Join Date: Jul 2007
Status: Offline
Reply With Quote
Jul 3, 2007, 02:45 PM
 
I had the DNS issue. Fixed it by pointing the DNS at 4.2.2.2
This address should work in most cases.
     
Fresh-Faced Recruit
Join Date: Jul 2007
Status: Offline
Reply With Quote
Jul 4, 2007, 03:04 PM
 
As was mentioned there can be a conflict with wireless IP addresses when iPhone tries to connect to your wireless router.
Step 1: open your network pref pane and click one TCP/IP info. generally you should see Using DHCP. Note your subnet mask and router IP address.
Step2: on the iPhone -go to "settings" - Wi-Fi set to "on" and select: choose a network
Step 3: after selecting your wireless network change to static IP temporarly.
Step 4: clear IP address field go down to subnet mask and enter manually same with router Ip you saw on the pref pane.
Step 5: switch back to DHCP and renew

If you are prompted for a WEP switch to WEP ACII and preceed password with $. ..sometimes not required.

You may need to click "forget network" and turn off phone before proceeding with the above.
     
Fresh-Faced Recruit
Join Date: Jul 2007
Status: Offline
Reply With Quote
Jul 4, 2007, 03:05 PM
 
once all this is done you may want to turn off "ask to join networks"
( Last edited by byronS; Jul 4, 2007 at 03:09 PM. Reason: duplicate)
     
Fresh-Faced Recruit
Join Date: Jul 2007
Status: Offline
Reply With Quote
Jul 5, 2007, 05:43 PM
 
Originally Posted by rclay6612 View Post
Fixed it!! For me at least it was a DNS issue. The iphone was getting the router's ip on top of the dns address. I noticed the web pages hung up at the first contact when the IP address is usually looked up on the DNS. I deleted the dns numbers on the dhcp panel then looked up my DNS numbers on my router. (For a belkin, point your browser to 192.168.2.1) I typed in the DNS ip address manually in the dhcp panel and I'm back online. And this is after adding in WPA security.
I noticed this too and changed it. Still no joy. This is with a 3 netgear house. I've tried everything I know of.

I just came from a coffee shop and had no trouble surfing wi-fi on their network. So, it's not the phone.
     
Fresh-Faced Recruit
Join Date: Jul 2007
Status: Offline
Reply With Quote
Jul 5, 2007, 05:51 PM
 
Anyone know why I have 4 bars on every mac in my home but the iPhone gives me 1 bar. Occationally it will show 4 and then drop quickly back to 1. This is in anywhere in my house, even a foot away from one of my 3 new netgear routers. I so want to wi-fi...
     
Fresh-Faced Recruit
Join Date: Jul 2007
Status: Offline
Reply With Quote
Jul 6, 2007, 02:47 AM
 
Iphone users with verizon fios service try the following:

1. go to settings for wifi
2. select your network
3. select forget this network
4. go back to list of networks
5. select your network
6. instead of selecting wep password, select wep hex or ascii password
7. insert your password in the wep hex/ascii password with a $ sign preceding your password
8. select your network
9. you should see the wifi symbol at the top of your screen and it should stay there.
10. good luck
     
Fresh-Faced Recruit
Join Date: Jul 2007
Status: Offline
Reply With Quote
Jul 7, 2007, 01:13 AM
 
If your iPhone is having trouble connecting to the Internet using your home or office Wi-Fi wireless router, the solution may be to change the iPhone’s DNS settings.

In some cases, when connecting to a wireless router the iPhone incorrectly selects the network’s broadband modem to act as the DNS server. The broadband modem will not work as a DNS server with the iPhone though. Instead, your iPhone should use your wireless router as the DNS server, or a public DNS server such as OpenDNS.

I've posted much more on this here:

Change iPhone’s Wi-Fi DNS Settings to Connect to the Internet - AndrewEscobar.com
     
Fresh-Faced Recruit
Join Date: Jul 2007
Status: Offline
Reply With Quote
Jul 7, 2007, 08:29 AM
 
I noticed this problem yesterday, however mine is a tad different and after going through all the steps on Andrew's site I am still having no luck at home.

When I am at home i can only get the "E" icon even though the WiFi settings say I am connected to my home network (network is protected) and the signal is strong, When I am at either of two offices i frequent I get the WiFi icon in place of the "E" and the connection smokes. When I am at home I just get the "E", if my phone has been sitting for a few minutes and I go to unlock the EDGE icon is gone and the WiFi icon has appeared as soon as I unlock the phone the EDGE icon returns.

From what I can tell, this could be caused by my Router at home being D-Link and the ones in the offices are AirPort Extreme base stations?

I went through all the steps above and I can get it to ditch the EDGE icon for a Wifi one but I get errors when trying load pages and get email.

Any Ideas?
     
Fresh-Faced Recruit
Join Date: Jul 2007
Status: Offline
Reply With Quote
Jul 7, 2007, 07:14 PM
 
I tried all of the above with limited success, i.e. putting the $ sign in front of 128 bit hex got my wifi signal on, but Safari still couldn't find server. I bought a new router just to see if that'd help LinkSys WRT330N. Without encryption, iPhone connected no problem. With anything higher than WEP 64 bit, would not connect. I'm connected with 64 bit WEP. Hope Apple can come up with some firmware upgrades that will improve this.
     
Fresh-Faced Recruit
Join Date: Jul 2007
Status: Offline
Reply With Quote
Jul 7, 2007, 11:39 PM
 
Unfortunately, I am by no means an iphone expert. All I know is I've spent over three hours on the phone with apple and at&t trying to figure out how to get my wifi connection to work in my home. At first, I was told by at&t that I needed the mac password from my ISP for the iphone. I entered the mac key and that didn't work. I was then told by apple that I needed at 128 bit wep instead of a 64 wep. I tried that and it didn't work. Then we tried removing the wep all together and that didn't work either. So I went to another site and did some reading and saw the suggestion that I mentioned above and low and behold it worked and its been working ever since.
     
Fresh-Faced Recruit
Join Date: Jul 2007
Status: Offline
Reply With Quote
Jul 7, 2007, 11:45 PM
 
try this site for a better explanation. iPhone Wifi Tips | Any iPhone
     
Fresh-Faced Recruit
Join Date: Jul 2007
Status: Offline
Reply With Quote
Jul 11, 2007, 09:46 PM
 
Originally Posted by byronS View Post
As was mentioned there can be a conflict with wireless IP addresses when iPhone tries to connect to your wireless router.
Step 1: open your network pref pane and click one TCP/IP info. generally you should see Using DHCP. Note your subnet mask and router IP address.
Step2: on the iPhone -go to "settings" - Wi-Fi set to "on" and select: choose a network
Step 3: after selecting your wireless network change to static IP temporarly.
Step 4: clear IP address field go down to subnet mask and enter manually same with router Ip you saw on the pref pane.
Step 5: switch back to DHCP and renew

If you are prompted for a WEP switch to WEP ACII and preceed password with $. ..sometimes not required.

You may need to click "forget network" and turn off phone before proceeding with the above.
Ok, I did this and I now my wifi bars are on and it looks like i am getting a strong signal. However, when i go to youtube or the internet, there is not really a connection there. What gives here? Could i have entered some info in wrong? I tried entering in my IP, did not work. Then deleted it again and renewing (still no luck). I basically did this with each field. When i deleted IP Address, subnet mask, and DNS, nothing happened, and I was still "connected" with no internet. When i deleted the Router info, i got kicked back to edge. Is my router number my "Default Gateway" number? And once it connects to the router, how come i cannot get on the internet?
     
Fresh-Faced Recruit
Join Date: Jul 2007
Status: Offline
Reply With Quote
Jul 13, 2007, 01:04 PM
 
I had an old Dlink router model DI-514 (802.11b only) that had issues with internet connectivity on the iPhone. I tried all of the trouble shooting steps:
1. Hex/Acsii
2. $ in front of password
3. DNS settings deleted and/or with 4.2.2.2
4. reset the devices
5. update firmware on router
6. no secruity setting
7. and on and on

I would get one or 2 webpages and then it would not work on iPhone anymore. I have 5 computers and a Wii running off the D-link router and all seems ok (although my work VPN did not connect wirelessly only works when I hooked up directly to the router). So I thought it was time to replace the aging thing. The local Officemax had the Dlink WBR-2310 (802.11g) for sale for $40 so that is what I went with. And after the install, the iPhone worked perfectly. I did not change my settings from previous so I am still using 4.2.2.2 as the DNS setting though. I am also using the exact same security settings WEP 128 bit hex password. Since it works great for the last 2 days, I have not mess with the settings. I've just been enjoying youTube and sufing the web on the faster connection. I love the iPhone even more now.

Thanks for all for the troubleshoothing steps. I am surprise that apple has not release any official word on this issue. So if all else fails, replace your router.
     
Fresh-Faced Recruit
Join Date: Jul 2007
Status: Offline
Reply With Quote
Jul 14, 2007, 03:17 AM
 
Originally Posted by sailomb View Post
I had an old Dlink router model DI-514 (802.11b only) that had issues with internet connectivity on the iPhone. I tried all of the trouble shooting steps:
1. Hex/Acsii
2. $ in front of password
3. DNS settings deleted and/or with 4.2.2.2
4. reset the devices
5. update firmware on router
6. no secruity setting
7. and on and on

I would get one or 2 webpages and then it would not work on iPhone anymore. I have 5 computers and a Wii running off the D-link router and all seems ok .
Thanks for posting -- I have the same DI-514 and I've tried everything too. I even contacted D-Link tech support -- their response: "We suggest you to configure the setting made on the router to be set on the WiFi of your Iphone to make it work through the router". Ummmm, sure. It looks like it's time to dump the DI-514. Really, I should have dumped it long ago -- I've spent thousands on 2 desktops, 2 laptops, PS3, and an iPhone, so I suppose another $40 to replace my 5 year old router isn't too bad.
     
Fresh-Faced Recruit
Join Date: Jul 2007
Status: Offline
Reply With Quote
Jul 16, 2007, 08:34 PM
 
In general, the iPhone seems to pretty seamlessly pick up whatever wifi signals are in range. Two exceptions, though, my home and my office (wouldn't you know it). I just solved the home network issue. I had the iPhone configured exactly the same as my Mac, but it was unable to resolve addresses through the DNS (funny thing is that one of my neighbors has an unsecured wifi router, and it worked fine through that). Tried all the suggestions in this thread (rebooted the router, pointed the DNS address to the router) to no avail. Tonight, I put in the address for the freeDNS server, and it immediately started working. Search me why, but it now works.

The office issue seems to be a little deeper. None of the above fixes worked (well, I didn't reboot the router, since there are 100+ folks that depend on it), not even using freeDNS. But I can't get to manually-typed IP addresses, so there's something else happening there.
     
Junior Member
Join Date: Jun 2007
Status: Offline
Reply With Quote
Jul 16, 2007, 10:12 PM
 
Originally Posted by bullcreek View Post
In general, the iPhone seems to pretty seamlessly pick up whatever wifi signals are in range. Two exceptions, though, my home and my office (wouldn't you know it). I just solved the home network issue. I had the iPhone configured exactly the same as my Mac, but it was unable to resolve addresses through the DNS (funny thing is that one of my neighbors has an unsecured wifi router, and it worked fine through that). Tried all the suggestions in this thread (rebooted the router, pointed the DNS address to the router) to no avail. Tonight, I put in the address for the freeDNS server, and it immediately started working. Search me why, but it now works.

The office issue seems to be a little deeper. None of the above fixes worked (well, I didn't reboot the router, since there are 100+ folks that depend on it), not even using freeDNS. But I can't get to manually-typed IP addresses, so there's something else happening there.
For me $ sign worked in front of the password, did not have to do anything else. It's been working for a week now and it picks up WiFi Access Point automatically every time. Before that I tried DNS addresses and everything else. When I looked at router's log file I realized that it was simply refusing connection. After adding $ nothing else was necessary.
Before you do that on iPhone go to Settings/General/Reset and click on Reset Network Settings to start fresh.
     
Fresh-Faced Recruit
Join Date: Aug 2007
Status: Offline
Reply With Quote
Aug 12, 2007, 11:16 PM
 
Can someone please help me out?? Just got the Iphone yesterday, consider myself to be rather techy, and am super frustrated that I can't hook up to my wifi in my apartment. I have a TrueMobile 2300 by Dell for my router, a MacBook, and now an Iphone. I don't have my router set up with a password. The Iphone is recognizing the network, but the airport signal has yet to pop up on the screen even after I accept the network. I've tried turning off the router and the phone, have read all the forums on this wifi problem, and still can't figure it out. Because I don't have a password for the router, shouldn't the phone just recognize it and be online?? Edge seems to be the only icon I've had on there since I bought the phone. Seems that other people that have this problem just put the hex thing when prompted for the password. Again, because I don't have a password, I'm not even given the opportunity to do this. HELP!!! If someone could walk me through this like I was 5 years old, that'd be awesome.
     
Fresh-Faced Recruit
Join Date: May 2007
Location: Fort Worth, Texas
Status: Offline
Reply With Quote
Aug 13, 2007, 12:02 AM
 
I feel your pain. All of you. I, too, had great difficulty locking on the home wifi network, even though every hotel, and coffee shop I pass works. I got a new router and spent time with Apple support. (BTW, It is a given you have to put a dollar sign in front of the password on Macs.) Finally, when the update came I downloaded and BINGO -- no problem. This wasn't mentioned as a fix, and it may have been a coincidence, but at that point I made no other adjustments and everything wifi has worked fine since then.
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 05:27 PM.
All contents of these forums © 1995-2015 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2015, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2