Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Hardware - Troubleshooting and Discussion > iPhone, iPad & iPod > How to fix the iPod classic's Cover Flow?

How to fix the iPod classic's Cover Flow?
Thread Tools
Mac Enthusiast
Join Date: Jan 2007
Location: Amsterdam, NL
Status: Offline
Reply With Quote
Sep 22, 2007, 12:17 PM
 
I recently bought an iPod classic. It's been great so far, but I'm experiencing some problems with Cover Flow: Many albums appear more than once and it basically only affects the ones with more than one artist like this:

CD A
1 Artist A
2 Artist A featuring B
3 Artist A featuring C
4 Artist A
5 Artist A

or

CD B
1 Artist A
2 Artist B
3 Artist C
4 Artist D
5 Artist E

The first example would generate three separate Cover Flow covers, while the second will show five.

So my question is: Is there any way to fix this (in iTunes?) so the iPod classic's Cover Flow menu will recognize albums with multiple artist as one whole album, showing only one cover? Of course, I'd like to do so without giving all songs the same artist name.
     
Posting Junkie
Join Date: Feb 2005
Location: 888500128
Status: Offline
Reply With Quote
Sep 22, 2007, 02:06 PM
 
Does it do this in iTunes as well?
     
Professional Poster
Join Date: Sep 2000
Status: Offline
Reply With Quote
Sep 22, 2007, 02:12 PM
 
Turn on the compilation setting for the album.
     
Posting Junkie
Join Date: Feb 2005
Location: 888500128
Status: Offline
Reply With Quote
Sep 22, 2007, 02:51 PM
 
Originally Posted by rjenkinson View Post
Turn on the compilation setting for the album.
That would sort it under Compilations though.

Enter the proper album artist - e.g. if you've got, say, William Shatner's "Has Been", and every other song features somebody different as artist, then enter "William Shatner" as the album artist, and that's where it will be sorted - no need for the "Compilation" tag anymore (better reserve that for actual compilation albums).

Having no experience with the new iPods, I don't know if they might have a bug in this regard (I know CoverFlow in iTunes sometimes does weird things even if all the settings are right) - which is why I asked if the problem shows up in iTunes as well.
     
.Neo  (op)
Mac Enthusiast
Join Date: Jan 2007
Location: Amsterdam, NL
Status: Offline
Reply With Quote
Sep 22, 2007, 03:05 PM
 
Nope that's the weird part. For example the CD Rhythms Del Mundo: Cuba appears twelve times in the iPod Cover Flow list, yet only once in iTunes' Cover Flow/grouped with artwork mode view.



In most cases the CDs are already set as compilation, so that doesn't make any difference either.
     
Posting Junkie
Join Date: Feb 2005
Location: 888500128
Status: Offline
Reply With Quote
Sep 22, 2007, 03:19 PM
 
I'd consider it a bug, then.

Apple have been tweaking this stuff in iTunes as well, over the past few releases, so I'd chalk up the discrepancy to an upcoming feature fix release.
     
Dedicated MacNNer
Join Date: Aug 2004
Status: Offline
Reply With Quote
Sep 22, 2007, 04:23 PM
 
did you use the Album Artist field?
     
Posting Junkie
Join Date: Feb 2005
Location: 888500128
Status: Offline
Reply With Quote
Sep 22, 2007, 04:42 PM
 
Originally Posted by zerock View Post
did you use the Album Artist field?
That wouldn't explain a discrepancy between iTunes and the iPod, would it?
     
Professional Poster
Join Date: Sep 2000
Status: Offline
Reply With Quote
Sep 22, 2007, 04:45 PM
 
The discrepancy may be due to browsing by artist on the iPod and by album in iTunes.
     
.Neo  (op)
Mac Enthusiast
Join Date: Jan 2007
Location: Amsterdam, NL
Status: Offline
Reply With Quote
Sep 22, 2007, 05:07 PM
 
Originally Posted by rjenkinson View Post
The discrepancy may be due to browsing by artist on the iPod and by album in iTunes.
That could be the problem yeah. It's really annoying to be honest and it makes Cover Flow practically impossible to use.

Overal I think iTunes handles CDs with more than one artist poorly in Grouped with artwork view. The only way to make the tracks of one CD stick together while maintaining the correct track order (1, 2,3,4 and not 2,4,1,3) is to sort them by Album, rather than Album Artist or whatever.

In any case it would be nice to see this fixed.
     
Posting Junkie
Join Date: Feb 2005
Location: 888500128
Status: Offline
Reply With Quote
Sep 22, 2007, 05:19 PM
 
Need. More. CoverFlow. Preferences. On. iPod.

Hm.
     
.Neo  (op)
Mac Enthusiast
Join Date: Jan 2007
Location: Amsterdam, NL
Status: Offline
Reply With Quote
Oct 6, 2007, 09:29 PM
 
Apple fixed it with their latest firmware update (1.0.2).
     
Junior Member
Join Date: Dec 2006
Status: Offline
Reply With Quote
Oct 10, 2007, 05:28 PM
 
im still havin a similar probelm in iTunes. I spent hours last night perfecting my iTunes and averything, but there are still 1 or 2 albums that just show up repeatadly, maybe 3 or 4 times, even though all of the settings are exactly the same...
     
Fresh-Faced Recruit
Join Date: Nov 2007
Status: Offline
Reply With Quote
Nov 11, 2007, 02:29 PM
 
After a week of sorting and experimenting with my CDs, I have found that the Cover Flow is less flaky than I first thought. If used correctly it can naturally maintain two separate sorted lists. Here is the way it displays albums

(1) By artist and grouped under that by album name. Ensure that the Compilation flag is OFF - even for multi-CD boxed sets or "best of" type releases... I have never in my life touched that option but I have discovered it to be arbitrarily set to "ON" by iTunes importing. It guesses wrong.

I also place the 2-digit year at the front of the title so that albums are shown in the chronological order...
Bowie, David
69 Space Oddity
71 Hunky Dory
72 The Man Who Sold The World

What happens for the year 2000 and beyond? I have found that 4-digit year will work correctly. Strange. My guess is that internally the iPod sorts by entire number and not by digits as letters.

2002 Heathen (2 CDs)

... is correctly ordered after the other albums.

Remember, even for multi-CD boxed sets, the Compilation flag is OFF. But in iTunes make sure Disc Number 1 of 2 and 2 of 2 are correctly filled in.


(2) By Album title if the Compilation flag is ON. The Artist field is displayed beneath the title... for example
Enter the Dragon (1973)
Lalo Schifrin


I use this mode to place soundtrack CDs and compilation CDs at the end of the Cover Flow list.
Soundtrack Album names are the name of the movie and year of release, as in "Sound of Music (1965)" That's just my convention.

To further separate compilation albums I add "0" to the Album titles ... so that "0 Miramar Collection 1 '94" comes after the last soundtrack CD - "Zed and Two Noughts (1985)"

A setback to compilation albums is that the Artist shown will be picked from the first song in that album. As opposed to "various" or blank... it had to pick something.
     
Posting Junkie
Join Date: Feb 2005
Location: 888500128
Status: Offline
Reply With Quote
Nov 11, 2007, 04:53 PM
 
None of that is in any way necessary, nor does it solve the problems we are seeing.

Albums will be sorted chronologically if the "year" tag is filled in properly and you repeatedly click on the "album" column header until it shows "album by year".


The problem I'm seeing is a single album, say by CéU, completely correctly tagged (about a dozen times), no compilation tag set in any of the songs, no multiple versions of ID3 tags, album artist identical on all tracks, artist identical on all tracks, in fact ALL info (except track title) identical on all tracks, and STILL it shows up as four separate covers directly after each other in CoverFlow.
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 12:17 AM.
All contents of these forums © 1995-2015 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2015, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2