Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Hardware - Troubleshooting and Discussion > iPhone, iPad & iPod > iPod Touch WiFi problems

iPod Touch WiFi problems
Thread Tools
Junior Member
Join Date: May 1999
Location: Southern California
Status: Offline
Reply With Quote
Dec 7, 2007, 09:34 PM
 
I am getting errors connecting to WiFi networks with my iPod Touch. This had affected a Touch I got a couple months ago. Initially, the WiFi worked perfectly on my WEP network and several others. Then, one day, I couldn't get any WiFi. After standard troubleshooting steps (forget network & re-enter, reset network settings, restart, restore iPod, etc.), it still wouldn't work. I returned the iPod and bought another. At first it also worked perfectly on any WiFi network I joined.

But now I'm affected by the same issue. This time, I went to the router settings and saw that the router (a Linksys) had assigned the iPod Touch an IP address. Yet, in the settings pane on th iPod Touch, the iPod had no IP address. I just ahead and reset all network settings, forget the network, reset the update and still nothing. And this was recently after updating to 1.1.2 firmware.

Given that this has now happened to iPod Touches, I'm concerned that it may be an issue that is affecting others. Any suggestions? The error I get in Safari is "Safari can't open the page because it can't find the server."
Sign the petition to add the Jacknote to Macworld Boston!
     
Fresh-Faced Recruit
Join Date: Dec 2007
Status: Offline
Reply With Quote
Dec 8, 2007, 04:26 PM
 
I believe the answer lies with your DNS address needing the same address as your router. Try clearing the address in the DNS field in wifi settings and put in whatever the address is that is in your router field.

I kept getting Safari can't find a server until I tried doing this this morning and my Ipod's wifi is working fine now.
     
Forum Regular
Join Date: Oct 2007
Location: Pensacola, FL
Status: Offline
Reply With Quote
Dec 8, 2007, 07:08 PM
 
It sounds like the iPod Touch isn't really that great yet. I thought about getting one because I don't want to pay for data charges on the iphone but the price makes me not want to. If it doesn't work like it should all the time I'll hold off. I'd like more memory too. 16gb is not really enough to play a bunch of movies but whatever.
Bla Bla Bla
     
Senior User
Join Date: Dec 2002
Location: aurora
Status: Offline
Reply With Quote
Dec 9, 2007, 10:07 PM
 
The iPod Touch is ready for prime time and at 16GB that is more than enough storage. I have one movie, three short movies, and part of Season 3 of Lost on mine plus a music and photo library. The battery goes down after watching a couple episodes but that is only to be expected. I have the problem with WiFi also and will try your suggestion.
     
jrome  (op)
Junior Member
Join Date: May 1999
Location: Southern California
Status: Offline
Reply With Quote
Dec 9, 2007, 10:54 PM
 
FYI, I also started a thread at the Apple forums. Leave a note there if you're also having problems; if it's a general issue, I'd like to see Apple address. I'll have to see a genius next week.


Apple - Support - Discussions - iPod Touch will not connect to WiFi ...
( Last edited by jrome; Dec 9, 2007 at 11:01 PM. Reason: added url)
Sign the petition to add the Jacknote to Macworld Boston!
     
jrome  (op)
Junior Member
Join Date: May 1999
Location: Southern California
Status: Offline
Reply With Quote
Dec 11, 2007, 05:39 PM
 
I got home, and now it works on my wireless network and one of my neighbors (Netgear), but not the other (Linksys). Probably an issue with how the Touch is interacting w/ Linksys routers. Good thing those aren't very popular. *rolls eyes*
Sign the petition to add the Jacknote to Macworld Boston!
     
Fresh-Faced Recruit
Join Date: Dec 2007
Status: Offline
Reply With Quote
Dec 12, 2007, 11:38 PM
 
I used ipod touch without any problems, this occured when I upgraded my ipod touch to 1.12, it is really wired.
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 05:42 PM.
All contents of these forums © 1995-2015 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2015, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2