Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Hardware - Troubleshooting and Discussion > iPhone, iPad & iPod > iMessage/text message

iMessage/text message
Thread Tools
Fresh-Faced Recruit
Join Date: Dec 2009
Location: Columbus, OH
Status: Offline
Reply With Quote
May 11, 2012, 11:36 AM
 
For some reason, all the iMessages that my wife and I have been exchanging over the last 3 days are failing, and being sent as text messages. I terminated my text plan a while back, because nearly everyone I know uses an iOS device, so it wasn't cost-effective after the onset of iMessage. Now I'm dreading my next AT&T bill...

What causes this to happen? Is there a setting on one, or both, of our phones that we've inadvertently changed? Is AT&T messing with things? Is it an iOS problem? It might have coincided with the latest iOS software upgrade, but I'm not certain.

Anyone else experiencing this?
Andy • www.B3NN3TT.com
MacBook Pro 2.8 i7
MacPro 2.66 Quad Xeon
Mac Mini 1.83 Core 2 Duo
     
Professional Poster
Join Date: Jan 2003
Status: Offline
Reply With Quote
May 11, 2012, 01:59 PM
 
call up your phone company and have them reset the account.

worked for me!
     
Moderator
Join Date: Feb 2006
Location: on the verge of insanity
Status: Offline
Reply With Quote
May 11, 2012, 02:17 PM
 
This happens to me occasionally. It seems to be associated to signal strength when I am not on wi-fi.
I like my water with hops, malt, hops, yeast, and hops.
     
B3NN3TT  (op)
Fresh-Faced Recruit
Join Date: Dec 2009
Location: Columbus, OH
Status: Offline
Reply With Quote
May 11, 2012, 02:32 PM
 
Originally Posted by Rumor View Post
This happens to me occasionally. It seems to be associated to signal strength when I am not on wi-fi.
That thought did cross my mind, but it has happened at home, when I'm sitting 20 feet from my wireless router, as well as at the office, where 3G has always been more than adequate.

Amazing, exactly what is being "reset" in your call to the phone company?
Andy • www.B3NN3TT.com
MacBook Pro 2.8 i7
MacPro 2.66 Quad Xeon
Mac Mini 1.83 Core 2 Duo
     
Posting Junkie
Join Date: Oct 2005
Location: Houston, TX
Status: Offline
Reply With Quote
May 11, 2012, 04:48 PM
 
That is an issue with "automagic" services, you have no ability to debug when they break.
     
Senior User
Join Date: Nov 2005
Status: Offline
Reply With Quote
May 11, 2012, 05:59 PM
 
If you use Messages beta on your Mac, it could be related to that. It seems silly, but I had a problem with iMessage showing messages failing to be delivered, even though the recipient got the message.

Here's the thread over at Apple. Take a read, and if it sounds like this could be you, log out of and delete Messages beta from your Mac. I did, and iMessage started working again.

https://discussions.apple.com/thread...0&tstart=0
     
Professional Poster
Join Date: Jan 2003
Status: Offline
Reply With Quote
May 11, 2012, 08:25 PM
 
I'm on pay-as-you-go text, and ATT wasn't getting texts to me (except their notices that such-n-such is available, those texts always seem to get thru.)

When I call customer service, after trying to sell me the $20 texting package once again and getting refused once again, the rep just went in to "reset the account" and things worked after that.
     
Mac Elite
Join Date: Oct 2000
Location: Macfreak7
Status: Offline
Reply With Quote
May 12, 2012, 12:27 AM
 
This has happened to me in the past. I have iMessages linked with my cell phone # as well as email. Often people would complain about receiving iMessages thru my email and not phone#.

To fix this I turned iMessages off, turn the phone off and reinsert the sim card. Turn iMessages on again and it re-authenticates the number with Apple's servers. And that's it! It's fixed the problem for me a couple of times. I'm guessing the problem started when I removed the sim card to use on an iPad, but i'm not 100% on that.

Also, you could link an email ID to your iMessages in case you haven't already, as a fail safe.

HTH!
     
Addicted to MacNN
Join Date: Dec 1999
Location: Tampa, Florida
Status: Offline
Reply With Quote
May 12, 2012, 03:43 PM
 
Get iPhone unlocked and jump to other GSM provider. tMobile's wireless service comes bundled with customer respect as a standard feature.

I can't believe that AT&T can screw subscribers in the age of the unlocked smartphone
( Last edited by The Godfather; May 12, 2012 at 04:00 PM. )
     
Posting Junkie
Join Date: Oct 2005
Location: Houston, TX
Status: Offline
Reply With Quote
May 12, 2012, 04:10 PM
 
Originally Posted by The Godfather View Post
I can't believe that AT&T can screw subscribers in the age of the unlocked smartphone
That age has yet to arrive in most of the world.
     
Clinically Insane
Join Date: Nov 1999
Location: 888500128, C3, 2nd soft.
Status: Offline
Reply With Quote
May 13, 2012, 07:33 AM
 
Originally Posted by mduell View Post
That age has yet to arrive in most of the world.
Um...actually, the United States was the last country to get unlocked iPhones, AFAIK.

But yes, most providers that sell you a SIM-locked phone under contract will only unlock it once the contract is up.
     
B3NN3TT  (op)
Fresh-Faced Recruit
Join Date: Dec 2009
Location: Columbus, OH
Status: Offline
Reply With Quote
May 14, 2012, 10:11 AM
 
Originally Posted by frdmfghtr View Post
If you use Messages beta on your Mac, it could be related to that. It seems silly, but I had a problem with iMessage showing messages failing to be delivered, even though the recipient got the message.

Here's the thread over at Apple. Take a read, and if it sounds like this could be you, log out of and delete Messages beta from your Mac. I did, and iMessage started working again.

https://discussions.apple.com/thread...0&tstart=0
This is a possibility. I did install the Messages beta on both of my Macs at home, so if this doesn't straighten itself out today, I'll look into that.

Also, I just realized yesterday that I ran the iOS update on my iPhone, but my wife had not done so yet; you don't suppose that incompatibility had anything to do with it...? I'm going to make sure she's run the update tonight as well. Hopefully something works.
Andy • www.B3NN3TT.com
MacBook Pro 2.8 i7
MacPro 2.66 Quad Xeon
Mac Mini 1.83 Core 2 Duo
     
B3NN3TT  (op)
Fresh-Faced Recruit
Join Date: Dec 2009
Location: Columbus, OH
Status: Offline
Reply With Quote
May 14, 2012, 10:51 AM
 
And just to add another layer of obfuscation on top of all this -

I just received a series of texts from a friend this morning, which came through as proper iMessages. I then immediately sent a message to my wife's phone, testing whether the problem had magically rectified itself, and it went through as a text message.

So it would appear that it's a problem with HER phone, and not mine.

The first order of business will be to run the new iOS update on her phone after work today to see if that addresses anything.
Andy • www.B3NN3TT.com
MacBook Pro 2.8 i7
MacPro 2.66 Quad Xeon
Mac Mini 1.83 Core 2 Duo
     
B3NN3TT  (op)
Fresh-Faced Recruit
Join Date: Dec 2009
Location: Columbus, OH
Status: Offline
Reply With Quote
May 15, 2012, 08:48 AM
 
Well, no luck.

New iOS update run, and Messages Beta has been uninstalled on both of my Macs at home, and the text behavior still exists. Everything she sends OR receives refuses to accept iMessage, to anyone on iOS, not just me. And since everyone else she communicates with has otherwise perfectly-functioning iMessage behavior in every other circumstance, the problem is CLEARLY with her phone only, and not the iMessage service.

Short of doing a restore on the phone, anyone else have any thoughts?

EDIT: Macfreak7, I missed your post earlier. I will give that a shot today and see if that changes anything. Thanks.
Andy • www.B3NN3TT.com
MacBook Pro 2.8 i7
MacPro 2.66 Quad Xeon
Mac Mini 1.83 Core 2 Duo
     
Mac Elite
Join Date: Sep 2006
Location: Back in the Good Ole US of A
Status: Offline
Reply With Quote
May 15, 2012, 12:11 PM
 
[deleted my post.. had missed Macfreak7's suggestion]
     
B3NN3TT  (op)
Fresh-Faced Recruit
Join Date: Dec 2009
Location: Columbus, OH
Status: Offline
Reply With Quote
May 15, 2012, 02:48 PM
 
So get this.

I went into SETTINGS to turn iMessages OFF, and found it was already turned off - somehow. My wife doesn't even have a clue how to do it, so I'm pretty certain there's no way she was able to turn it off herself - but there is was.

Threw the switch, everything works as it should. No idea how it had been disabled in the first place.

Last place ya check, huh?
Andy • www.B3NN3TT.com
MacBook Pro 2.8 i7
MacPro 2.66 Quad Xeon
Mac Mini 1.83 Core 2 Duo
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 03:41 PM.
All contents of these forums © 1995-2015 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2015, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2