Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > News > Mac News > Still no fix for early 2009 iMac issue with graphics card

Still no fix for early 2009 iMac issue with graphics card
Thread Tools
MacNN Staff
Join Date: Jul 2012
Status: Offline
Reply With Quote
Mar 5, 2013, 08:18 PM
 
Some owners of early 2009 model iMacs that have upgraded to later versions of Snow Leopard, Lion or Mountain Lion have been reporting issues with the included Nvidia GeForce GT 130 video card without a response from Apple, according to a year-long support thread on the company's support website. The issue appears to center around a faulty kernel extension released late in the Snow Leopard updates that remains unfixed, and causes graphic glitches, crashes and even kernel panics when the graphics card is stressed, such as during games.

Of particular annoyance to the owners, TUAW.com reports, is that the issue does not appear when using Windows under Boot Camp on the same models, suggesting that the Windows driver is ironically superior to the present Mac driver. The thread has not garnered an exceptionally large audience, but this could be because the problem is only seen when using applications that graphically tax the iMac -- something few iMac owners tend to do on a regular enough basis to have it be noticed as a major issue. The problems with the card continue even to the present version of Mountain Lion -- though Apple has been withholding the latest version of Mountain Lion, the as-yet-unreleased 10.8.3, over for testing on (among other areas) graphics for an exceptionally long time and number of revisions (12 thus far). Users have in some cases reported that Apple has replaced the graphics card in order to fix the issue, but this solution has not always worked. Others have used fan-control programs to keep the graphics card better cooled, which seems to reliably mitigate the issue for most users. Though there is some hope that the next update to Mountain Lion may resolve the issue, in the meantime MacNN echoes TUAW's call for affected users to add their voice to the support thread to encourage Apple to resolve the issue permanently. Now that the root cause of the issue has been identified through diligent user investigation, the company should take on the challenge and repair the affected kernel extension, or offer to fix the issue at no charge for out-of-warranty owners.
     
Dedicated MacNNer
Join Date: Dec 2004
Location: West Michigan
Status: Offline
Reply With Quote
Mar 6, 2013, 12:12 PM
 
The symptoms described here are almost certainly heat-related. I've seen a LOT of hear-related video-card failures in Apple systems, both iMac and MacPro (the original 1900x cards had a heat-sync that clogged almost instantly with dust, causing overheating and then complete card failures once enough damage had been done). One thing I've found is that people sometimes install iMac systems where they do not get proper ventilation in the first place, which can add to the problems. If cranking up the internal fans, placing the system in a cooler area, or blowing cool air over the entire iMac with box-fan magically make the symptoms go away, then you'll have a clear picture that the problem you are having is heat-related. The only thing software might do in that case (other than crank up the fans) would be to prevent the GPU from running at full speed, thus limiting the heat (and performance) of the GPU. IMHO this is a design-flaw on Apple's part and should be remedied by Apple for free. Why Apple's attitude varies so much from customer to customer and from instance to instance I'll never know. They replaced my x1900 board twice, but refused to offer a permanent solution. (Now I run an "unsupported" AMD 6870, which works just fine. But Apple's solution was to continue to provide me with cards which would never be reliable and then eventually tell me to "take a hike".)
     
Fresh-Faced Recruit
Join Date: Jul 2013
Status: Offline
Reply With Quote
Jul 10, 2013, 10:12 PM
 
I think I made a comment under my old username (which I can't use anymore, drat!) just years ago about this very issue. Still no satisfaction. I have had it with Macs because of this problem. I have to reboot every hour when doing anything graphically intense , including just *using the finder* due to many custom icons.After a couple of hours, all my custom folders become invisible , and my image previews that have not disappeared become so blurry as to be unviewable. Standard previews are fine, but custom ones (such as from photoshop) are completely screwed up.
Because of this I have sworn not to get another Mac, have told others to avoid Macs, who, in turn have likely told others, again, the same thing. I wonder if Apple has taken this kind of thing into account, when completely ignoring the plight of early 2009 iMac owners...
     
Fresh-Faced Recruit
Join Date: Oct 2013
Status: Offline
Reply With Quote
Oct 21, 2013, 10:48 AM
 
     
Fresh-Faced Recruit
Join Date: Oct 2013
Status: Offline
Reply With Quote
Oct 21, 2013, 10:51 AM
 
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 05:57 PM.
All contents of these forums © 1995-2015 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2015, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2