Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Enthusiast Zone > Classic Macs and Mac OS > Firewire/USB Combo card not functioning!

Firewire/USB Combo card not functioning!
Thread Tools
Registered User
Join Date: Feb 2002
Status: Offline
Reply With Quote
Aug 27, 2002, 02:43 PM
 
Hi,

I recently purchased the usb firewire combo card listed below (from geniality maple technology):
USB 1.1 + IEEE 1394 Combo Card

--------------------------------------------------------------------------------

Parts NoˇG

GMUIP-04
Specification & FeatureˇG

1.32Bit PCI Rev2.1 Bus interface
2.Support OHCI (Open Host Controller Interface)
3.Support Plug and play and Hot swappable.
4.Each port over current protection.
FireWire
(1) Compliant with IEEE 1394-1995 & P1394a standards
(2) Two 6-pin FireWire root ports
(3) Maximum 400Mbps data transfer rates
(4) Maximum 4.5meters cable length
USB
(1) Compliant USB (Universal Serial Bus) 1.1 standards
(2) Two USB root ports
(3) Support full speed (12Mbps) and low speed(1.5Mbps) data transfer rates
(4) Provides 500MA output current per port
(5) Maximum 5 meters USB cable length.
Operating System Support:
Windows 98SE/ME/2000/XP
Mac OS 8.6 or higher

From the web site I was lead to belive that the card is functional with macintosh computers (the manufacturers have since confirmed this). I have an apple powermac 9500/200 running mac os 9.1 which has all the latest drivers and fully meets the usb/ firewire criteria.

However, when I plug in a usb zip 250 drive from work to test the card it fails to work at all. The drive turns on and accepts disks but the device simply does not mount on the desktop.

Apple system profiler reports the card in the pci slot as:

card type: pci
card name: pci bridge
card model: not avialable
card rom#: not available
card revision: 1
card vendor ID: 104c

The card has Opti Firelink written on a large chip on it plus the GM-tek name (GM-Tek ComboA Ver 1.2)

I've tried the apple USB adapter software (version 1.4.1 which is the latest I think) but it has not helped. Someone told me that my 9500 has PCI slots that are version 2.0 compliant whereas the combo card is PCI version 2.1 compliant which they reckon would explain why the card fails to work. I'm not sure as I thought PCI was backwards compatible.

This comob card thing just gets weirder! I took a VST USB smartdisk and a Lacie Firewire CDRW home from work today to test out the firewire ports. The VST smart disk failed to work at all on the usb ports and did not even show up on the system profiler. However, the Firewre CDRW worked a treat - even though it did not show up on the System profiler! I managed to burn a cd with no problems! This is sooo weird. I plugged in a firewire external hd which also did not show up on ASP but mounts and works perfectly! If I put a cd into the external firewire cdrw it comes up in ASP as SCSI ID 3! Even though the cdrw drive does not show up! If I then put a cd into the internal cd rom drive as well then it too shows up in ASP as SCSI ID 3!! I thought that this was impossible?

Finally, I tried an Epson printer (brand new USB) but that didn't work either - not even showing up in the Chooser or ASP.Do you think there is any chance that the USB ports on this combo might be damaged/nonworking?

Or maybe I just happen to be trying the USB devices that just don't work with PCI adapters?

This is really bugging me now.

If anyone can help I think we'd both (me and my mac) be greatful!!

thanx

spooky
     
Mac Elite
Join Date: Jan 2002
Location: Live at the BBQ
Status: Offline
Reply With Quote
Aug 28, 2002, 04:32 AM
 
it sounds to me like the card may have damaged USB components, or maybe there are some incompatibilities with your system, which is less likley. You can also check to see if you have all of the proper USB enabling extensions in your system folder. If you moved any extensions to the disabled folder or deleted them, you should move them back into the extensions folder and/or reinstall them from your OS 9 install disk. If your firewire/usb card came with software for the mac, you may need to install that, but it shouldn't be necessary if you have a proper 9.1 or later installation. Before sending the card in for a refund, make sure you have all of the proper software components in place (trying different configurations) and if it still doesn't work, send it back. Then get a MacAlly brand combo card. I have one and it works flawlessly, right out the box, no additional software (orangemicro makes goodfw/usb cards as well, I hear).

As far as the system profiler results you get, it only needs to detect the card and acknowledge the additional firewire and usb ports, not necessarily the devices attached to them (it will usually identify usb drives and some fw drives, but if doesn't i.d. them and they still work, there's nothing to worry about).
"Bill Gates can't guarantee Windows... how can you guarantee my safety?"
-John Crichton
     
Senior User
Join Date: Oct 1999
Location: Planet Earth
Status: Offline
Reply With Quote
Aug 30, 2002, 01:25 PM
 
I've been through two now on my PowerCenter 150.

1st one was from FireWireDirect. Didn't work at all
2nd one was from Adaptec. USB ports worked, not FW. Made the computer unstable.

I've got more to try...
---I'm on a low Microsoft diet.
     
Junior Member
Join Date: Jul 2000
Location: usa
Status: Offline
Reply With Quote
Sep 26, 2002, 09:38 PM
 
Yes, make sure you have the proper updates from both the manufacturer and Apple. My Orange Micro card had some initial problems until I downloaded the latest Firewire and USB extensions. The strange thing is that the Firewire doesn't show up on my System Profiler either but the ports do work as I've used to import some digital video.
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 02:09 AM.
All contents of these forums © 1995-2015 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2015, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2