Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Enthusiast Zone > Classic Macs and Mac OS > Printer driver won't load due to memory?

Printer driver won't load due to memory?
Thread Tools
Dedicated MacNNer
Join Date: Aug 2002
Status: Offline
Reply With Quote
Sep 10, 2002, 08:03 AM
 
I recently put in a larger hard drive in my rev B iMac with 256 MB RAM. My primary OS is 10.1.5 and I've gone through the extended routine of installing 9.1 from CD, updating to 9.2.1 via the ugrade CD, and then upgrading that to 9.2.2 via software update. From there, I installed 10.0 from the CD, 10.1 from that upgrade CD, and then 10.1.5 via Software Update. I then installed a separate OS 9.1 on it's own partition. Exhausting!

After 10.1.5, 9.2.2, and 9.1 were all installed and verified to work, I installed the drivers for my Lexmark Z42 printer on all three systems. As it had before, the X driver works fine but now the OS 9 driver for the Z42 will work in 9.1 but not 9.2.2. In the Chooser, when I click on the Z42 icon, I get an error message that the driver didn't load because the application (what application?) is out of memory. I tfurther instructs to allocate more memory via the Finder and if that doesn't work then re-install the driver.

First, no applications were running and second, I've re-loaded the driver about four times now. Interestingly, I get the same error message regardless of whether 9.2.2 is booted itself or is running inside of X. Of course, I had to have an app active in Classic to get to the Chooser that way but that's beside the point. Trashing the Z42 prefs made no difference.

What I haven't done is re-assign Classic to the 9.1 partition where I know the printer driver works. I'm not sure what this would prove anyway. What I'd like to avoid is starting all over again by re-installing OS 9 in the X partition with verifying that I can get the driver to load at each step of the upgrade road.

One other piece of critical info: On my previous HD, I had the same conceptual setup with X, 9.2.2, and 9.1 and the printer worked fine any which way I used it.

Any thoughts to share before I commit myself to this task? TIA
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 03:35 PM.
All contents of these forums © 1995-2015 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2015, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2