Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Enthusiast Zone > Classic Macs and Mac OS > Opening any of my apps or control panels gives me error # -2817.

Opening any of my apps or control panels gives me error # -2817.
Thread Tools
Forum Regular
Join Date: Mar 2000
Location: DC metro area.
Status: Offline
Reply With Quote
Apr 15, 2004, 06:22 AM
 
For about the past two weeks, I have been getting error messages saying that “The application [insert application or control panel name] could not be opened because an unexpected error occurred (-2,817)” whenever I have been using the Mac for a while and then try to open a new application. I have been fixing it by restarting the Mac, but that is not an acceptable solution, especially because the problem reoccurs after an hour or so.

Does anyone know what’s up with this and/or know how to fix it for good?

The setup is a dual-USB iceBook (2001) running system 9.2.2 with 640MB RAM. The HD has 18.63 GB of space of which 14.81 GB is being used and 3.81 GB is available.

Thanks.
     
Clinically Insane
Join Date: Oct 2000
Location: Los Angeles
Status: Offline
Reply With Quote
Apr 16, 2004, 02:12 AM
 
I'm a bit too lazy to pull out my old Mac troubleshooting tomes. Is there any reason in particular why you're running OS 9 on a perfectly OS X capable machine?

"The natural progress of things is for liberty to yield and government to gain ground." TJ
     
Mac Elite
Join Date: Sep 2001
Location: Chico, CA and Carlsbad, CA.
Status: Offline
Reply With Quote
Apr 16, 2004, 05:38 PM
 
Originally posted by Forbodium:
For about the past two weeks, I have been getting error messages saying that “The application [insert application or control panel name] could not be opened because an unexpected error occurred (-2,817)” whenever I have been using the Mac for a while and then try to open a new application. I have been fixing it by restarting the Mac, but that is not an acceptable solution, especially because the problem reoccurs after an hour or so.

Does anyone know what’s up with this and/or know how to fix it for good?

The setup is a dual-USB iceBook (2001) running system 9.2.2 with 640MB RAM. The HD has 18.63 GB of space of which 14.81 GB is being used and 3.81 GB is available.

Thanks.
Sounds like a disk error to me. I think all the Norton haters live in the Mac OS X forums... so I'd usually run Norton on the disk. If you don't own a Norton, try booting from a Mac OS 9 install CD and running Disk Repair, hopefully you'll find some good stuff.

"In Nomine Patris, Et Fili, Et Spiritus Sancti"

     
Senior User
Join Date: Mar 2000
Location: A mile high, Denver, Colorado, USA
Status: Offline
Reply With Quote
Apr 17, 2004, 12:25 PM
 
Who are the Brain Police?
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 08:32 AM.
All contents of these forums © 1995-2015 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2015, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2