Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Enthusiast Zone > Classic Macs and Mac OS > ActiveX

ActiveX
Thread Tools
Grizzled Veteran
Join Date: Jun 2001
Status: Offline
Reply With Quote
Jun 30, 2004, 11:28 PM
 
What is it and how do I install it so I can use google mail in OS9.1?
     
Addicted to MacNN
Join Date: Oct 2001
Location: BFE
Status: Offline
Reply With Quote
Jul 1, 2004, 06:50 AM
 
It is PC only and does not exist for OS9.

I'm a bird. I am the 1% (of pets).
     
Mac Elite
Join Date: May 2001
Location: Cambridge UK
Status: Offline
Reply With Quote
Jul 2, 2004, 04:20 PM
 
Google mail doesn't (necessarily) use ActiveX - Safari and Firefox are able to load the site fine, and neither support ActiveX.

Maybe it tries to use ActiveX if you are using IE.
     
Clinically Insane
Join Date: Oct 2000
Location: Los Angeles
Status: Offline
Reply With Quote
Jul 7, 2004, 02:50 AM
 
ActiveX is a major security risk, so much so that MSN's The Slate magazine actually recommended that Windows users switch to Firefox. As others have stated, Safari is officially supported by gmail.

"The natural progress of things is for liberty to yield and government to gain ground." TJ
     
Dedicated MacNNer
Join Date: Nov 2003
Location: sleep
Status: Offline
Reply With Quote
Jul 29, 2004, 03:20 AM
 
I used gmail on OS 9.1 with Mozilla 1.2.1 until the other night when I deleted the ActiveX extension. After that it stopped working. But it worked last night for a few minutes. Now it doesn't. Maybe they are tweaking the code over in google HQ or something else is screwy.

And when gmail loads you get the red loading rectangle and just end up with a blank page. I checked the source on that page and found...

<title>Gmail</title><noscript>Javascript is disabled in your browser. Gmail requires Javascript to be enabled in order to operate.<p>To use Gmail, enable Javascript by changing your browser preferences.<p>After enabling Javascript, <a href=/gmail>try again</a>.</noscript><script>var fs_time=(new Date()).getTime();var testcookie = 'jscookietest=valid';document.cookie = testcookie;if (document.cookie.indexOf(testcookie) == -1) {top.location = '/gmail/html/nocookies.html';}document.cookie = testcookie + ';expires=' + new Date(0).toGMTString();var agt = navigator.userAgent.toLowerCase();if (agt.indexOf('msie')!= -1 && document.all) {var control = (agt.indexOf('msie 5') != -1) ? 'Microsoft.XMLHTTP' : 'Msxml2.XMLHTTP';try {new ActiveXObject(control);} catch (e) {top.location = '/gmail/html/noactivex.html';}}</script><frameset rows='100%,*' border=0><frame name=main src=/gmail/html/loading.html frameborder=0 noresize scrolling=no><frame name=js src=/gmail?view=page&name=js&ver=e148456b67e168d9 frameborder=0 noresize></frameset>

With the relevent part being: {top.location = '/gmail/html/noactivex.html';}

Let me re-install IE and see if that gets back the ActiveX extension. If it does I will post it..

Oh, and javascript is enabled. I think that is my pop-up blocker at work.
     
Mac Elite
Join Date: Apr 2002
Location: Illinois
Status: Offline
Reply With Quote
Aug 2, 2004, 01:05 AM
 
Enable JavaScript...
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 05:21 AM.
All contents of these forums © 1995-2015 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2015, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2