Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Enthusiast Zone > Classic Macs and Mac OS > AppleScript and Quake 2

AppleScript and Quake 2
Thread Tools
Fresh-Faced Recruit
Join Date: Jan 2000
Status: Offline
Reply With Quote
Jan 22, 2002, 10:45 PM
 
I posted in the Games forum, but nobody seemed to care, so I hope some AppleScript folks can help.

I'm trying to setup my old 7500 w/ 132MHz 604 as a Quake 2 dedicated server. I'd really like to have it start the server when the Mac boots.

I wrote an AppleScript to start the server:

<BLOCKQUOTE><font size="1"face="Geneva, Verdana, Arial">code:</font><HR><pre><font size=1 face=courier>
tell application <font color = red>"Quake <font color = blue>2</font>"</font>
run params <font color = red>"+set dedicated <font color = blue>1</font>; +set game rogue; +exec RogueServer.cfg"</font>
end tell
</font>[/code]

I then added an alias to the script in my Startup Items folder.

When I boot the Mac, it starts regular Quake 2, but not in dedicated server mode, and not running the Rogue expansion. But, I can quit Quake 2, and then double-click the alias, and it starts the dedicated server just fine. The only problem here is that Quake 2 is not the foreground app; I have to switch to it.

I also wrote the following script to start the Rogue expansion so I wouldn't have to hold down Option and type in the command line parameters:

<BLOCKQUOTE><font size="1"face="Geneva, Verdana, Arial">code:</font><HR><pre><font size=1 face=courier>
tell application <font color = red>"Quake <font color = blue>2</font>"</font>
run params <font color = red>"+set game rogue"</font>
end tell
</font>[/code]

When I double-click this script, it starts Quake 2 with the Rogue expansion, but again, the Quake 2 app is not the foreground app. I have to switch
to it via Alt-Tab.

It's a PowerMac 7500 with a 132MHz 604, MacOS 9.1, 96MB of RAM. I'm running Quake 2, v3.20 with the Ground Zero expansion pack by Rogue Entertainment. I've also got the gameppc.lib files for the expansion from Logicware.

Any ideas?

The Quake-2-not-being-the-foreground-app thing is really annoying now, because it seems that I can still play Quake 2 even if the Finder is the foreground app. When I quit Quake, I find that all my icons have been renamed to eeeeeeeddddddssssssfffffff because that's what I'm pressing in the game!

Thanks,

Gron-gron
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 11:19 AM.
All contents of these forums © 1995-2015 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2015, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2