Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Enthusiast Zone > Classic Macs and Mac OS > OS 9 won't update

OS 9 won't update
Thread Tools
Forum Regular
Join Date: Jan 2001
Location: New England
Status: Offline
Reply With Quote
Feb 1, 2002, 12:18 AM
 
Hoping for some help from people more tech-saavy than I am...

I've got an original Bondi iMac. I was running 9.2 yesterday when the whole system froze, and the long and short of it is I had to do a clean install of OS 9 from CD to get things back. I dragged over some extensions, sound files, etc., from the old (9.2) system folder to the new one. Then I tried to run my OS 9.1 installer. I got an error message that said something like "This installer is not allowed to install over a newer version of MacOS on your computer."

What's the deal? How can I fix it? I want my OS 9.2 back.

Thanks for your advice,

NewsHound
Exit, pursued by a bear.
--'The Winter's Tale,' Shakespeare
     
Junior Member
Join Date: May 2001
Status: Offline
Reply With Quote
Feb 1, 2002, 02:15 AM
 
Kill the 9.2 system file and try again.
     
Forum Regular
Join Date: Jan 2001
Location: New England
Status: Offline
Reply With Quote
Feb 1, 2002, 03:27 AM
 
Originally posted by Worboren:
<STRONG>Kill the 9.2 system file and try again.</STRONG>
It's already gone. Didn't help.
Exit, pursued by a bear.
--'The Winter's Tale,' Shakespeare
     
Junior Member
Join Date: May 2001
Status: Offline
Reply With Quote
Feb 1, 2002, 06:02 AM
 
Hmm... perhaps try trashing the whole "Previous System Folder" with 9.2.2 (don't empty the trash), hopefully the installer will stop seeing it.

Another option: trash OS 9, clean install again, update to 9.1 (or whatever) and then drag over your prefs, extensions etc from the old 9.2.2.
     
Clinically Insane
Join Date: Apr 2000
Status: Offline
Reply With Quote
Feb 1, 2002, 08:15 AM
 
Don't go to 9.2. Get the 9.1 full install and stay there. If you can't, stay at 9.04.

If you must... for Classic or whatever... do this.

Launch the updater, and proceed as far as possible. Just before hitting start, remove the Finder, System, MacOS ROM and System Enabler from your System Folder.

Go back to the installer and hit start.

Voila.


If that doesn't work (it will), boot sans extensions too.

[ 02-01-2002: Message edited by: Cipher13 ]
     
Forum Regular
Join Date: Jan 2001
Location: New England
Status: Offline
Reply With Quote
Feb 2, 2002, 12:15 PM
 
Cipher,

Thanks for the tip. It worked great, and I'm running 9.1 just fine -- well, almost. Sherlock didn't work under 9.0 after the crash, and it still doesn't work. Any further advice?

But thanks again for getting me back on the OS update track!
Exit, pursued by a bear.
--'The Winter's Tale,' Shakespeare
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 09:55 AM.
All contents of these forums © 1995-2015 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2015, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2