Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Enthusiast Zone > Classic Macs and Mac OS > DHCP Wierdness

DHCP Wierdness
Thread Tools
Reply With Quote
Jun 14, 2000, 05:15 PM
Having a problem with DHCP on a few macs in my office. The Macs in question are running various versions of the Mac OS, including 7.6.1 and 8.x. The DHCP Server is on NT Server 4 (sp5).

I had previously been using static IP addressing for our mixed Mac/PC office, but recently switched to DHCP to simplify my life. Instead, it is making it very complicated. All of the PCs, and most of the newer Macs are handling it just fine, but some of the older Macs have started to give me a problem.

After about two weeks of running smoothly, four of the oldest machines have started to give IP conflict errors. It seems that they are all trying to use the same IP address. This IP, coincidentally, is the lowest available IP address (according to my DHCP server), and is not actually leased by ANY of them.

My working theory is that the Mac gets a lease offer, takes it, and never sends a message back to the DHCP server letting it know that it accepted the lease.

Any ideas on solutions? I have tried wiping out the TCP/IP, Appletalk and, Appleshare prefs, then restarting and resetting everything. Didn't work.

Any other ideas?


Torkel Spindler
Reply With Quote
Jun 15, 2000, 11:46 AM

Waht version(s) of MacOS and OpenTransport do you have on the faulty machines??

Older versions of OpenTransport (before 2.0) had these problems.

-Torkel Spindler
Reply With Quote
Jun 15, 2000, 12:11 PM
We have also been experiencing a similar problem. We had a few current Macs (8.5) that were having IP problems on a DHCP, we moved them to static IPs and they were fine. We replaced the DHCP, and now those same Macs are having problems with the static IPs. This really doesn't make any sense. I think we're running the latest OpnTx.
Reply With Quote
Jun 15, 2000, 01:33 PM
Originally posted by Torkel Spindler:
What version(s) of MacOS and OpenTransport do you have on the faulty machines??
Actually, we are running OS 7.6.1 and 8.1 on the offending machines, and it looks like they are running either v.1.2 or 1.3.1 of Open Transport.

I wouldn't mind upgrading them to a higher OS (which I think would solve the problem), but they are really old machines (6116s and 4400s) which are scheduled for retirement in the next few months, and don't have much RAM. I'd prefer not to have to upgrade the memory and OS to solve this problem.

Having said that, I have done a bit of searching around and it seems that Open Transport v.2.0 and higher is built with a newer OS in mind. Is there a way to install a newer version of Open Transport on these older machines without upgrading the OS? If so, I have not found it yet.



[This message has been edited by cameronc (edited 06-15-2000).]
Hans M Aus
Reply With Quote
Jun 15, 2000, 11:45 PM
There is an informative article in the Apple Tech Info Library:

Open Transport: DHCP Client Behavior
Article ID: 58372
Created: 5/12/99
Modified: 4/20/00

We use Vicomsoft's DHCP 6.6.2 server and had a similar problem with previous versions. A client would complain about a duplicate address which was always the same client's own IP address. The problem seemed to occur whenever the client needed to renew the IP lease but couldn't reach the server within a very short, critical time period; the client lost sync with the server. One cause of the network noise problem turned out to be another client which was connected to the same multiport repeater as the DHCP server. We reduced the problem by connecting the DHCP server directly to its own switch port in the network.

The DHCP 6.6.2 server PINGs the network with a candidate IP address until a free IP is found. The clients haven't complained about a duplicate address problem since we installed version 6.6.2 several months ago. I wish that the server had a log file where I could see how often the PING finds a duplicate IP.

Forum Regular
Join Date: Jun 2000
Location: Freiburg
Status: Offline
Reply With Quote
Jun 16, 2000, 06:17 AM

On the Macs that receive the same or wrong IP address, check the AppleTalk control panel. On an older MacOS, AppleTalk automatically switches to the printer port (LocalTalk) when a problem is detected on the network. The fact that several Macs are receiving the wrong address suggests that the client is not communicating with the DHCP server.
Cheers, Hans M. Aus, W├╝rzburg,
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Privacy Policy
All times are GMT -4. The time now is 02:18 PM.
All contents of these forums © 1995-2015 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2015, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2