Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Enthusiast Zone > Classic Macs and Mac OS > Finder memory size keeps on expanding

Finder memory size keeps on expanding
Thread Tools
Steve Johnston
Guest
Status:
Reply With Quote
Jan 28, 1999, 03:27 PM
 
I have OS 8.5.1 and Nortons DD 4.01, I can leave my Mac unattended all day only to find the finder memory has bloated to +64MB. Also Filesaver can not run full check (on shut down) as it says that the disk is in use.
     
Marc Norman
Guest
Status:
Reply With Quote
Feb 1, 1999, 02:09 PM
 
What are your memory settings? Is Virtual Memory on? What is your cache size? Those two factors affect your Finder's memory the most.

Marc
     
Steve Johnston
Guest
Status:
Reply With Quote
Feb 2, 1999, 01:46 AM
 
Virtual memory is off and cache is set to default (2048K)

steve
     
jofo
Guest
Status:
Reply With Quote
Feb 2, 1999, 07:30 PM
 
This isn't an answer to the cause exactly, but the sharing of an observation... I have a 32MB Ram iMac which uses 14.5MB for running the system. I feel this is inexplicably high, but better than the 34MB the system uses when I turn Virtual Memory off! My virtual is currenly set at min. Effectively I am gaining nothing, but for the recapturing of nearly 20MB that I lose when it is set to "off" I would LOVE to know what is going on here. I have installed al available updates. When I receive the new Norton Utilities (one that works with this new system) I hope to find a real solution.
     
scott
Guest
Status:
Reply With Quote
Feb 6, 1999, 03:53 PM
 
Steve -- for your problem, I have no idea whats going on. I would contact Symantec and see if they have any idea, since Disk Doubler seems to be the variable in that equation.

It is normal for the System partition to grow substanially during normal use, as the Mac OS uses "shared libraries". Shared libraries are bits of code that get used by several applications at once to conserve resources. However, the memory that shared libraries consume will almost always manifest in the System memory partition. It's nothing to worry about.

Jofo - Although some people have religious disputes about this, it really is best with the newer versions of Mac OS to have virtual memory on. In the past, virtual memory would only be used if Mac OS ran out of real RAM. That is no longer the case. In fact, having VM on actually reduces the amount of real RAM that applications require to launch.

This is a good idea in particular with the iMac and Blue and White G3s, as they use a new type of Macintosh ROM (NewWorld ROM), that loads itself into RAM. This makes the machine faster, but also takes more memory. Turning on VM significantly reduces this side effect, however. In fact, I would recommend turning VM up to 64MB on a 32MB iMac.

- Scott

------------------

--
Scott Stevenson
Contributing Editor,
MacN
     
crocodial
Guest
Status:
Reply With Quote
Feb 7, 1999, 01:37 AM
 
I have been using VM and Im not sure I like it. It reduces the demand for memory, most notably in the system software, but it leaves a shadow behind sometimes, especially when I am on the web. If Ive been on a page for a while and I go to hide the window or close it, it closes but, it leaves the image behind for a split second. Understand? I hate it. I have an iMac runnning with 96 MB RAM and i have the VM set to 97. Ive had it up to 150 MB but, it was the same problem. Any advice?
     
Marc Norman
Guest
Status:
Reply With Quote
Feb 7, 1999, 10:39 PM
 
Croc, try fiddleing with your browser's cache settings, that may have an impact on your prob. As for VM and cache size, try setting the disk cache up one notch and VM to just one over the physical RAM size. Programs will load faster and your RAM requirements will drop into the ground.
     
MonkeyNinja
Guest
Status:
Reply With Quote
Feb 9, 1999, 11:55 AM
 
I was reading the problems that the Guys in the other posts were experiensing and I started thinking about virtual memory.
I have a G3 266 with 256mb RAM, with vm turned off and the cache at its default.
My question is, Should I be using vm at the minimum setting so the requirements fall a bit down or don't I need vm with that amount of RAM.
     
Marc Norman
Guest
Status:
Reply With Quote
Feb 12, 1999, 06:26 PM
 
I think you should turn on VM to 258, you will see an decrease in loading times.
     
Ellis D Trails13
Guest
Status:
Reply With Quote
Feb 13, 1999, 10:34 PM
 
Here is the only cure>Use RamDoubler 8, set 'Advanced' controls to "Hold System Heap", and your Memory Creep problem will disappear. I guarantee it.
     
Mac Elite
Join Date: Oct 1999
Location: near Boulder, Colorado
Status: Offline
Reply With Quote
Feb 27, 2000, 04:29 PM
 
first off....OS8.5.1 has a documented Memory leak...upgrade to 8.6 at least.
second, if you only have 32 Mb RAM, buy more, it's less than a dollar a Mb now..in the mean time, with 32 real, set VM to 64, don't go much higher than double your real RAM. get at least 96Mb RAM for modern use, preferably 128+, i have 208 Mb and sometimes i have to quit apps.
third, be aware that RAM fragments just like a hard drive...try to quit apps in the same order you open them to reduce fragmentation. i have also had success with a combination of MacOS Purge, followed by a "force quit" of the finder, to defrag RAM...otherwise, just hit "Restart"

PM8500/G3-454 1Mb L2@227
OS9/OS8.6
208Mb interleaved EDO RAM...NO VM
ATi Rage Orion
Acard ATA66 PCI w/ Maxtor 20.5Gb
IBM 1Gb SCSI int HD, Plextor 12/20 var spd CD-ROM, Plextor 8 x 20 CDR on the way, zip 100, jaz 1Gb, HP c1716T magnet-optical 2X (1.3Gb/ cart) HP IIcx scanner, Nikon LS1000
Yamaha YST-M50 speakers

[This message has been edited by zac4mac (edited 02-27-2000).]
     
matt.lenkowsky
Guest
Status:
Reply With Quote
Mar 28, 2000, 11:30 PM
 
ím running 8.6 on a PB 99, and have a similar serious problem with memory leakage occurring in strange circumstances.
The memory required to run system files starts at around 23-25 megs. Then it slowly grows, up to 45 megs; I recognize that shared mem use might be occurring, but I was at 45 with just IE5 and Audion running besides the finder.
Oddly enough, it also seems to get better at strange times. Any given moment it might drop 10-15 megs. Also, whenever I OPEN programs the problem alleviates a little bit (at least this is the case with Netscape (though not Word). Quitting them makes it worse.
I run Ram Doubler 8 w/ Hold System Heap chosen; it doesnít seem to make any difference.
Anyone have any ideas what my problem is?

Sorry about the snafu -
I'm a newbie.

Thanks,
Matt Lenkowsky
     
Professional Poster
Join Date: Mar 1999
Status: Offline
Reply With Quote
Mar 28, 2000, 11:48 PM
 
taking a stab in the dark... have never heard of or seen the extreme case you describe, 'dropping 10-15 meg' at any given time...

bad RAM?

maybe try deleting the Finder pref's, System pref's, Memory pref's, and why not toss these too:
Apple Menu Options pref's
ASLM pref's
Energy saver pref's
MacOS pref's
TSM pref's
and restart
     
matt.lenkowsky
Guest
Status:
Reply With Quote
Mar 29, 2000, 09:22 PM
 
I followed your instructions to the t, and it seems to have done the trick - Sys. ram use stable ca 20-25 megs, and no sudden changes.
many thanks.
matt
     
exa
Grizzled Veteran
Join Date: Mar 2000
Status: Offline
Reply With Quote
Apr 3, 2000, 09:11 PM
 
But isn't it true that virtual memory slows down the computer? I've noticed under macbench that I loose a whole 200 points during cpu benchmarks. Any way around this loss in performance (also noticable in real time, such as when you have system sounds on, you hear more of those sounds when running the mouse through a menu without virtual mem rather than with it on)
     
mickeysquid
Guest
Status:
Reply With Quote
Apr 4, 2000, 10:41 AM
 
I don't know if this applies to you or not, but many "disk is in use" errors can be due to file sharing. Turn off file sharing and see if your Filesaver problem goes away.
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 02:38 AM.
All contents of these forums © 1995-2014 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2014, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2