Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Enthusiast Zone > Classic Macs and Mac OS > Remote Access reports "connecting at unknown speed"

Remote Access reports "connecting at unknown speed"
Thread Tools
Fresh-Faced Recruit
Join Date: Dec 1999
Status: Offline
Reply With Quote
Mar 7, 2000, 10:30 AM
 
GV external modem, GV90/flex script, G3/300, Netscape 4.72. Again, one of those things that occur out of nowhere: Remote Access no longer gives me the connection speed, e.g., "connecting at 45333..." etc., but "connecting at unknown rate..." instead. I've reset the modem, but no luck.
     
Bitt
Guest
Status:
Reply With Quote
Mar 9, 2000, 01:28 PM
 
Same problem, same model GV modem on 2 different Macs at 2 separate locations. Started within the past few days. What could this be?
     
pkkc
Guest
Status:
Reply With Quote
Mar 9, 2000, 01:30 PM
 
This problem happens on my PowerMac 9500 with Geoport Telecom Adaptor as well once I have upgraded the OS to MacOS 8.5. I remember that I have seen this mentioned in MacUser UK and believe it comes from the modem script file.
     
Spike
Guest
Status:
Reply With Quote
Mar 9, 2000, 02:03 PM
 
I also have this problemwith a GV 56k USB modem but it has always doneit with Remote Access. I downloaded the latest Modem Scripts from GV's site but it made no difference. Sent about 6 e-mails to their tech support but they never answered me!!

IF anyone has a fix then let me know!

Cheers,

Spike
     
Robin Redbreast
Guest
Status:
Reply With Quote
Mar 9, 2000, 03:05 PM
 

For once, I think I know the answer. I have a GV internal of the same sort in a G3 400Mhz B & W. I trustingly installed the GV software which includes a global fax software thingie I never use. It was my first mac & a new computer. I had never used a Mac before, so I assumed the odd connecting at unknown speed through Netscape 4.3 & later 4.5 was normal. Then, when I was having some other sorts of problems, some suggested looking up & disconnecting the fax software. I did. Low & behold, Remote access suddenly started telling me what speed I was telecomming at for the very first time in addition to apparently fixing the problem I was trying to solve. (I admit, I probably never set up the fax software by filling in the blanks. As I said, I was a new user & had not experience or need of it.) My suggestion is: go into the Extentions Manager & turn the GV fax software & related Control panels firmly to the Off positioin. At worst, you will waste a little time. At best, It might fix your problem.
Robin Redbreast
     
Forrest Johnson
Guest
Status:
Reply With Quote
Mar 9, 2000, 03:24 PM
 
I had the same problem with my G4/450. I changed the modem to Apple Internal 56k Modem V90 and got the connection speed back. It seems to work as well as the default GV modem selection.
     
BrittB
Guest
Status:
Reply With Quote
Mar 9, 2000, 07:34 PM
 
Hi All, when the modem reports that it is connecting at an unknown speed this is not an error. What is really happening is that the modem has negotiated two different speeds with the host, one for upload, another for download. This happens sometimes on all computers, nothing to worry about.
     
Flatliner
Guest
Status:
Reply With Quote
Mar 10, 2000, 09:58 AM
 
I experienced this yesterday after flashing my external Zoom modem to V90.
I found that selecting "use verbose logging" in the ARA options fixed it.
     
pkkc
Guest
Status:
Reply With Quote
Mar 12, 2000, 11:50 PM
 
Crack it!

This is nothing wrong with your modem and system installation, just an "Unaccounted for case in a switch statement"! (C programmers may know what I mean) That is, the modem script file doesn't what number to print out in your connection status box. For example, in my modem (GeoPort), it doesn't know what number to print when it is connected at 33.6 kbps, therefore it can only use "Communicating at an unknown rate".

Part 1...
     
pkkc
Guest
Status:
Reply With Quote
Mar 12, 2000, 11:52 PM
 
If you open the modem script of the modem in question, using text editor such as BBEdit, somewhere in the script (I use my GeoPort/Express Modem's script as an example) you can find the following lines:

<PRE>
matchclr 1 40 "2400\13"
matchclr 2 40 "2400/"
.
.
.
matchclr 14 51 "28800"
</PRE>

If you are using a GeoPort adaptor like me, which can connect at 31.2 kbps and a maximum of 33.6 kbps as well, add the following lines after the one with 28800, if they are not there already:

<PRE>
matchclr 15 52 "31200"
matchclr 16 53 "33600"
</PRE>

the first and second numbers 15, 52 and 16, 53 are just consecative numbers from the orginal lines above.

Part 2...
     
pkkc
Guest
Status:
Reply With Quote
Mar 12, 2000, 11:53 PM
 
Then scroll down a little bit until you have reached the following lines:

<PRE>
@LABEL 51
note "Communicating at 28800 bps." 2
CommunicatingAt 28800
jump 70
!
@LABEL 59
note "Communicating at an unknown rate." 2
jump 70
</PRE>

Just like a jump in BASIC, add some more lines so that the script can tell us the correct connection speed, and this will become:

<PRE>
@LABEL 51
note "Communicating at 28800 bps." 2
CommunicatingAt 28800
jump 70
!
@LABEL 52
note "Communicating at 31200 bps." 2
CommunicatingAt 31200
jump 70
!
@LABEL 53
note "Communicating at 33600 bps." 2
CommunicatingAt 33600
jump 70
!
@LABEL 59
note "Communicating at an unknown rate." 2
jump 70
</PRE>

Done! In English, what I have done, in the plain text modem script file of my GeoPort modem, add 2 cases so that when the modem is connection at 31200 bps or 33600 bps, a line will be in the connecting status box showing the correct sting.

Part 3...
     
pkkc
Guest
Status:
Reply With Quote
Mar 12, 2000, 11:57 PM
 
Therefore for those of you who have a 56K modem, you will have to find out all the possible connection speeds and do the same thing as above.

Last Always work on a copy and I do not accept any responibility of you modifying your modem script file and then trashed your Mac. But do call me if you need help and I will definitely try.

Patrick.

PS. Sorry for me spelling.
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 02:54 PM.
All contents of these forums © 1995-2014 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2014, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2