Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Enthusiast Zone > Classic Macs and Mac OS > Mp3's skip like hell with 9.0.4

Mp3's skip like hell with 9.0.4
Thread Tools
Mac Enthusiast
Join Date: Apr 1999
Location: Portland, Oregon
Status: Offline
Reply With Quote
Apr 5, 2000, 07:49 PM
 
Well now im pissed. Just for backround I have an imacdvse with standard ram and harddrive, etc... Anyways, before when I would open an application like internet explorer or whatever, if i had mp3's playing they would skip for like a microsecond then everything would be ok. Since I've upgraded to 9.0.4 yesterday, however, the skipping is horrendous. It skips and slows waaaaaaaaaaaaaaaaaaay down for the entire time an application is opening, no matter what it is.

This is unacceptable. I know part of the reason it skipped before and it skips now is beacuse of virtual memory, but now its like whenever i wanna open anything I feel like stopping the mp3 so i dont have to hear the warping that's caused... its so annoying.

Anyone else having this problem? I've tried it with all the mp3's players i have (grayamp, macast, soundjam, audion), and it happens with all of them. How irritating.
everything you know is wrong (and stupid)
     
Grizzled Veteran
Join Date: Oct 1999
Location: Minneapolis
Status: Offline
Reply With Quote
Apr 5, 2000, 08:30 PM
 
Ok, try these things...
Disable Multi user control panel, related extentions
In the energy saver control panel, click advanced, and make sure processor cycling is off!
In the servers folder in the system folder, amek sure its empty (unless you always mount a appleshare disk on boot)
Update to quicktime 4.1.1

------------------
-See Yea!
     
Mac Enthusiast
Join Date: Apr 1999
Location: Portland, Oregon
Status: Offline
Reply With Quote
Apr 5, 2000, 09:05 PM
 
I already have processor cycling off, and i've upgraded to qt 4.1.1... I use the multi user control panel, but i'll try disabling it and see if that helps... I'm at work right now so I cant try at the moment but i will when I get home. Thanks for the suggestions.
everything you know is wrong (and stupid)
     
Raiden
Guest
Status:
Reply With Quote
Apr 5, 2000, 10:30 PM
 
I too have upgraded to MacOS 9.0.4. In addition, I upgraded SoundJam™ MP to version 2.0Plus. Within the preferences for SoundJam™ you can opt to have the entire mp3 file loaded into memory. I did this and so far I am not having any problems with skipping when I load applications while the mp3s are playing nor do I notice a system performance hit. Granted, I did not try to play mp3s with SoundJam™ MP version 1.6 and MacOS 9.0.4, but my current setup works fine on my iBook (96M RAM). I hope this helps.
--Raiden
     
brian h
Guest
Status:
Reply With Quote
Apr 6, 2000, 12:54 AM
 
I also experience this, but with a twist. It also happens when playing audio CDs. I think its because the system changed with OS9 to play CDs digitally via software rather than through the CD hardware (or something like that). Before OS9, my CDs could keep playing even after the system crashed! Anyway after the first OS9 Audio Upgrade, I noticed that this audio skipping started happening consistantly. Whenever I run an application, open a document, and sometimes when accessing a webpage, the CD stutters (as does mp3s). Its not always drastic, but it happens consistantly.

Whats up with this??! I'm running 9.04 on an iMac 333, B&W G3 400, and a Wallstreet Powerbook G3. They all have over 150 megs of ram and are running with virtual memory on. Multi-users is disabled and I've got the latest updates of about everything else.

Now that I'm thinking of it, the CD audio is just damn flakey recently. Today the control strip cd control stopped working or would play a track for 20-30 seconds at best, but the Apple CD audio player kept working flawlessly... wierd stuff ever since those Audio updates came out... maybe I'll try downgrading to the CD/DVD and Apple Audio extensions that came with the original OS9 which wasn't nearly as bad.
     
Professional Poster
Join Date: Mar 1999
Status: Offline
Reply With Quote
Apr 6, 2000, 01:20 AM
 
i am not saying that it's the cause of all your ills here, but if you have enough RAM and do not require VM then do not use it.

some app's and some games require VM, most do not.

VM and audio playback and streaming video, for examples, do not get along well.

and VM messes with MacOS theme sounds. scroll down your Apple menu with VM on and listen to the sounds made as you scroll, then turn VM off and restart and repeat the Apple menu exercise, listen for the difference. it is dramatic. VM will give you about one out of two or three clicks as you scroll, VM off and you hear them all.

so in very real sense, VM does not deal with a certain kind of transient signal processing very well and that can result in certain types of problems under certain conditions.

as you have found.

i went to the doctor and told him 'Doc, it hurts when i do this...', and the Doc said 'Well, then don't do that, and buy more RAM if'n ya needs it'
     
Brian H
Guest
Status:
Reply With Quote
Apr 6, 2000, 04:07 PM
 
Well, I will certainly try turning VM off to see if it is that simple, but I have a big issue with Apple creating updates that all of a sudden don't work right unless you turn of VM which THEY THEMSELVES have the OS turn ON by default! I have 256 megs of RAM, but still use VM because apps DO load faster and run more efficiently. I've heard from someone who was a developer that VM is actually preferred by some applications and they run better with it ON than off. (Of course there are a number of video/audio apps that do better with it off)

Lets face it... this should be a no-brainer. Playing an audio CD should not be such a tax on the OS that the CD skips whenever you do something else. CDs ran fine with VM on up until recently, and the MP3 skipping wasn't as bad either.

I think Apple need to fix this ASAP cause there are a LOT of iMac/iBook owners out there who will never touch the memory settings to turn off VM, but their CDs will skip and once again it looks like Apple is an inferior product. My inlaws just bought a new iMac on my advice and they had only one complaint and that was that the CD skips when they use the computer for other stuff at the same time.
     
Professional Poster
Join Date: Mar 1999
Status: Offline
Reply With Quote
Apr 6, 2000, 04:53 PM
 
VM is only of any real benefit if you haven't enough RAM, OR if an application requires it.

i have read every Apple TIL article, etc. and every opinion on this, and i also have some personal experience on many different Macs, VM off and VM on.

Don't use VM unless you must.

Apple has VM on by default because ALSO by default they ship Macs with a woefully inadequate amount of RAM. it is pretty much a given that a good starting point is 128M of RAM, these days. i am not the biggest poweruser around and i would not even consider a newer/newest Mac model with less than 128M

[This message has been edited by wlonh (edited 04-06-2000).]
     
Petrus
Guest
Status:
Reply With Quote
Apr 6, 2000, 06:30 PM
 
I'm experiencing big trouble with the 9.04 update on my Pismo. The Mp3 payer problem with skipping was almost gone by removing the "Apple Audio Extension" that came with the updater.

However, the problem with slow ethernet connection still is there. Only 25% of 9.02...

m99ph@mail.ryp.umu.se
     
Mac Enthusiast
Join Date: Jan 1999
Location: Inside your computer!!!!
Status: Offline
Reply With Quote
Apr 6, 2000, 06:50 PM
 
With my old 275Mhz 603e I used to get a skip/pause when playing mp3 and opening an app, but I've never heard a skip or pause from my iMac DVSE when opening an app or anything. Not even with 9.0.4. That's really weird. I even tried to bogg down the CPU by putting an alias of both IE5 and OL5 on my desktop, highlighting both and opening then both at the same time, while an MP3 is plaing in soundjam and 2 visual pluggins open.
I couldn't get it to pause/skip for worth anything...

sorry for not being much help...
     
jeff denapoli
Guest
Status:
Reply With Quote
Apr 7, 2000, 11:46 AM
 
I have had the opposite experience...not to dash your hopes or anything. I too have an imac dvse and with 9.0 experienced tiny skips whlie applications were opening. With 9.04 however, there are absolutely no skips. My performance has improved.
     
scott
Guest
Status:
Reply With Quote
Apr 7, 2000, 12:05 PM
 
maybe I'll try downgrading to the CD/DVD and Apple Audio extensions that came with the original OS9 which wasn't nearly as bad.

Never mix system extensions between different versions of the OS. You're asking for trouble. Apple's software engineers are expecting certain things to be constant, and doing something like the above messes with the formula.

If you going to downgrade, downgrade the whole OS with a clean install, not just a few things.

- Scott
     
scott
Guest
Status:
Reply With Quote
Apr 7, 2000, 12:11 PM
 
so in very real sense, VM does not deal with a certain kind of transient signal processing very well and that can result in certain types of problems under certain conditions

VM (virtual memory) is not inherently a bad thing. In fact, it essential for high performance systems. The problem is that Mac OS 9.x's VM subsystem is pretty bad. VM was sort of tacked on to the OS. This is compounded by the fact that Mac OS 9.x doesn't really do preemtive multitasking.

By contrast, with Mac OS X, you won't turn VM on or off. It will be on all the time, it's extremely effecient, and it doesn't slow anything down. I know it's hard to wait, but when Mac OS X comes out, Apple's detractors will basically be out of excuses.

- Scott

     
buserror_uk
Guest
Status:
Reply With Quote
Apr 7, 2000, 12:15 PM
 
VM is good, use it. Not using VM is trying fight a rear guard fight.
VM is not only a paging system, it allows to do "file mapping", wich accelerate many tasks by factors of magnitude. Basicaly, the system "fake" loading libraries, and loads only the bits that are *really* needed, when they are needed.
The best speed is attained by having lots of ram, AND VM on. if you don't have enough ram, you fall into the "paging" mode of VM, and its slow. That what people use as argument for not using it.

So, back to the problem of 9.04 & sound playback.

In the pre-g3 world, we had SCSI. SCSI was smart and took very little CPU to run.
The AWACS (sound chip) was then the king of the hill, and had a very high priority for it's interupts. It was possible to lock the machine up doing sound playback if you wanted to, even the mouse would be jerky. Twas cool: real time!
With the G3s arrived IDE.. Unfortunately, IDE requires more CPU than SCSI: needs more interrupts. So the sound driver gets less, and can even be interrupted itself by that nasty IDE.
So you can get skips when playing audio and doing "heavy" disk access. "heavy" is all relative, only certain operations at a certain rate causes the problem. For example, Outlook Express makes my playback skips everytime it gets emails, even if the task does not seems "heavy".

Now, we are modern and all, and we have USB!
So we have the IDE driver being has hungry as before, and a poor USB driver that fights for it's life trying to send a BUNCH of data (heh, 44kHz is quite heavy, thats why mp3 exists) to it's controler to play the sound.

You got it, either it has no time because IDE bothers it (the skips) or the data (the sound) it was expecting to send to the controler gets corrupted at some point by something that interrupt it. That lastest is what we experience on the iMac DVs when the sound is not skipping, but garbled, as soon as there's a disk access.

Michel Pollet, author of Vamp (first mp3 player on Mac, back in... wheee)
     
buserror_uk
Guest
Status:
Reply With Quote
Apr 7, 2000, 12:26 PM
 
Well, saying that VM on macos 9 is not well integrated is not really true. It is very efficient. For quite some time now MacOS runs on top of a "nanokernel" that has a lot of rather evolved features. VM on MacOS carries around years of bad reputation, unjustified these days.

And preemptive multitasking has very little to do with real time processing. Preemtive multitasking is user/task related, it has no impact on how the drivers do their work: those are *always* been in a "preemtive" world.

So the problem is more related to an IO bottleneck at the driver level: VM just highlights it, it does not cause it.
     
Professional Poster
Join Date: Mar 1999
Status: Offline
Reply With Quote
Apr 7, 2000, 01:04 PM
 
whatever the case or opinion may be, i stand by my statement. don't use VM unless you must.

and you will certainly take some hits in performance in some instances if you use it.
     
dp
Guest
Status:
Reply With Quote
Apr 7, 2000, 01:22 PM
 
I have the same problem. Only I'm running OS 8.6. I NEVER had this problem until I put in the USB software for my USB pci card and upgraded to QT4. Now it skips like crazy. Just scrolling in IE or any app for that matter makes it skip. I have VM turned off. If I disable the USB exts, the problem goes away! hmmmmm.......
     
Brian H
Guest
Status:
Reply With Quote
Apr 7, 2000, 01:35 PM
 
thanks for the explaination buserror... thats pretty much what I've come to hear from programmers I know familiar with low-level system operations. IF VM isn't paging because there is more than enough "real" ram, then it speeds things up, makes the system more efficient not the opposite. (given the exceptions for digital video work, etc..)

But my point again is this: Apple ships systems with 64megs of ram (now). I know a LOT of first time Mac users, many of whom I suggested buy an iMac or iBook.... they don't always have enough money to buy a 128 meg upgrade right off the bat. Macs _USED_ to play audio CDs just fine with VM on or off, no matter what applications were running. But ever since they changed the way audio CDs are played on newer machines under OS9 there have been problems. I think it is _unacceptable_ for Apple to ship a new machine that can't play an audio CD out of the box without skipping under normal system use! Thats it. I fortunately have 256megs of ram and _could_ turn off VM if that is the problem. But I'm a long time Apple supporter and would rather keep the advantages of VM and suffer the skips patiently until there is a fix.

My point is that the average person buying an iMac will 1) not know why the CD is skipping and consider it a defect in Mac design, 2) won't know to turn off VM, or if they only have 64 megs of RAM won't want to for other reasons, and 3) will be VERY annoyed if told they need to buy a RAM upgrade for a brand new machine! As a consultant, I do suggest to people to buy ram right away, but its ridiculous that it would be _necessary_ in order to just listen to music while checking your email...

Apple needs to look into this and deal with it (soon I hope).
     
tbp9f
Guest
Status:
Reply With Quote
Apr 7, 2000, 02:50 PM
 
VM in OS 9 seems to be a lot better than previous OS versions. However, I have always found that MacOS VM will cause mp3 skipping. With VM off, MacOS mp3 playback is perfect - I can't get it to skip (using SoundJam MP). This is not the case with Windows, where WinAmp will skip when you do just about anything.

Since I have 160 MB Ram, I usually run with VM off because I am always playing mp3's and I can't stand skipping. I ran VM on for the last couple months and it was fine EXCEPT mp3's would skip during certain operations. Better than with 8.6, though.
     
Junior Member
Join Date: Apr 1999
Location: Bay Area, CA, USA
Status: Offline
Reply With Quote
Apr 7, 2000, 04:18 PM
 
I just called Apple Tech Support, and the representative told me that it is faster to have VM turned off, but some proggies might have some probs. I have 320MB RAM, and he said, if I can spare the HD space, having VM turned on will make RAM usage more efficient, but will make the computer run slightly slower, even if you stay within your physical memory. So, for top performance, turn VM off, and buy gobs of cheap RAM (I got mine for $65 per 128MB at http://www.asr-online.com/main.html). And remember, you can never have too much RAM!
I like systems, their application excepted. (George Sand, translated from French), "J'aime les systèmes, leur application exceptée."
     
Mac Enthusiast
Join Date: Apr 1999
Location: Portland, Oregon
Status: Offline
Reply With Quote
Apr 7, 2000, 05:29 PM
 
Heh, I like how this has turned into the VM discussion.. anyways, the problem I had just went away, and I didnt do a damn thing. It's just like it was under 9.0, it skips for a millisecond when I open something like IE, but the problems I was having before of horrible warping/skipping when opening ANYTHING has gone away. I didnt do anything, but i'm not complaining.
everything you know is wrong (and stupid)
     
P
Moderator
Join Date: Apr 2000
Location: Gothenburg, Sweden
Status: Offline
Reply With Quote
Apr 7, 2000, 07:03 PM
 
The problem is not MacOS 9.0.4 per se, bit rather the Audio Updates (which are included in OS 9.0.4).

To avoid sound skipping, the MacOS has sound buffers - meaning tht a bit of data is buffered before it starts to play. This introduces a lag, but that's OK - as long you know how large the buffer is.

As performance improves, these buffers have been made smaller - most recently in MacOS 8.1 - but one fact has stayed the same: The buffers swell to four times their usual size when VM is turned on. This is because there might be a page fault - meaning that info has to be moved from the disk to RAM.

When the DVD sync issue surfaced, Apple decided to work a bit on their Sound code. One of the things they did was that they made the buffers smaller when VM was on - they're the normal size now, meaning a fourth of what they used to be. This has several advantages - many games have better sound now than they did before, as it is easier to sync. The downside is the issue you are speaking of - when there is a page fault, the music might hack.

From what you are describing, your machine is page faulting constantly. This means that you are almost out real RAM. More RAM would help alleviate - and possibly eliminate - this issue _even if you do not turn VM off_ as page faulting becomes less common with more RAM.

That's as easy as I can make it. Tell me if it went over anyones head.
The new Mac Pro has up to 30 MB of cache inside the processor itself. That's more than the HD in my first Mac. Somehow I'm still running out of space.
     
Cowboy
Guest
Status:
Reply With Quote
Apr 7, 2000, 07:33 PM
 
Not sure when this happened for me, but it was before the 9.04 update (update didn't affect this).

I'm on a B&W G3 450 with 384 megs ram (dislike Virtual Memory intensely). I have no skips opening apps or anytime except when I drag windows around. It didn't used to do this... I think this started with OS 9. Using SoundJam (great app).
     
StuStu
Guest
Status:
Reply With Quote
Apr 8, 2000, 01:53 PM
 
I have also major problems with audio and my Pismo running 9.0.4 Quicktime 4.11, 128MB. If you are monitoring a source through the sound input port on the Mac, the sound that comes out of the speakers or the sound out port is delayed by about half a second. This is bad news for those of us that record audio live with our PowerBooks. I thought it was a Pismo problem, but now I've heard of other people having it with older Macs and OS 9. I WISH I could downgrade this Pismo to 8.6. I had NO problems with that whatsoever. It was so nice to use. Now, I'm stuck with a buggy OS 9 and there's nothing I can do until OS X comes out. APPLE SORT IT OUT!!!!!! Even CD's skip when opening windows with lots of files in them. As another person said above, on my old Mac (G3 233 PowerBook ) The audio CD used to keep playing even when the Mac had crashed!!!!!

Stuart
     
RohnnyB
Guest
Status:
Reply With Quote
Apr 8, 2000, 07:40 PM
 
I have a PowerComputing PowerCenter 120 w/208 megs RAM, a Rage Orion graphics card, and a 6X CD-ROM player. Also just installed a new 9.1 gig IBM HD. Next up are a G3/400 upgrade, and and I was thinking of upgrading to a faster CD-ROM player with RW (see below).

Anyway, ever since installing 9.0.4, my CDs are skipping like crazy, but other CDs (games, macaddict discs, etc.) work fine. I've never had skips on any version of the OS, and I started w/7.0 in '92 on a IIs. It is very annoying!

I've tried turning on/off VM, and have disabled the audio update, nothing helps. Even have a friend coming over Monday evening to clean my player, thinking it was a hardware problem. Was even going to recheck the SCSI connections (since the HD was just installed). Also, in an act of desperation, I 'cleaned' the laser with one of those CD cleaner discs. Now that I've read all this, however, I guess I just won't have a CD music player or be able to take further advantage of SoundJam unless I downgrade to 9.0. Thinking of even going back to 8.6, which was terrific.

BTW, under 9.0, I ALWAYS had to enable the CD 'sound in' after every restart before the CD would play, then it did just fine. With 9.04 that chore is no longer needed, but of course it now skips all over the place. That was the reason I originally wanted to upgrade to 9.0.4, to see if the 'enabling' problem had been resolved. Fix one problem, create another.

Finally, the only reason I originally disabled the audio update installed by 9.0.4 was that it created a lot of sound distortion and screwed up sound levels something awful. I've heard that the update was only for the fast machines, but 9.04 installed it, so I figured it was OK...

Why does each version just keep getting more unstable and complicated? Seems like Apple is becoming bloatware like our friends at Microsoft. Or maybe the Mac OS is trying to get too close to Mac X in features but lacks the capabilities of Mac X (i.e., pre-emption). Whatever, it's a pain...

I've become very nostalgic for the kinder, simpler days...Even 7.5.3 during Apple's dark days was better...Bottomline: any kind of definitive help would be appreciated. Thanks.
     
Professional Poster
Join Date: Mar 1999
Status: Offline
Reply With Quote
Apr 8, 2000, 09:44 PM
 
pardon me, but... kinder, simpler days of 7.5.3?!?!? you mean the WORST MacOS ever?? and at a time when the product line and OS direction was an indecipherable mess??

MacOS has gotten nothing but better and more stable... i have 3 generations of Macs running MacOS 9.04 with no problems and the rest of my family's Macs are similarly kicking butt and my Mac-using friends are happy as clams

obviously your mileage has varied from that of the majority

but, i digress and am terribly off-topic.
     
Rohn
Guest
Status:
Reply With Quote
Apr 9, 2000, 12:30 PM
 
To the moderator person:

No need for the road rage. I've heard B vitamins help. I used 7.5.3. to tweak things a bit. Yes, I know it was a rotten release, that's why I picked it. But I digress, too. I think a lot of people's mileage is varying according to the verbiage above. That's why I decided to post here in the first place, to add my voice to the many who are having either MP3 or CD skipping problems. My only desire is to fix the skipping, but I certainly appreciate your emphatic historical knowledge about the worst OS releases of all time. Doesn't that at least show that Apple is capable of making more mistakes that just selecting tangerine for its first iBook?

With respect to the current update, I have to admit that, other than the skipping issue, 9.0.4 has been a rock-solid update. The new ATI drivers have speeded up 2D graphics a bit.

Further, I will also admit that this skipping thing is the first major glitch I've ever had when updating, so I suppose I'm spoiled. ALTHOUGH, updating all those programs in preparation for 9.0 was not particularly fun, even though I'm a download junkie. Even had the patience to keep 8.6 until all my programs' updates were out before switching...

Don't worry, I am a fan of Apple, have been for almost a decade now. I just want it to work to my satisfaction, like any other customer. And I want to be proud to recommend the platform to others as I have done so many times in the past...Fixing my skipping problem will only help in this effort.

Anyway, thanks for your sincere concern and sympathetic words...

[This message has been edited by Rohn (edited 04-09-2000).]
     
Mac Enthusiast
Join Date: Apr 1999
Location: Portland, Oregon
Status: Offline
Reply With Quote
Apr 9, 2000, 11:03 PM
 
Rohn, interesting you say that 9.04 made your cd player skip... I was thinking it was more like the new way apple must have implemented cd playing. My imac dvse has skipped on cds since i got it, and it came with 9.0. I didnt really care though, since my mp3 collection is around 6 gigs, so I never listen to cds.

I just think it's weird that you didnt have the skipping before, and now you do, and the 9.04 update caused it.

Anyways, I have to agree with wlonh... 7.5.3 blew ass

So far, my favorite system of all time was 8.6, and I would be using it on this computer if it had come with it. I had gotten 9.0 before my new computer, and I didnt like it... had too many problems. So I went back to 8.6 on that computer. Then I read that people were getting their new DV imacs with 8.6 and were complaining.. i was hoping mine would come with 8.6 but it didnt.. but in the end, after using system 9 for about 4 months now, I have to say its not that bad. It just works a little differently and you have to get used to it.
everything you know is wrong (and stupid)
     
Goatee
Guest
Status:
Reply With Quote
Apr 10, 2000, 03:35 AM
 
Sorry to digress a little - but Cowboy, what do you mean by "B&W G3"? Does it stand for "black and white"?

confused....
     
Rohn
Guest
Status:
Reply With Quote
Apr 10, 2000, 04:40 AM
 
My comment about 7.5.3 was for effect. I liked 8.6 the best too. And, yes, 9.X is really OK, all things considered. One other nice thing about 9.0.4 is that it seems to be handling the 'memory creep' problem better, at least for me. System/OS memory no longer bloats up from the 30s to the 50s or 60s over time. And the largest unused block of memory stays about the same, even when I repeatedly open and close Communicator and other hog programs. That is a good thing, not having fragmented memory all over the place...

I really do apologize to everyone about the 7.5.3 thing; I thought everyone would recognize the sarcasm as gentle and humorous. Apparently, it was recognized as neither. Nor, apparently, was it recognized as sarcasm at all, but, rather, a condemnation of 9.0 to the depths of OS hell. Not my intention at all. I've just discovered those smilies, and I will use them in the future to denote each such instance of funnin'...Heck, Apple is over 130 on the stock market, we don't have to be so gosh darn defensive anymore...

Regardess, thanks billybob for your reasoned and 'quiet' response to a real problem. I, again, just want the skipping to go away...

Final Postscript: Finally got my CD-ROM to work. How? I bought a Yamaha 8424S burner! Amazing how a new player can help things when the old one finally goes south. It was, after all, a hardware problem, so sorry for my disparaging remarks about 9.0.4. The player's failure just happened to coincide with the installation of the update.

[This message has been edited by Rohn (edited 06-03-2000).]
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 12:23 PM.
All contents of these forums © 1995-2015 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2015, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2