Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Enthusiast Zone > Classic Macs and Mac OS > Slow wake-up from sleep on an iMac

Slow wake-up from sleep on an iMac
Thread Tools
hagop
Guest
Status:
Reply With Quote
Apr 14, 2000, 03:27 PM
 
Whenever I try to wake up my computer from sleep, there is about a 20 second wait before I can actually use the computer. Turning off AppleTalk cuts this down to less than 3 seconds, making it virtually instant. I read somewhere that the slow down is caused by the MacOS trying to scan the AppleTalk network to search for devices, thus explaining why it's faster if I turn off AppleTalk.

But I don't want to turn off AppleTalk, because I use a printer that requires AppleTalk, and I don't want to constantly turn off and on AppleTalk whenever I want to print.

Does anyone know of any solution (or suggestions) to this "problem"?

This computer is an iMac 350, running MacOS 9.04, but I don't think this problem is specific to this system.

Another option I have is to replace the stock hard drive in the machine with a quiet one, so that I don't have to put it to sleep when it's not being used (the only reason I put it to sleep is because the hard drive noise is so damn irritating). But that's for another topic.

Thank you,

-Hagop
     
SurfinCowboy
Guest
Status:
Reply With Quote
Apr 18, 2000, 10:53 AM
 
Is the lag time after all the extensions have loaded and all the desk icons have appeared but before the control strip shows up? You might try removing any recent servers from the recent servers folder in the Apple Menu folder and see if that helps.

Good luck...
Cowboy
     
Brent
Guest
Status:
Reply With Quote
Apr 18, 2000, 01:24 PM
 
You computer isn't scanning the network for servers, it's scanning for an available Appletalk address. It would like to use the one it grabbed before it went to sleep, but it first has to check if anyone else is using it. The delay is the time out duration as it waits for anyone else to respond to the address query.
I haven't actually tried this myself, but you may try hard coding the Appletalk address. You have to set the Appletalk control panel to advanced and then check the "User Defined" box. Just use the same address that's already there.
Your other option is use adjust the timeout values in OpenTransport with one of the shareware tools that allow you to change these settings. This is not recommended if you don't know what you are doing.
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 11:29 PM.
All contents of these forums © 1995-2015 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2015, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2