Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Enthusiast Zone > Classic Macs and Mac OS > How do I get rid of this stupid keyboard layout menu?

How do I get rid of this stupid keyboard layout menu?
Thread Tools
Mac Elite
Join Date: Nov 2000
Location: Los Angeles, CA
Status: Offline
Reply With Quote
Feb 27, 2001, 11:46 PM
 
Ever since I reinstalled Mac OS 9 (and upgraded to 9.1) I have had a keyboard layout menu, with an American flag as its icon, between the clock and the applications menu. It will let me switch my keyboard to one of four Slavic layouts. This feature is completely useless, and I would like to disable the menu. Suggestions?
Fyre4ce

Let it burn.
     
Grizzled Veteran
Join Date: Oct 1999
Location: Minneapolis
Status: Offline
Reply With Quote
Feb 28, 2001, 01:31 AM
 
Open the Keyboard control panel, and choose your correct keyboard layout
     
Clinically Insane
Join Date: Apr 2000
Status: Offline
Reply With Quote
Feb 28, 2001, 04:18 AM
 
Just make sure only one keyboard is checked - if more than one is checked the menu will appear. Otherwise it won't.

Cipher13
     
Fyre4ce  (op)
Mac Elite
Join Date: Nov 2000
Location: Los Angeles, CA
Status: Offline
Reply With Quote
Feb 28, 2001, 08:23 AM
 
Nope, sorry - tried that already. The "US" layout is checked and grayed out. The others are all unchecked, and I still have the menu.

------------------
Fyre4ce

"I need a vacation." - Terminator robot
Fyre4ce

Let it burn.
     
Forum Regular
Join Date: Jan 2001
Location: Heidelberg Germany
Status: Offline
Reply With Quote
Feb 28, 2001, 08:53 AM
 
You have to check the one you want before you can uncheck the US keyboard.

I am also on 9.1 and this works just fine for me.
     
Professional Poster
Join Date: Sep 2000
Status: Offline
Reply With Quote
Feb 28, 2001, 09:27 AM
 
worse comes to worse, you may want to re-install the OS and upgrade to 9.1 again.

-r.
     
sumsaentor
Guest
Status:
Reply With Quote
Feb 28, 2001, 12:42 PM
 
In the keyboard control panel, there is a pull-down menu, where you choose between scripts. If 'Roman' is chosen, you can select and deselect keyboard layouts in roman-script-based languages such as English, German etc. Use the pull-down menu in the control panel to switch to another script (in your case probably called 'Cyrillic') and deselect the Slavic keyboards that show up below.

Hope this helps,


Originally posted by Fyre4ce:
Ever since I reinstalled Mac OS 9 (and upgraded to 9.1) I have had a keyboard layout menu, with an American flag as its icon, between the clock and the applications menu. It will let me switch my keyboard to one of four Slavic layouts. This feature is completely useless, and I would like to disable the menu. Suggestions?
     
sumsaentor
Guest
Status:
Reply With Quote
Feb 28, 2001, 01:22 PM
 
Ooops, I think I was a little too hasty above. The method I explained will let you deselect all but one keyboard layout per script, which doesn't really solve your problem. The solution is to start up withour extensions. Open the system suitcase and remove scripts that you don't want. Foreign scripts may have garbled-looking names, since the finder cannot show more than one font at a time :-(
(I hope this is something they have fixed in OSX, because it is really annoying if you use several different (non-English) languages)

Anyway, the scripts are the ones that look like plain sheets of paper with a globe on them. Remove the scripts from the system suitcase (I don't think the Roman script will show up there, but you don't want to remove that anyway), restart and the menu should be gone. That worked for me.

     
ekoelbel
Guest
Status:
Reply With Quote
Feb 28, 2001, 03:02 PM
 
i had that when viavoice was installed on my powerbook....
     
Grizzled Veteran
Join Date: Mar 2000
Location: Massachusetts, USA
Status: Offline
Reply With Quote
Feb 28, 2001, 03:32 PM
 
If you have Unicode and WorldText installed you will have the keyboard layout menu. The only way to get rid of it is to get rid of the unicode enabled System suitcase.
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 09:35 AM.
All contents of these forums © 1995-2015 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2015, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2