Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Enthusiast Zone > Classic Macs and Mac OS > s.o.s. startup problems

s.o.s. startup problems
Thread Tools
Forum Regular
Join Date: Jan 2001
Location: Bruges, Belgium
Status: Offline
Reply With Quote
Jun 25, 2001, 03:51 PM
 
hi, I've got a major problem, the other imac is not starting up anymore, inistead it shows a folder icon with a question mark / finder icon blinking (this happens before anything else). Starting up from a bootable cd and running techtool deluxe doesn't help, the disk first aid reports

"keys" defect, 4,285

quick help needed!!!

-c
-c
     
Administrator
Join Date: May 2000
Location: California
Status: Offline
Reply With Quote
Jun 25, 2001, 05:56 PM
 
Disk damage. You could try an update of the driver with Drive Setup, but that usually doesn't do it.

Copy everything off & reformat. Either that or DiskWarrior/TechTool Pro.
     
caifara  (op)
Forum Regular
Join Date: Jan 2001
Location: Bruges, Belgium
Status: Offline
Reply With Quote
Jun 26, 2001, 07:19 AM
 
thanks for the input reader50, but more problems seem to occur:

the computer is totally stuck now, I can "start" up from a disk but I can only see the disk icon and the menu bar in the finder where I can't perform any actions. Is there something I can do? I have another iMac next to it and I have a crossover cable, I also have applecare, techtool deluxe, techtool pro, norton utilities and disk first aid.

any help would be VERY much appreciated,
-c
-c
     
Administrator
Join Date: May 2000
Location: California
Status: Offline
Reply With Quote
Jun 26, 2001, 12:00 PM
 
Sounds like the disk damage has gotten worse. Boot from the TechTool Pro CD, it has the ethernet extensions. Recover all the data from the damaged disk, and save via ethernet to the other iMac. Or use a FireWire cable (assuming both Macs have FireWire), launch the other Mac in FireWire Target Disk Mode so the other Mac's HD will be available to TechTool Pro.

If TTP cannot save to the other iMac, then things get complicated. The same applies if TTP cannot find the damaged HD.

If TTP cannot find the damaged HD, you can use Data Rescue to access the HD. It is shareware (US$39), but is the only thing I know of that will work even if the driver/partition map of a HD is damaged.

If things get complicated, the only sure way to save your data yourself is to boot from another drive. That can be done with an external, or by removing the damaged HD from the iMac and putting it in a multi-drive PowerMac. Either way, you can save the recovered files to the other HD.

If you cannot boot from anther drive, nor borrow a multi-drive PowerMac, things get risky. Use Drive Setup to format the damaged drive. Format it the exact same way as before - IE: if you had one partition in HFS+, format that way. 2 partitions in HFS, format that way. Go up to the menu Functions -> Initialization Options. In the dialog, make sure the options "Low level format" and "Zero all data" are not checked. If either option is checked, the format will permanently wipe all your data.

If you format a different way from the original, you can either reformat the correct way or use Data Rescue. In Data Rescue, you would first try as an HFS+ disk. Then as an HFS.

After the format, do nothing to the apparently empty drive. Boot from the Norton CD and use the "Undelete" command on your apparently empty HD. Norton should find most of the missing files, and restore them.

Note: This is getting into serious stuff. If you don't feel comfortable going after your files this way, use your AppleCare. You paid for it, let Apple get the files back. And accept the week or two it will take them to do it. If you do any of these steps incorrectly, there is a real chance of losing most or all of your data.

And I do suggest regular backups in the future. Good luck.
     
caifara  (op)
Forum Regular
Join Date: Jan 2001
Location: Bruges, Belgium
Status: Offline
Reply With Quote
Jun 26, 2001, 01:31 PM
 
reader50, thanks for answering again, but I really can't do anything in the finder, so using th pro cd won't do: the cd icon appears (normal cursor), then it starts searching the other desktop stuff (clock cursor that isn't ticking) and it never finds it.

I think I will be forced to give the thing away for a week or two (except if someone knows how to solve the cursor problem).

-c
-c
     
caifara  (op)
Forum Regular
Join Date: Jan 2001
Location: Bruges, Belgium
Status: Offline
Reply With Quote
Jun 28, 2001, 08:47 AM
 
woohoo, long live applecare, this guy solved the problem in 2 hours.

-c
-c
     
Administrator
Join Date: May 2000
Location: California
Status: Offline
Reply With Quote
Jun 28, 2001, 02:18 PM
 
I would be interested in how he got around the Finder startup freeze. I have a few ideas, but it would be nice to know what worked. Once you get past that freeze, I know how to save the drive. At least in my G4, it would be trickier in your iMac with no 2nd hard drive.
     
caifara  (op)
Forum Regular
Join Date: Jan 2001
Location: Bruges, Belgium
Status: Offline
Reply With Quote
Jun 29, 2001, 04:46 AM
 
I wasn't at home when he fixed that program, I came home when he was running norton.
I'll ask my dad later, he was at home, but I don't know if he will remember what the applecare guy did. (he sure didn't take the hard drive out, and he did use ethernet, but not for copying data)

-c
-c
     
Clinically Insane
Join Date: Apr 2000
Status: Offline
Reply With Quote
Jun 30, 2001, 03:40 AM
 
I had that prob about a week ago. Even booting from a CD the Finder died.

So, I put the HD as slave in the G4. Same prob - Finder crashed.

Then I noticed that I could still move the mouse, and still drop into Macsbug.

So, its not a hard crash, really.

So I took out the HD, booted of my master, deleted the Finder from my System, put the DiskWarrior app there, renamed it Finder, changed is type/creator with ResEdit to "FNDR/MACS", shut down, put in the dead slave, booted, and it went straight into DiskWarrior, no crash.

Repaired the HD. Rebooted from CD, put the Finder back in its place, rebooted from the master, and it all worked perfectly.

Game over - Cipher: 1, Ugly Problem: 0.

I just figured it was a HD/Finder conflict. So, take the Finder out of the equation.

This course of action will work for you too - if you want me to guide you through it, contact me.
     
caifara  (op)
Forum Regular
Join Date: Jan 2001
Location: Bruges, Belgium
Status: Offline
Reply With Quote
Jun 30, 2001, 01:35 PM
 
eu, cipher, I think you're a little late (appearing to what came before), allthough if it should happen again I'll sure contact you, thanks for the offer.

The applecare guy tried booting from the techtool cd, didn't work, but booting from the 9.1 cd did work, but the thing wasn't ok. At some point (dunno where, as I wrote before, I wasn't there) he disconnected the hard drive. He also used his powerbook, diskwarrior and norton.

-c-[/LIST]
-c
     
Clinically Insane
Join Date: Apr 2000
Status: Offline
Reply With Quote
Jun 30, 2001, 09:32 PM
 
Oops, didn't notice you'd already fixed the problem
Well, if it happens again... drop me a line.
I've only experienced it once ever - and have never seen it before that on MacNN or anywhere else.

So, twice ever... its a rather rare problem...
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -5. The time now is 09:17 AM.
All contents of these forums © 1995-2013 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.7 © 2000-2013, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2