Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Hardware - Troubleshooting and Discussion > Mac Desktops > PowerMac G5- no startup chime

PowerMac G5- no startup chime
Thread Tools
Mac Enthusiast
Join Date: Nov 1999
Location: Seattle, WA
Status: Offline
Reply With Quote
Aug 22, 2013, 10:42 PM
 
Another one off of the chipper pile from work. This is my toughest one, but it's the one I want to get working the most. It's a PowerMac G5, early 2005 build with the dual 2.7 Ghz processors. Found it almost completely stripped down- no RAM, no hard drive, no optical drive. Added a hard drive and an optical drive and added some RAM. RAM was described in the eBay ad thusly:

1GB DDR PC3200 400Mhz high density
High Density Chipset (Pleas see compatible motherboard list below.)
184 Pins, Desktop Memory
Dual Channel Support
Unbuffered, Non-ECC, Non-Registered
2.5V
Lifetime Warranty
Non-ECC, None Register, Unbuffered
superior quality and best price
Fully tested

According to my G5 owners manual, this should be the correct RAM. Upon power up, there is no chime. I have put a startup disc in the drive and can hear it spinning as I hold down the C key. There is one steady on red LED on the board near the RAM slots. The power light in the switch gives a two blink series, which research indicates means "no RAM installed", at least on the late 2005 models. The processor heat sinks do get warm, and the backup battery is installed correctly and is new. Also, I have tried swapping out the video card.

All I ever get out of this one is two blinks and no chime. Help.

Val

Added- pulled off the cooling unit cover and found no evidence of any coolant leaks, and it is definitely a water cooled unit. So I'm hoping this one is worth saving.
( Last edited by ValVashon; Aug 22, 2013 at 11:33 PM. Reason: Added info about cooling unit)
     
Administrator
Join Date: Jun 2000
Location: California
Status: Offline
Reply With Quote
Aug 22, 2013, 11:50 PM
 
RAM on this unit must be added in matched pairs. The slot pairs count outwards from the center.

========== 4
========== 3
========== 2
========== 1
========== 1
========== 2
========== 3
========== 4

They don't have to be filled in order (ie you can use pair 2 while pair 1 is empty) but you must use the matching slots. If you happened to use the lower slots in both banks (pair 1 top bank, pair 4 bottom bank) the system will not boot.
     
Mac Enthusiast
Join Date: Nov 1999
Location: Seattle, WA
Status: Offline
Reply With Quote
Aug 23, 2013, 11:05 AM
 
Thanks for the heads up, but I've tried the RAM that way already- both pairs of RAM in the #1 slots (at different times) but still just the blinking light. My only thought is that I have cheaped out and gotten incompatible RAM and should maybe get a pair of sticks from an approved vendor that are guaranteed to work in a G5, but I'm getting hesitant to throw any more money at this thing.

Also- if I'm reading the front blinking light correctly, it is just showing me that there is no RAM, not incompatible RAM. The two blinks never change, no matter what I have in those slots.

Val
     
Administrator
Join Date: Jun 2000
Location: California
Status: Offline
Reply With Quote
Aug 23, 2013, 12:08 PM
 
Buy a pair of Mac-specific RAM from a Mac vendor like OWC in the smallest size. A pair of 256. Or borrow some old RAM from any friend who's long owned Macs.

Also, after plugging in RAM, (and with the Mac unplugged) press the reset button near the battery. Hardware changes can confuse the controller chip, requiring a reset before booting.

That diagnostic light on the motherboard. What is the label beside it?
     
Fresh-Faced Recruit
Join Date: Feb 2003
Location: Fox Island,Washington
Status: Offline
Reply With Quote
Aug 25, 2013, 02:20 AM
 
Val,
The next time you're in the area, (Fox Island- Tacoma) let me know. I have 4.5 GB of ram from my old 2.5 G5 you are welcome to have. Also a X800XT that I have no use for.
     
Mac Elite
Join Date: Feb 1999
Location: California
Status: Offline
Reply With Quote
Aug 25, 2013, 05:35 PM
 
The red LED would indicate there's a problem, but Apple just doesn't say what: About the Power Mac G5 (Late 2005) diagnostic LEDs

All I can think of is checking to see that every component is plugged in or attached correctly. Have you ruled out any problems with the logic board or its capacitors?
     
Administrator
Join Date: Jun 2000
Location: California
Status: Offline
Reply With Quote
Aug 26, 2013, 01:35 AM
 
It's an Early 2005 dual 2.7, which would make it a PowerMac7,3

On my Late 2005 G5, there are multiple diagnostic LEDs on the motherboard, and one is normally lit on boot when there is power available from the PS. We need to know the label beside the lit LED before we can interpret it.
     
Mac Enthusiast
Join Date: Nov 1999
Location: Seattle, WA
Status: Offline
Reply With Quote
Sep 1, 2013, 09:56 PM
 
It just says "D 58" or something like that (tiny print, bad eyes even with granny glasses) next to it. No real diagnostic information. I have a line on some guaranteed correct RAM so I will report back.

Val
     
Mac Enthusiast
Join Date: Nov 1999
Location: Seattle, WA
Status: Offline
Reply With Quote
Sep 5, 2013, 10:54 PM
 
Thanks to Coldwater for the RAM! It now starts up after I put two sticks in, and I had it on long enough to start off a disc and format the hard drive. Most of the covers on the cooling system were still off so I didn't leave it on long, but it's now working!

You MACNN people are the best- I started with 4 desktops off of the chipper pile and now have 4 working computers!

Val
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 07:11 PM.
All contents of these forums © 1995-2015 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2015, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2