Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Hardware - Troubleshooting and Discussion > Mac Notebooks > Simpletech external not working

Simpletech external not working
Thread Tools
Fresh-Faced Recruit
Join Date: May 2007
Status: Offline
Reply With Quote
Sep 17, 2007, 03:41 PM
 
when i first bought it i had to partition it to use it for my MB and i was able to move all my info over to it. now when i plug it in to my MB it wont even show up on the desktop. any ideas whats wrong?
     
Professional Poster
Join Date: Nov 2004
Location: eating kernel
Status: Offline
Reply With Quote
Sep 17, 2007, 03:53 PM
 
Maybe it's dead? Corrupted?

BTW, wrong forum.
Signature depreciated.
     
Forum Regular
Join Date: Feb 2007
Status: Offline
Reply With Quote
Sep 17, 2007, 04:55 PM
 
Try another USB port or another port on another computer. Does it work anywhere else?
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 01:04 PM.
All contents of these forums © 1995-2015 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2015, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2