Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Hardware - Troubleshooting and Discussion > Mac Notebooks > MBP unibody won't sleep when lid is closed

MBP unibody won't sleep when lid is closed
Thread Tools
Senior User
Join Date: Oct 1999
Location: Austin, TX 78751
Status: Offline
Reply With Quote
Sep 2, 2009, 05:25 PM
 
Here's a tough nut for you guys to crack.

I have a problem with my MBP where it stops going to sleep when the lid is closed (the MBP isn't frozen: sleep can be invoked manually, and the MBP sleeps automatically as well). If I reset the SMC or -- get this -- boot from any external drive, *including a cloned backup*, the problem will go away for 5-6 days.

An Apple Product Specialist had me delete some networking files in /Library/Preferences/SystemConfiguration, which fixed the problem -- temporarily. Then an Apple "Genius" at the Domain did an archive and install, which also only solved the problem temporarily. Later I myself erased my hard disk and restored a backup, and that seemed like a permanent fix, but after I updated to 10.5.8 from 10.5.7, the problem returned.

I think I may have to take my MBP back to the Apple Store so that they can run the special Apple Hardware Test (my own AHT turned up nothing). Some web searches revealed a similar problem with an earlier MacBook Pro from a few years back -- but closing the lid always resulted in a freeze, which isn't my case.

A hardware problem or a software problem? If software, which files are involved in triggering sleep when the lid is closed?
     
Senior User
Join Date: Oct 1999
Location: Austin, TX 78751
Status: Offline
Reply With Quote
Dec 5, 2009, 06:22 AM
 
This is still happening. And I should have added that the problem seems to be triggered only when I have an external monitor attached (an Apple Cinema Display 23"). I don't think it's a hardware problem -- I think it's a bug involving Apple Cinema Displays.
     
Moderator
Join Date: Jan 2001
Location: Polwaristan
Status: Offline
Reply With Quote
Dec 5, 2009, 11:14 AM
 
Are you mirroring or spanning with the second monitor?
How are you connected, miniDP or DVI? Try it with DVI if you can (mDP>DVI).

When a Mac notebook is connected to an external display and its internal display is off (e.g., when you boot it up with the lid closed and the ext display becomes the only one), it's normal for it not to respond to lid open/close. However your habits sound slightly different.
     
Senior User
Join Date: Oct 1999
Location: Austin, TX 78751
Status: Offline
Reply With Quote
Dec 5, 2009, 11:35 AM
 
I'm neither spanning nor mirroring; I'm using the external display with the MBP lid closed. The MBP is booted with no external display attached. The Cinema Display connects via mDP>DVI.
     
Moderator
Join Date: Jan 2001
Location: Polwaristan
Status: Offline
Reply With Quote
Dec 5, 2009, 11:40 AM
 
so you connect it after your mbp boots up, then the external becomes your only monitor (with the mbp LCD off)?
     
Posting Junkie
Join Date: Dec 2000
Status: Offline
Reply With Quote
Dec 5, 2009, 11:53 AM
 
I don’t get the problem. If the MBP is connected to AC power and an external display is attached, you should be able to use it with the lid closed, which means it shouldn’t go to sleep just from closing the lid. You should have to invoke sleep manually or let Energy Saver autosleep it after a certain amount of time, like a desktop.

Ticking sound coming from a .pkg package? Don't let the .bom go off! Inspect it first with Pacifist. Macworld - five mice!
     
Clinically Insane
Join Date: Nov 1999
Location: 888500128, C3, 2nd soft.
Status: Offline
Reply With Quote
Dec 5, 2009, 11:54 AM
 
Originally Posted by Le Flaneur View Post
I'm neither spanning nor mirroring; I'm using the external display with the MBP lid closed. The MBP is booted with no external display attached. The Cinema Display connects via mDP>DVI.
So you boot the MBP, connect the external display, then put it to sleep, and wake it up again from an external keyboard/mouse to have it in clamshell mode, using only the external display?

And then you're trying to get it to sleep by opening the MBP and then closing it again?

That cannot work, as the sleep sensors in the display assembly are disabled when you have the machine in clamshell mode. If they weren't, the machine would be asleep and wouldn't wake up as long as it was closed.
     
Senior User
Join Date: Oct 1999
Location: Austin, TX 78751
Status: Offline
Reply With Quote
Dec 5, 2009, 07:47 PM
 
Originally Posted by CharlesS View Post
I don’t get the problem. If the MBP is connected to AC power and an external display is attached, you should be able to use it with the lid closed, which means it shouldn’t go to sleep just from closing the lid. You should have to invoke sleep manually or let Energy Saver autosleep it after a certain amount of time, like a desktop.
OK, here's the clearest explanation of the problem that I can muster. As I already stated, at home I use the MBP in closed-clamshell mode with a 23" Apple Cinema Display. However, in the morning when I'm ready to go to work, I unplug the the mini-DP>DVI and USB connectors going to the ACD. Normally, when I unplug the ACD USB connector, the MBP wakes up briefly even though the lid is closed (as evidenced by the illuminated Apple logo), but then it goes to sleep when it recognizes that there's no longer an external display attached and the lid is closed. The disconnect sequence followed could also be: instead of unplugging the mini-DP and USB cables with the MBP's lid closed, I first open the lid of the MBP, and then I disconnect the cables, observing that the display comes on, and then I close the lid (after observing the MBP asleep) before stowing the MBP in my carrying case.

However, after intervals ranging from a day to about a week or so, what happens instead when I go through the above-mentioned disconnect procedure (either sequence) is that after all of the cables are disconnected (i.e. an external display is no longer connected), the MBP will not sleep when I close the lid. This phenomenon will persist until I reboot. Indeed, the MBP will resume sleeping when I close the lid if I reboot the MBP without an ACD connected. If an ACD is connected when I reboot, I'm pretty sure that when I later disconnect the ACD, the MBP will refuse to sleep when the lid is closed.

Note: in all cases when the MBP will not sleep with the lid closed, manually invoking sleep works, so this is not about system freezes. Also note that this does not appear to be a problem with the screen magnet sensor.

There is nothing in the system log that corresponds to when the the MBP refuses to sleep with the lid closed.

Doesn't it sound like when the MBP refuses to sleep with the lid closed, it somehow continues to act as if the ACD were still attached? I guess the next time it happens, I should open the Displays preference pane and check, right?

Apple tech support, from Product Specialists to the people to whom the Product Specialists refer their tricky cases like this, have been very disappointing. They think the problem is third party software and advise me to install a clean system with nothing but iWork / iLife apps!

My guess is that this is a bug in the system software. I'd like to avoid the tedious pain of rebuilding a system from scratch, especially since it might not work. I've always wondered what preference files might be involved, but I could never get a straight answer from Apple.

Any thoughts would be appreciated.
( Last edited by Le Flaneur; Dec 5, 2009 at 09:14 PM. )
     
Moderator Emeritus
Join Date: Apr 2001
Location: Wasilla, Alaska
Status: Offline
Reply With Quote
Dec 5, 2009, 07:58 PM
 
A coworker has similar issues when using a 24" LED cinema display. I can ask her on Monday if she's come up with a fix.
     
Senior User
Join Date: Oct 1999
Location: Austin, TX 78751
Status: Offline
Reply With Quote
Dec 5, 2009, 09:08 PM
 
Originally Posted by AKcrab View Post
A coworker has similar issues when using a 24" LED cinema display. I can ask her on Monday if she's come up with a fix.
That's good to know, because I had begun to think that I should have purchased a 24" LED cinema display instead!

By all means please ask her! By the way, I'm using version 10.5.8 of the MacOS; what about her?
( Last edited by Le Flaneur; Dec 5, 2009 at 10:46 PM. Reason: question about OS version)
     
Posting Junkie
Join Date: Nov 2000
Location: in front of my Mac
Status: Offline
Reply With Quote
Dec 6, 2009, 10:37 AM
 
The solution to this problem IMHO is to disconnect from closed-lid mode properly.

1) Apple Menu > Sleep (or alt-cmd-eject)
2) Immediately after that pull all USB connections*
3) Now you can take your time and disconnect the display and power

The advantage is that your MBP goes to sleep and you can verify that it does so properly. Once it's asleep it should stay asleep as long as you don't reconnect a USB device.


*) Note that this has to happen quickly because pulling a USB connection if the Mac has already gone to sleep will wake it up again.
     
Senior User
Join Date: Oct 1999
Location: Austin, TX 78751
Status: Offline
Reply With Quote
Dec 6, 2009, 11:03 AM
 
Simon, I wasn't aware that there's a way to disconnect from closed-lid mode properly (in fact, I've described two different methods). All these connections are supposed to be hot-pluggable. In my extensive discussions with Apple tech support, no one has suggested that there's just one way to do this. Furthermore, putting the machine to sleep before disconnecting USB devices will wake the Mac up again -- no matter how quickly you pull the USB cable.
     
Posting Junkie
Join Date: Nov 2000
Location: in front of my Mac
Status: Offline
Reply With Quote
Dec 6, 2009, 11:14 AM
 
There is indeed a correct way because pulling/connecting USB devices will wake a Mac.

Therefore, the USB connections have to go first. When I put my Mac to sleep there are just about two seconds until it actually does so. Just enough time to yank the USB cable. Once that cable's gone you can take your time with everything else.

Connecting is exactly the other way around. You connect the display, power, and then the USB. Once the USB connection is made the Mac will wake up.

The only thing you really have to avoid is connecting/disconnecting a USB device when your Mac has already gone to sleep as that will always wake it up.
     
Posting Junkie
Join Date: Dec 2000
Status: Offline
Reply With Quote
Dec 6, 2009, 11:16 AM
 
Yeah, I’m not sure why pulling the USB cables would be necessary in that case. The Apple link on Simon’s link above does mention sleeping the machine before coming out of closed-lid mode, though, so it might be interesting for you to try disconnecting the display cable while it’s asleep in order to come out of closed-lid mode, just to see if it makes a difference.

Another thing you could try is to choose “Detect Displays” from the Display menu extra after you’ve disconnected the display cable so that it can rescan for attached monitors, and perhaps reactivate the closed-lid sensor when it doesn’t find any.

Ticking sound coming from a .pkg package? Don't let the .bom go off! Inspect it first with Pacifist. Macworld - five mice!
     
Senior User
Join Date: Oct 1999
Location: Austin, TX 78751
Status: Offline
Reply With Quote
Dec 6, 2009, 11:52 AM
 
Originally Posted by Simon View Post
When I put my Mac to sleep there are just about two seconds until it actually does so. Just enough time to yank the USB cable. Once that cable's gone you can take your time with everything else.
That's weird. I wonder what is delaying sleep on your Mac. I've never seen a way of unplugging USB from a sleeping Mac without reawakening the Mac.
Originally Posted by Simon View Post
Connecting is exactly the other way around. You connect the display, power, and then the USB. Once the USB connection is made the Mac will wake up.
I do that.
Originally Posted by Simon View Post
The only thing you really have to avoid is connecting/disconnecting a USB device when your Mac has already gone to sleep as that will always wake it up.
Impossible to avoid, AFAIK.
     
Posting Junkie
Join Date: Dec 2000
Status: Offline
Reply With Quote
Dec 6, 2009, 11:55 AM
 
If you sleep, then disconnect the display cable without bothering with the USB cables, does it work?

Ticking sound coming from a .pkg package? Don't let the .bom go off! Inspect it first with Pacifist. Macworld - five mice!
     
Senior User
Join Date: Oct 1999
Location: Austin, TX 78751
Status: Offline
Reply With Quote
Dec 6, 2009, 11:55 AM
 
Originally Posted by CharlesS View Post
Yeah, I’m not sure why pulling the USB cables would be necessary in that case. The Apple link on Simon’s link above does mention sleeping the machine before coming out of closed-lid mode, though, so it might be interesting for you to try disconnecting the display cable while it’s asleep in order to come out of closed-lid mode, just to see if it makes a difference.
I'm pretty sure that that's the way I used to do it. But then someone else told me that I was doing it wrong, and so I switched to his method. I'm happy to revert to Simon's method, but I'll be surprised it it makes any difference.

Of course, the disconnect method I outlined above does work 90% of the time.

Originally Posted by CharlesS View Post
Another thing you could try is to choose “Detect Displays” from the Display menu extra after you’ve disconnected the display cable so that it can rescan for attached monitors, and perhaps reactivate the closed-lid sensor when it doesn’t find any.
Sure, it would be especially good to do that when I find that my MBP won't sleep when I close the lid, but I shouldn't have to do that every time. The Mac is supposed to be plug and play.
     
Senior User
Join Date: Oct 1999
Location: Austin, TX 78751
Status: Offline
Reply With Quote
Dec 6, 2009, 11:58 AM
 
Originally Posted by CharlesS View Post
Yeah, I’m not sure why pulling the USB cables would be necessary in that case. The Apple link on Simon’s link above does mention sleeping the machine before coming out of closed-lid mode
It also says this:

"Some DVI displays, including Apple's aluminum-framed DVI displays, can be unplugged without putting the computer to sleep."

Note that, Simon! ;-)
     
Senior User
Join Date: Oct 1999
Location: Austin, TX 78751
Status: Offline
Reply With Quote
Dec 6, 2009, 12:00 PM
 
Originally Posted by CharlesS View Post
If you sleep, then disconnect the display cable without bothering with the USB cables, does it work?
Does what work? The USB cable connection is required for the Cinema Displays. If I don't disconnect the USB cable, then no, the MBP won't wake up.
     
Posting Junkie
Join Date: Dec 2000
Status: Offline
Reply With Quote
Dec 6, 2009, 12:02 PM
 
What I mean to ask is, if you disconnect the display while the computer is asleep, do you still get the behavior that you’re talking about in this thread, or does it work as you expect?

What I am trying to do is to see whether Simon’s method does make a difference or not. If it does, then great, we’re done. If it doesn’t, then we can eliminate that and move on to something else.

Ticking sound coming from a .pkg package? Don't let the .bom go off! Inspect it first with Pacifist. Macworld - five mice!
     
Senior User
Join Date: Oct 1999
Location: Austin, TX 78751
Status: Offline
Reply With Quote
Dec 6, 2009, 12:07 PM
 
Originally Posted by CharlesS View Post
What I mean to ask is, if you disconnect the display while the computer is asleep, do you still get the behavior that you’re talking about in this thread, or does it work as you expect?
I'll try it again for a while, and we'll see ;-) But I'll be surprised if it makes a difference, especially since the Apple tech article that Simon quotes states that the Mac doesn't have to be asleep before the display is unplugged.
( Last edited by Le Flaneur; Dec 6, 2009 at 01:09 PM. )
     
Forum Regular
Join Date: Jan 2007
Location: Wisconsin
Status: Offline
Reply With Quote
Dec 6, 2009, 01:14 PM
 
Have you looked at Console to see if there is any unwanted activity that is keeping your MBP awake? I had the same problem and it turns out that iStat Menus was trying to launch every 10 seconds (but failing since I had uninstalled it). All I had to do was delete the plist file that the Uninstaller apparently missed in /Library/LaunchDaemons/

So it might be something like that. Worth checking out, I think.
     
Senior User
Join Date: Oct 1999
Location: Austin, TX 78751
Status: Offline
Reply With Quote
Dec 6, 2009, 02:16 PM
 
As I noted in my post above, "There is nothing in the system log that corresponds to when the the MBP refuses to sleep with the lid closed."
     
Forum Regular
Join Date: Jan 2007
Location: Wisconsin
Status: Offline
Reply With Quote
Dec 6, 2009, 02:20 PM
 
Oops, missed that. My mistake
     
Posting Junkie
Join Date: Nov 2000
Location: in front of my Mac
Status: Offline
Reply With Quote
Dec 6, 2009, 02:49 PM
 
Originally Posted by Le Flaneur View Post
That's weird. I wonder what is delaying sleep on your Mac. I've never seen a way of unplugging USB from a sleeping Mac without reawakening the Mac.
That's the entire point. The Mac should *not* be sleeping yet when you yank the cable. If it is it will immediately wake up again. The whole idea is to unplug the USB cable *before* it goes to sleep so that it stays asleep.

When you press alt-cmd-eject and immediately yank the USB cable you'll unplug it before the Mac goes to sleep. That's what you want.
     
Posting Junkie
Join Date: Dec 2000
Status: Offline
Reply With Quote
Dec 6, 2009, 03:27 PM
 
Why does it matter if the USB cable is unplugged or not? I would think the display cable would be all that would need to be unplugged.

Ticking sound coming from a .pkg package? Don't let the .bom go off! Inspect it first with Pacifist. Macworld - five mice!
     
Posting Junkie
Join Date: Nov 2000
Location: in front of my Mac
Status: Offline
Reply With Quote
Dec 6, 2009, 03:54 PM
 
AFAIK USB governs sleep (along with power), the display connection OTOH has no influence on sleep behavior.
     
Posting Junkie
Join Date: Dec 2000
Status: Offline
Reply With Quote
Dec 6, 2009, 04:11 PM
 
Originally Posted by Simon View Post
the display connection OTOH has no influence on sleep behavior.
Yes it does, particularly in this case. If you have AC power and an external display connected, the MBP will let you run it with the lid closed. If one of those two things is not present, it will sleep (yes, if you plug in a USB cable while the lid is closed without a display attached, it will wake up momentarily, but will go back to sleep again a few seconds later).

Also, the presence of the display cable while the lid is closed is what will cause the internal screen to be deactivated, along with the sensor that will detect when the lid is closed in order to cause the machine to go to sleep. If you plug a USB cable in while the lid is closed and no display is attached, it will go ahead and turn the screen on, even though you won’t be able to see it due to the lid being closed (but if you open the lid immediately, you’ll see it then). Since the sensor is a critical component of what the OP is complaining about, I think it’s relevant.

USB, on the other hand, only has influence on sleep behavior if you plug or unplug it. If you leave it alone, it shouldn’t, I’d expect.
( Last edited by CharlesS; Dec 6, 2009 at 04:32 PM. )

Ticking sound coming from a .pkg package? Don't let the .bom go off! Inspect it first with Pacifist. Macworld - five mice!
     
Senior User
Join Date: Oct 1999
Location: Austin, TX 78751
Status: Offline
Reply With Quote
Dec 6, 2009, 05:16 PM
 
Originally Posted by Simon View Post
That's the entire point. The Mac should *not* be sleeping yet when you yank the cable. If it is it will immediately wake up again. The whole idea is to unplug the USB cable *before* it goes to sleep so that it stays asleep.

When you press alt-cmd-eject and immediately yank the USB cable you'll unplug it before the Mac goes to sleep. That's what you want.
OK, I did that. I pulled out the ACD's USB cable before my MBP went to sleep, and you're right, it didn't wake up. So I disconnected the video cable as well. Then I opened the lid of the MBP (no external display attached), and it woke up normally using the built-in display. But guess what? When I later closed the lid (no external display attached), the MBP failed to go to sleep. And I checked in the Displays preference pane, and it only used the internal LCD. Clicking "detect displays" did nothing.

So we need to look somewhere else besides the specific steps followed when disconnecting the external display ;-)
     
Posting Junkie
Join Date: Dec 2000
Status: Offline
Reply With Quote
Dec 6, 2009, 05:30 PM
 
Have you tried resetting your Mac’s NVRAM?

Ticking sound coming from a .pkg package? Don't let the .bom go off! Inspect it first with Pacifist. Macworld - five mice!
     
Senior User
Join Date: Oct 1999
Location: Austin, TX 78751
Status: Offline
Reply With Quote
Dec 6, 2009, 05:43 PM
 
Originally Posted by CharlesS View Post
Have you tried resetting your Mac’s NVRAM?
Yes, and I've reset the SMU as well. I'm not sure that actually does anything, because the restart alone gets sleep working again.
( Last edited by Le Flaneur; Dec 7, 2009 at 10:19 AM. )
     
Posting Junkie
Join Date: Dec 2000
Status: Offline
Reply With Quote
Dec 6, 2009, 05:46 PM
 
Ah, I see that you mentioned that that fixed it for 6 days in the OP. You also say that deleting the network prefs fixed it “temporarily” — how long a time period did that fix last?

Ticking sound coming from a .pkg package? Don't let the .bom go off! Inspect it first with Pacifist. Macworld - five mice!
     
Senior User
Join Date: Oct 1999
Location: Austin, TX 78751
Status: Offline
Reply With Quote
Dec 6, 2009, 06:07 PM
 
Originally Posted by CharlesS View Post
Ah, I see that you mentioned that that fixed it for 6 days in the OP. You also say that deleting the network prefs fixed it “temporarily” — how long a time period did that fix last?
Again, I wonder whether it's deleting the network prefs that has an effect -- it's probably just the restart, since I restart after moving those prefs to the trash.

It would be helpful if someone with the same configuration (Apple display as sole external display with MBP in closed clamshell mode) were to post here.
     
Posting Junkie
Join Date: Dec 2000
Status: Offline
Reply With Quote
Dec 6, 2009, 06:12 PM
 
I’ve got a Dell display that I could try in closed-lid mode, but since it’s not an Apple monitor, it’s probably not what you want.

Ticking sound coming from a .pkg package? Don't let the .bom go off! Inspect it first with Pacifist. Macworld - five mice!
     
Senior User
Join Date: Oct 1999
Location: Austin, TX 78751
Status: Offline
Reply With Quote
Dec 6, 2009, 06:22 PM
 
Originally Posted by CharlesS View Post
I’ve got a Dell display that I could try in closed-lid mode, but since it’s not an Apple monitor, it’s probably not what you want.
My guess is that the monitor's USB cable is key -- does the Dell have one? Do you have a MBP unibody? Which version of the OS? (I have 10.5.8, but I imagine SL is the same). Try Simon's way of disconnecting the display: command-option-eject, then disconnect the display's USB cable, then the video cable (DVI?), then wake up the MBP, then close the lid and see whether it sleeps.
     
Posting Junkie
Join Date: Nov 2000
Location: in front of my Mac
Status: Offline
Reply With Quote
Dec 7, 2009, 04:27 AM
 
Originally Posted by CharlesS View Post
Yes it does, particularly in this case. If you have AC power and an external display connected, the MBP will let you run it with the lid closed. If one of those two things is not present, it will sleep (yes, if you plug in a USB cable while the lid is closed without a display attached, it will wake up momentarily, but will go back to sleep again a few seconds later).
Charles, that is correct. In theory. I am also aware that is what Apple publishes everywhere.

But in my own testing I have had to observe that it doesn't really work that way, at least not all the time. I can run closed-lid mode w/o a display connected. I am guessing this is not intended behavior, but it is reproducible. All it requires is sleeping a closed-lid mode MBP, removing the display, and then waking it again. It will stay awake and run in closed-lid mode. This just as an example. What I have learned after a lot of testing is that power and USB are actually really the crucial ingredients. Plugging/unplugging USB always wakes a Mac and no power also always means no closed-lid mode.

Note also that it can happen that disconnecting power doesn't immediately sleep your Mac as intended. However, whenever I experienced that (it's quite rare actually) an SMC and PRAM reset have restored the proper behavior.

Bottom line, I think what you're saying is correct and it's definitely also the intended behavior. However, I have witnessed many times that there are deviations from that ideal behavior. And I believe unless people are aware of this it can at times be very confusing to use closed-lid mode.
     
Senior User
Join Date: Oct 1999
Location: Austin, TX 78751
Status: Offline
Reply With Quote
Dec 7, 2009, 07:37 AM
 
Can we get back on track here and continue to troubleshoot the problem I'm experiencing? What's interesting to me, Simon, is that the disconnect procedure that you recommended seemed to trigger the problem more quickly!
( Last edited by Le Flaneur; Dec 7, 2009 at 08:34 AM. )
     
Posting Junkie
Join Date: Dec 2000
Status: Offline
Reply With Quote
Dec 7, 2009, 12:05 PM
 
Originally Posted by Simon View Post
But in my own testing I have had to observe that it doesn't really work that way, at least not all the time. I can run closed-lid mode w/o a display connected. I am guessing this is not intended behavior, but it is reproducible. All it requires is sleeping a closed-lid mode MBP, removing the display, and then waking it again. It will stay awake and run in closed-lid mode. This just as an example. What I have learned after a lot of testing is that power and USB are actually really the crucial ingredients. Plugging/unplugging USB always wakes a Mac and no power also always means no closed-lid mode.
Yes, but when you do this, main screen turn on (what you say!!). You can see this by looking at the translucent Apple logo on the top of the case, which is behind the screen. It lights up, because of the screen’s backlight. The screen is on. If you open the lid quickly you will notice the screen is already on and you won’t have to wait for it to wake up. When the display is connected and you wake up the MBP in closed-lid mode, that’s when it activates the screen (and presumably, the sensor), which is what we were looking at.

It’s looking like I’m going to be swamped today and tomorrow, but I’ll try to get around to playing around with this if I can find some time later in the week.

Ticking sound coming from a .pkg package? Don't let the .bom go off! Inspect it first with Pacifist. Macworld - five mice!
     
Posting Junkie
Join Date: Nov 2000
Location: in front of my Mac
Status: Offline
Reply With Quote
Dec 7, 2009, 12:11 PM
 
Originally Posted by CharlesS View Post
Yes, but when you do this, main screen turn on (what you say!!). You can see this by looking at the translucent Apple logo on the top of the case, which is behind the screen. It lights up, because of the screen’s backlight.
No, but that's exactly what I'm trying to point out! You can get the internal display to remain *off* even though the MBP is running in closed-lid mode and there's no display attached to the video port. This is not how it's supposed to work, but I can reproducibly get it to behave that way.

But I see that the OP would rather have us discuss his problem than the subtleties of closed-lid mode. Fair enough I guess. So I'll shut up now.
     
Senior User
Join Date: Oct 1999
Location: Austin, TX 78751
Status: Offline
Reply With Quote
Dec 7, 2009, 12:52 PM
 
Originally Posted by Simon View Post
But I see that the OP would rather have us discuss his problem than the subtleties of closed-lid mode. Fair enough I guess. So I'll shut up now.
Thanks, Simon! I'm most interested in hearing from someone else with a similar configuration who either does or does not experience the problem.

I'm wondering what my next step is -- I'm at a loss as to what to do.
     
Posting Junkie
Join Date: Nov 2000
Location: in front of my Mac
Status: Offline
Reply With Quote
Dec 7, 2009, 12:55 PM
 
I didn't want to derail your thread. Sorry about that. I understand you're frustrated with this problem and finally want it fixed. Unfortunately at this point I have nothing more I can suggest you try. However, I'm also not so sure I understand what exactly the problem is at this point. Could you summarize quickly where we are by now? Maybe something else will come to my mind. At least I can promise I'll try.
     
Senior User
Join Date: Oct 1999
Location: Austin, TX 78751
Status: Offline
Reply With Quote
Dec 7, 2009, 01:04 PM
 
Here's the summary: I routinely disconnect the cinema display from my MBP daily (operating in closed-lid mode) in order use the MBP with its built-in display only. After a few days of doing this (and no intervening restarts), I'll disconnect the Cinema Display, allow the MBP to recognize the internal display and turn it on (your method makes no difference), but when I close the lid the MBP won't sleep. In other words, with no external display connected, the MBP will no longer sleep when the lid is closed. If I then restart the MBP -- without any external display connected -- my MBP will sleep properly when the lid is closed. That is the workaround.
( Last edited by Le Flaneur; Dec 16, 2009 at 01:48 PM. Reason: better explanation)
     
Senior User
Join Date: Oct 1999
Location: Austin, TX 78751
Status: Offline
Reply With Quote
Dec 16, 2009, 12:29 PM
 
I thought that the 1.8 firmware update might help (since it changes behavior after wake from sleep), but it didn't

What should my next step be? I wish I knew which files were involved, but perhaps its a pure hardware interaction? I actually have another MBP, so I could swap the hard disks and see whether it makes a difference. Apple tech support recommends either a clean install or creating a separate partition onto which I would install a clean system.
     
Posting Junkie
Join Date: Dec 2000
Status: Offline
Reply With Quote
Dec 16, 2009, 02:24 PM
 
Swapping the hard disks seems like a good thing to try — that could let you know whether or not it's your MBP's hardware that's causing the issue.

If you want to do the same thing with a little less work, you could get a FW800 cable (or a clear one if you prefer), connect the two MBPs using FireWire Target Mode, and boot one directly off the other's hard disk.

Ticking sound coming from a .pkg package? Don't let the .bom go off! Inspect it first with Pacifist. Macworld - five mice!
     
Senior User
Join Date: Oct 1999
Location: Austin, TX 78751
Status: Offline
Reply With Quote
Dec 16, 2009, 02:34 PM
 
That's a good idea, but it usually takes a few days of operation for the problem to occur, and it would be a bit of a pain to carry two conjoined laptops around for that time.
     
Posting Junkie
Join Date: Dec 2000
Status: Offline
Reply With Quote
Dec 16, 2009, 02:53 PM
 
Then swapping the hard drives probably isn't a bad thing to try. Just get a TORX T6 screwdriver and you're all set.

Ticking sound coming from a .pkg package? Don't let the .bom go off! Inspect it first with Pacifist. Macworld - five mice!
     
Senior User
Join Date: Oct 1999
Location: Austin, TX 78751
Status: Offline
Reply With Quote
Dec 16, 2009, 06:41 PM
 
Originally Posted by CharlesS View Post
Swapping the hard disks seems like a good thing to try [snip]

If you want to do the same thing with a little less work, you could [snip] connect the two MBPs using FireWire Target Mode, and boot one directly off the other's hard disk.
A MBP won't operate in FW Target mode with the lid closed, will it? So I'd have to keep both open?
     
Posting Junkie
Join Date: Dec 2000
Status: Offline
Reply With Quote
Dec 16, 2009, 07:01 PM
 
The MBP that was operating as a hard drive would probably have to have the lid open, but the other machine (which would be the one you'd be testing) would be able to be used as normal.

Ticking sound coming from a .pkg package? Don't let the .bom go off! Inspect it first with Pacifist. Macworld - five mice!
     
Senior User
Join Date: Oct 1999
Location: Austin, TX 78751
Status: Offline
Reply With Quote
Dec 16, 2009, 07:05 PM
 
Duh. Thanks!
     
Posting Junkie
Join Date: Nov 2000
Location: in front of my Mac
Status: Offline
Reply With Quote
Dec 17, 2009, 03:41 AM
 
It's worth a try though. Obviously it has to be open so you can turn it on and press the key combo, but once it displays the FW logo on the screen you should try closing it and see what happens. Maybe the screen stays on (displaying just the FW logo), but I'm not so sure closing the lid will sleep it. Assuming it's plugged in, what is there to sleep anyway? The computer's not really on. It's just running the disk and the FW controller and there's power for that.

I'm kind of busy right now, but I'll see if I can try it later. I'll report back.

Word of caution if you decide to try this though. Don't close the lid while actually copying important stuff. If closing the lid indeed sleeps the MBP the file transfer will be botched.
     
 
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 04:28 AM.
All contents of these forums © 1995-2015 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2015, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2