Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Software - Troubleshooting and Discussion > Applications > Copying and pasting text in own Textedit document sometimes indents paragraphs of ...

Copying and pasting text in own Textedit document sometimes indents paragraphs of ...
Thread Tools
Mac Elite
Join Date: Feb 2004
Location: Excellent, the sports issue is within arm's reach, I'll be here all day.
Status: Offline
Reply With Quote
Jan 22, 2009, 06:43 PM
 
Copying and pasting text in own Textedit document sometimes indents paragraphs of my texts and puts bullets by them


Guys, every now and then, Textedit has this weird problem of changing entire paragraphs of text on me whenever I copy something that's in that document and then paste it in the same document, but only in random sections or paragraphs of the document. In order to get around this problem, I'm supposed to use this Paste and Match Style paste option from the Edit menu to circumvent this problem.

But this problem doesn't always even happen altogether, just sometimes.

I can't seem to find any settings to turn it off, either in Preferences, or in my menus. But I don't want to convert everything into plain text and then reconvert into rich text to fix the problems in the document, because inside of my Textedit document are paragraphs of text in different fonts and sizes that I need to save as is... and in most of my other such documents where I have different fonts and sizes of text in paragraphs where I do such said copying and pasting, the problem does not pop up. It's just in some documents, in some locations within the document.

What's going on?


I tried searching this forum for:
Textedit paste indent
Textedit paste
Textedit bullet
Textedit indenting

but none of these search terms turned up threads regarding this problem.


I also tried searching on MacRumors forums for:
Textedit paste

but that didn't work.

Searching the internet in general did not work.

Note: I'm easily the slowest/worst searcher in the universe, because I'm seriously trying to locate threads about this topic, and after looking at the results, I claim that one does not exist... and yet someone else will dig it up in like 5 minutes. But does anyone know how this problem can be fixed?

No, I want to still use the NORMAL PASTE routine: Command-V, I have a ton of things to paste.
No, I should not have to do a Find/Replace every single time I do a normal pasting, that's B.S.

What's going on?
     
Moderator
Join Date: Oct 2001
Location: San Jose, CA
Status: Offline
Reply With Quote
Jan 22, 2009, 08:18 PM
 
Can you explain again exactly what the problem is? It's not very clear. You copy from one part of a doc to another and what happens? You lose formatting? How about a step by step of what you are doing that is not working?

Steve
Celebrating 10 years and 4000 posts on MacNN!
     
And.reg  (op)
Mac Elite
Join Date: Feb 2004
Location: Excellent, the sports issue is within arm's reach, I'll be here all day.
Status: Offline
Reply With Quote
Jan 23, 2009, 02:13 PM
 
Let's say that I have 4 paragraphs of text.

Paragraph 1. I type whatever into it.
Paragraphs 2-4: Pasted into the document from somewhere else. (May or may not have same text, font, and size.)
Paragraphs 5-6. I type whatever into it.
Paragraphs 7-8: Also pasted. Not necessarily the same as Paragraph 2.

If I copy text from Paragraph 1 into Paragraph 1, then it's fine. Same for 5 or 6 into 5 or 6.
If I copy text from Paragraph 2, 3, or 4 into Paragraph 2, 3, or 4, then most of the time it is fine. But other times, let's say that I paste the text into line 4 of paragraph 3. Then all lines from that line up in the paragraph through the space in between Paragraphs 1 and 2 (but not including Paragraph 1) will be indented:

[empty space] (bullet point) [slightly smaller empty space]

but Paragraphs 5 and on will be fine.

If I copy text from Paragraph 7 or 8 into Paragraph 7 or 8, then most of the time it is fine. But again, not always. In this case, all lines from that line up in the paragraph through the space in between Paragraphs 6 and 7 (but not including Paragraph 7) will be indented. Meanwhile, all paragraphs before 7 will be unaffected, and all paragraphs after 8 will not be affected.


If I copy text from paragraph 7 or 8 into paragraph 5 or 6, then, sometimes, the indenting occurs, but for most documents, it won't.



(Also, I'm having this weird issue with the spacebar, in which typing a space will, 1 out of every 1000 or so types, will type a space that is formatted differently. For instance, when I write up code in Taco HTML Edit, I will type a paragraph, just like this, but then when I go to save my document, I get a warning that my document needs to be saved with a different format. I figured that maybe I typed a ` instead of a ' or something like that, but, nope, the spacebar did not type correctly on the screen. I color coded the w in this paragraph to use the space immediately to its left as the example "mistyped" space, and I would have to go through my document, line by line, character by character, to find the misformatted space, deleteit, just like that, and then retype it, then the document can be saved correctly.)

^^ Could this problem be related to it?



Also, an issue about my Finder... this has been going on since upgrading to 10.5, and reinstalling my system software doesn't fix it. Whenever I drag a file over to another window, maybe 1 out of every 30 times, after I unclick to signal the "drop" motion, the file icon will remain on the screen for a few seconds, or until I click somewhere else. Also, sometimes, my arrow keys become completely disabled when I'm trying to navigate menu items in multicolumn Finder view. Are all these problems related uniquely, and has anyone else experienced these kinds of issues?
( Last edited by And.reg; Jan 23, 2009 at 06:52 PM. )
     
Moderator
Join Date: Oct 2001
Location: San Jose, CA
Status: Offline
Reply With Quote
Jan 24, 2009, 05:17 PM
 
OK, wow, I'm completely lost by your description. I still can't picture exactly is going on. How about a screenshot or typing in exactly what you are seeing? Also, adding extra, unrelated questions into this makes it even more confusing. Create separate topics in the forum and I'm sure you'll get more responses.

In any case, if we are talking about TextEdit (this is just TextEdit we're talking about, not Word or some other editor?), have you tried turning off Smart Copy/Paste in the preferences?

What does a ' or ` have to do with the spacebar? I don't understand this part of your question at all. And what is a mistyped space? A space is a space.

Also, there is no indication of what computer you are using, what OS you are using, and whether you are using an internal keyboard on a portable, or an external keyboard.

If you can fill in some more of the blanks (or "mistyped spaces") maybe I and others can help.

Steve
Celebrating 10 years and 4000 posts on MacNN!
     
Grizzled Veteran
Join Date: Mar 2004
Status: Offline
Reply With Quote
Jan 24, 2009, 07:08 PM
 
Originally Posted by Andrej View Post
Paragraphs 2-4: Pasted into the document from somewhere else. (May or may not have same text, font, and size.)
Could "from somewhere else" be a web page? Much of the html there contains lists or tables. TextEdit will pick up on that formatting, and try to preserve as much as it can (if you're working in a "rich text" document). I don't know if there's any formal way of addressing that phenomenon... just have to play with the formatting. Select the bad text, drop down the ruler, and set the 'Lists' popup to 'None' for example.
-HI-
     
Posting Junkie
Join Date: Dec 2000
Status: Offline
Reply With Quote
Jan 24, 2009, 07:19 PM
 
Try using Edit -> Paste and Match Style instead of Edit -> Paste. That will remove any formatting attached to the text you are pasting and make it use the current style settings instead.

If you use this option a lot, you can remap the keyboard shortcuts in System Preferences -> Keyboard and Mouse so that Command-V does Paste and Match Style and some other shortcut of your choosing does the regular Paste (according to TextEdit's .nib file, the default shortcut for Paste and Match Style is ⌘-option-shift-V).

Ticking sound coming from a .pkg package? Don't let the .bom go off! Inspect it first with Pacifist. Macworld - five mice!
     
And.reg  (op)
Mac Elite
Join Date: Feb 2004
Location: Excellent, the sports issue is within arm's reach, I'll be here all day.
Status: Offline
Reply With Quote
Jan 25, 2009, 04:25 PM
 
iMac G5 1.6 GHz
Mac OS X 10.5.6 (been a problem since 10.5)


Originally Posted by ibook_steve View Post
have you tried turning off Smart Copy/Paste in the preferences?
Doing so did not fix the problem.

And what is a mistyped space? A space is a space.
It should be. But, as I said, sometimes, like 1 out of every 1000 times, the computer will take my spacebar input and translate it into the normal space, but with this weird extra formatting that I don't see that only pops up when I save the document. Here's what would happen in, say, TacoHTMLEdit if a space gets misinterpreted:

This file contains characters that cannot be saved with the ASCII text encoding. You can save the file with the UTF8 encoding and include the following meta tag for browsers to read:
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">

Do you want to use the UTF8 encoding to save this file?
To get around the problem, I have to go seek out word by word where the problematic, mistyped space is and retype it. Then I can save the document without getting that error.

But this isn't a problem with TacoHTMLEdit, it's a problem in general. Maybe it's related.


Here's what the indenting problem looks like:

[Edit: I cannot place an example of the indenting directly here, because vBulletin collapses extra whitespace. I have to use the code tag:]

Code:
• Indented text • • iMac G5 1.6 GHz • Mac OS X 10.5.6 (been a problem since 10.5) • • • • I would paste something down here and for whatever reason, bunches of lines above it would be indented with bullets. This kind of problem is difficult for me to search for on the internet, because using the correct keywords returns unrelated problems. I am copying private communications from university software, and therefore I cannot post a screenshot of the actual text. • • Has NO ONE seen this happen before? •

But, again, I've copied stuff from that same university software before, and I have not had this problem pop up with 95% or so of my documents. Just every now and then.
     
Clinically Insane
Join Date: Oct 2000
Location: Los Angeles
Status: Offline
Reply With Quote
Jan 25, 2009, 04:50 PM
 
It sounds like there's extra formatting coming from the university server that's screwing things up. Without being able to see what you're actually working with, it's difficult to say for sure what the issue is or offer a fix. Have you tried a word processor other than TextEdit?

"The natural progress of things is for liberty to yield and government to gain ground." TJ
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 11:41 PM.
All contents of these forums © 1995-2014 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2014, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2