Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Software - Troubleshooting and Discussion > Applications > iPhoto won't connect to Photostream

iPhoto won't connect to Photostream
Thread Tools
Mac Elite
Join Date: Aug 2005
Location: Vancouver, BC
Status: Offline
Reply With Quote
Jan 25, 2013, 11:04 PM
 
Running Mountain Lion.

I created a new user and wanted to migrate my iPhoto library over to it. Just did a simple copy. Everything works fine except that I can't connect to Photostream with this new user.

I've tried logging out of iCloud and deleting the iCloud keychain entries, the logging back in but that didn't help.

I opened up console and see that I'm getting the following errors when iPhoto tries to connect:

__________________________________________________ __________

2013-01-25 7:34:26.918 PM iPhoto[43647]: Timeout launching photo stream agent

2013-01-25 7:34:26.941 PM com.apple.AppSandboxSMLoginItemEnabler[43658]: FAILURE: Failed to open property list at file://localhost/private/var/db/launchd.db/com.apple.launchd.peruser.504/overrides.plist for reading. (The operation couldn’t be completed. No such file or directory)

2013-01-25 7:34:26.950 PM com.apple.AppSandboxSMLoginItemEnabler[43658]: FAILURE: Failed to write property list at file://localhost/private/var/db/launchd.db/com.apple.launchd.peruser.504/overrides.plist. (The operation couldn’t be completed. No such file or directory)

2013-01-25 7:34:26.956 PM com.apple.AppSandboxSMLoginItemEnabler[43658]: FAILURE: Could not repair overrides database: 0x2

2013-01-25 7:34:26.966 PM com.apple.AppSandboxSMLoginItemEnabler[43658]: FAILURE: Failed to open property list at file://localhost/private/var/db/launchd.db/com.apple.launchd.peruser.504/overrides.plist for reading. (The operation couldn’t be completed. No such file or directory)

2013-01-25 7:34:36.918 PM iPhoto[43647]: Timeout launching photo stream agent

__________________________________________________ __________

504 is the UID for my user, so I went and looked in launched.db and sure enough there isn't a file there for my user (though there are 18 other ones).

Am I on the right track? Any ideas what to do next to sort this out?

Thank you!
     
Mac Elite
Join Date: Aug 2005
Location: Vancouver, BC
Status: Offline
Reply With Quote
Jan 28, 2013, 02:39 AM
 
Huh, suddenly today it started working - I decided to try enabling photostream again and it connected. Went and checked launcehd.db and now there's a peruser.504.....no clue what happened but I guess I'll take it!
     
Clinically Insane
Join Date: Nov 1999
Location: 888500128, C3, 2nd soft.
Status: Offline
Reply With Quote
Jan 28, 2013, 01:16 PM
 
My iPhoto had difficulty on January 26th, as well. Last synched photo from Photo Stream was from the 25th (early a.m. US time).
Worked fine again yesterday evening (27th).
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 01:39 PM.
All contents of these forums © 1995-2014 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2014, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2