Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Software - Troubleshooting and Discussion > Applications > question about Activity Monitor CPU Usage cores

question about Activity Monitor CPU Usage cores
Thread Tools
Forum Regular
Join Date: Nov 2005
Location: MA
Status: Offline
Reply With Quote
Jun 25, 2013, 10:14 PM
 
So Activity monitor measures CPU Usage in a nifty little rolling series of green and red dots piled on top of each other to measure the amount of CPU usage. It looks a little bit like a stock ticker.

On systems with more than one core, it has one of these CPU usage graphs for each core.

See: OS X: Activity Monitor shows one CPU Usage graph on systems with more than four cores

But my 15" rMBP i7 with 4 cores only shows one graph in the activity monitor.
And my 11" MBA i7 with 2 cores shows four graphs in the activity monitor.

Can anyone explain to me what is the reason for this discrepancy? Thanks!
     
P
Moderator
Join Date: Apr 2000
Location: Gothenburg, Sweden
Status: Offline
Reply With Quote
Jun 26, 2013, 05:20 AM
 
Both your Macs have Hyperthreading, a feature that makes each processor core appear as two to the operating system. To the operating system, your 11" MBA has 4 cores and your MBP has 8. Presumably Activity Monitor defaults to only showing one graph when you have 8 cores, because it would confusing otherwise. There's probably a setting to override it in one of the menus.
The new Mac Pro has up to 30 MB of cache inside the processor itself. That's more than the HD in my first Mac. Somehow I'm still running out of space.
     
Forum Regular
Join Date: Nov 2005
Location: MA
Status: Offline
Reply With Quote
Jun 26, 2013, 08:33 AM
 
Ah, ha. THX!!!
     
Addicted to MacNN
Join Date: Mar 2004
Location: UK
Status: Offline
Reply With Quote
Jun 28, 2013, 04:34 AM
 
My 8 core Xserve shows all 8 cores.
I have plenty of more important things to do, if only I could bring myself to do them....
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 04:07 AM.
All contents of these forums © 1995-2014 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2014, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2