Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Enthusiast Zone > Art & Graphic Design > PDF forms and Preview

PDF forms and Preview
Thread Tools
Moderator
Join Date: Aug 2001
Location: North Muncietucky
Status: Offline
Reply With Quote
Dec 19, 2013, 06:47 PM
 
I have a real head-scratcher here.
I had to build a PDF form for a client. It's a single page questionnaire with a healthy mix of text fields and check boxes. The purpose is to have their clients grab it off the website, fill it in, and email it back. No biggie.

So, I build the form and test it using both Adobe Reader and Preview. Works great. I get an email from both apps containing a filled-in form. So I send it to my client.

My client reports that, using Preview, she can fill-in the text fields and check the boxes, but, when she emails it, it arrives with just the text fields filled. The check boxes are now un-checked.

The only difference I can determine, between their setup and mine, is that I am still on OSX 10.6.8, and their office is on 10.8. Has anyone else seen this sort of issue with how Preview in 10.8 treats PDF forms? I'm at a loss as to what could be wrong.
     
Moderator
Join Date: Jun 2000
Location: inside 128, north of 90
Status: Offline
Reply With Quote
Dec 20, 2013, 11:27 AM
 
Haven't seen it, but then, have not done many forms lately.

if you want to send to me, I could try. On 10.7. PM for addy.
     
Moderator
Join Date: Jun 2000
Location: inside 128, north of 90
Status: Offline
Reply With Quote
Dec 20, 2013, 12:50 PM
 
In Preview, a user is able to select multiple checkboxes (both m and f, for example) so those instances should be toggle/radio buttons. Other places the multiple choice makes sense.

If I fill in the forms in preview, then open in adobe, the forms LOOK empty but the checkboxes are still checked. When I click on a field the data reappears.
If I open in preview, it's as your user stated, text is there but boxes are unchecked.

there also seems to be two types of things happening to the checkboxes, a solid fill, and a check over a small square.

In adobe, I get an error that it can't find the right type of Helvetica. "Cannot find or create the font 'Helvetica'. Some characters may not display or print correctly." Which prob explains why the text does not display. I do have a bunch of helveticas, but possibly not yours.
     
Moderator
Join Date: Aug 2001
Location: North Muncietucky
Status: Offline
Reply With Quote
Dec 20, 2013, 01:06 PM
 
Interesting. I get none of those problems. The Helvetica thing is also strange, since the text fields are set to default to Arial.
Gah. I hate making forms.
     
Administrator
Join Date: Jun 2000
Location: California
Status: Offline
Reply With Quote
Dec 20, 2013, 01:36 PM
 
Perhaps the check-mark is a Helvetica character, from a little-used variation.
     
   

Tags
forms , pdf , preview
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 12:57 AM.
All contents of these forums © 1995-2015 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2015, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2