Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Software - Troubleshooting and Discussion > Mac OS X > Set time zone automatically: a bunch of hooey!

Set time zone automatically: a bunch of hooey!
Thread Tools
Moderator
Join Date: Oct 2001
Location: San Jose, CA
Status: Offline
Reply With Quote
Feb 23, 2013, 02:07 PM
 
On my 2010 MBP, this option simply does not work. The time is set correctly automatically, but auto time zone detection does not. Is it just me?

Steve
Celebrating 10 years and 4000 posts on MacNN!
     
Administrator
Join Date: May 2000
Location: California
Status: Offline
Reply With Quote
Feb 23, 2013, 02:47 PM
 
I expect it works by loading an Apple server, which geolocates you via your IP address. If you use a VPN service, you'd have the same final IP address regardless of your location. It would likewise fail if your IP range is a new one, not in their files.

I've tried it on one cross-country trip. I think it worked; I don't specifically recall having to reset the time zones. But it's also been awhile since.
     
Moderator
Join Date: Oct 2001
Location: San Jose, CA
Status: Offline
Reply With Quote
Feb 24, 2013, 12:47 AM
 
I travel across the country quite a bit and it never works. Could it be the hotel wi-fi networks that are the problem? Then again, I've tried it at the sites I visit (when I'm working) and it still doesn't seem to work or even when I come home. Oh well. Not a huge deal, just annoying.

Steve
Celebrating 10 years and 4000 posts on MacNN!
     
Administrator
Join Date: May 2000
Location: California
Status: Offline
Reply With Quote
Feb 24, 2013, 02:31 AM
 
Delete your Date and Time pref file? Sometimes the old tricks are the best ones.
     
Grizzled Veteran
Join Date: Dec 2001
Location: Land of Enchantment
Status: Offline
Reply With Quote
Feb 24, 2013, 01:54 PM
 
Never worked for me either, not just in hotels, but also at my best friend's house who the exact same router as I have at home.
     
Moderator
Join Date: May 2001
Location: Hilbert space
Status: Offline
Reply With Quote
Feb 24, 2013, 09:56 PM
 
This has worked fine for me. Are you sure you have location services enabled, though? These can be found in the Security & Privacy > Privacy section of the Sys Prefs.
I don't suffer from insanity, I enjoy every minute of it.
     
Moderator
Join Date: Oct 2001
Location: San Jose, CA
Status: Offline
Reply With Quote
Feb 25, 2013, 06:02 PM
 
Yes Location Services are enabled. What locations have you been at where it worked?

Steve
Celebrating 10 years and 4000 posts on MacNN!
     
Moderator
Join Date: May 2001
Location: Hilbert space
Status: Offline
Reply With Quote
Feb 25, 2013, 11:16 PM
 
Originally Posted by ibook_steve View Post
Yes Location Services are enabled. What locations have you been at where it worked?
Phew, I've been traveling a lot, lot: everywhere in Europe, including more exotic countries such as Romania, South Korea, Japan, Chile, etc. I've never had a problem with that, to be honest, and I'm a bit surprised.
I don't suffer from insanity, I enjoy every minute of it.
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -5. The time now is 11:15 AM.
All contents of these forums © 1995-2013 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.7 © 2000-2013, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2