Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Enthusiast Zone > Networking > G4 Cube: 100 Mbps Ethernet (almost) dead, but 10 Mbps works just fine

G4 Cube: 100 Mbps Ethernet (almost) dead, but 10 Mbps works just fine
Thread Tools
Posting Junkie
Join Date: Jun 2003
Location: Dangling something in the water… of the Arabian Sea
Status: Offline
Reply With Quote
May 31, 2005, 07:37 PM
 
So I was surfing along today at work where I have my Cube, and was using Transmit hooking up to .Mac.

I don't know if it did something to my networking, because now internet access with my 100 Mbps Ethernet connection (thru a Linksys switch, hooked up to my workplace's network) suddenly is EXTREMELY slow. It had been working just fine for several days before that.

I tried switching ports on the switch. No difference.

I tried a new cable. Exactly the same.

Tried rebooting. No improvement.

Tried connecting through wireless (Linksys switch --> SMC wireless router). Works fine.

Then I went into the network settings and turned off 100 Mbps Ethernet support and manually forced it to 10 Mbps. Works 100% fine. Everything is speedy again.

So, I now know my network jack isn't dying, but why won't it work properly at 100 Mbps?
My PC is on the same switch, and works fine with a 100 Mbps connection.
     
Admin Emeritus
Join Date: Oct 1999
Location: Zurich, Switzerland
Status: Offline
Reply With Quote
Jun 1, 2005, 08:05 PM
 
Did you try rebooting the switch? I've seen them crash and start misbehaving.

Also, did you try a different cable? (I know, unlikely, but it's easy enough to test.)

tooki
     
Administrator
Join Date: Apr 2001
Location: San Antonio TX USA
Status: Offline
Reply With Quote
Jun 1, 2005, 09:47 PM
 
The cable between the switch and the company network is one possible culprit-swap it out with a BRAND NEW cable and see if there's any difference. If not, use the same brand new cable between the switch and your computer. If you can, try connecting directly to the office network with the brand new cable. That will indicate whether or not the Linksys box has anything to do with the problem.

Glenn -----OTR/L, MOT, Tx
     
Clinically Insane
Join Date: Oct 2000
Location: Los Angeles
Status: Offline
Reply With Quote
Jun 2, 2005, 05:18 AM
 
How did you force it down to 10Mb, EW?

"The natural progress of things is for liberty to yield and government to gain ground." TJ
     
Admin Emeritus
Join Date: Oct 1999
Location: Zurich, Switzerland
Status: Offline
Reply With Quote
Jun 3, 2005, 06:18 PM
 
In Panther and higher, it's right in the Network settings.
Go to the settings for the ethernet port, click the Ethernet tab, and then change the "Configure: " menu from Automatically to Manually. All the settings will appear.

tooki
     
   
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 07:35 AM.
All contents of these forums © 1995-2015 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2015, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2