Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Enthusiast Zone > Networking > Mac OS X internet sharing with Playstation 3 problems

Mac OS X internet sharing with Playstation 3 problems (Page 2)
Thread Tools
Fresh-Faced Recruit
Join Date: Oct 2008
Status: Offline
Reply With Quote
Oct 22, 2008, 06:18 PM
 
I finally got my PS3 to connect to the internet using the built-in airport card. Here is what I did.

Turn on Internet Sharing. If you don't know how to do that then ask me and I will walk you through that as well.
Open Terminal and type this exactly as shown:

cp /etc/bootpd.plist /tmp/bootpd.plist

Hit the Return key. It may seem as though nothing has happened. That's okay.

Turn Internet Sharing off.

Go back to the Terminal window and type:

open -e /tmp/bootpd.plist

Hit the Return key. A file will open in TextEdit. Locate this section of the file, near the end:

<key>reply_threshold_seconds</key>
<integer>4</integer>

Change 4 to 0 and then hit Command+S to save the file.

Go back to the Terminal Window and type:

sudo cp /tmp/bootpd.plist /etc

You will need to know the administrator password. If you do not have one set up, then you might need to set one up first. You will be warned that this could be dangerous. I don't know what any of this is doing, but it worked. So if it messed up my computer, I can't tell because everything seems to be working perfectly.

Okay. After you enter the password, hit the Return key.

Turn Internet Sharing back on.

Now. Go over to your PS3 and set up a wireless connection the "easy" way. It said it was checking some network configurations or something like that and then it brought me to the SSID screen. I chose Manual and selected my access point that was already in there from before and then typed in my WEP password. Then I moved on and let it do everything automatically and it worked! Try it out. Let me know if this helps or if I need to clarify something that didn't make sense.
     
Fresh-Faced Recruit
Join Date: Nov 2008
Status: Offline
Reply With Quote
Nov 20, 2008, 03:03 PM
 
Okay, so I know this thread is old, but up to last month nobody had posted a solution to using the internal airport card to share the connection so I said i'd register incase anyone else was googling endlessley to find a solution.

Turn on Internet sharing:
select the network you want to share and share it via airport and give your network a name... set up a 5 digit WEP key if you want protection.

open terminal and type ifconfig en1
This will give you your router number, mine was 10.0.2.1, it will be listed next to the word inet
next type dig, this will give you your ISP's DNS numbers (at the very bottom, next to the word server)

On your PS3 open the network settings, scan for your new network, enter the WEP key and configure the IP manually.

Under IP type the router number but add a digit to the last number, in other words, my router was 10.0.2.1, so I assigned my PS3 the IP 10.0.2.2
use the standard subnet mask of 255.255.0.0
enter the router number you found (10.0.2.1)
enter the DNS numbers found earlier.

MTU = Auto
Proxy Server = Do Not Use
UPnP = doesnt make a difference

and thats it, your done... im using my PS3 with my 3G mobile broadband shared via airport.

EDIT: After a PM I realised I completely left out the Airport settings part.

In Airport settings under TCP/IP select configure IPv4 via DHCP, and under DNS add your ISP's DNS numbers that you found earlier.
( Last edited by Tetsuo_83; Nov 22, 2008 at 11:47 AM. Reason: Missed a step.)
     
Fresh-Faced Recruit
Join Date: Nov 2006
Status: Offline
Reply With Quote
Dec 2, 2008, 01:26 AM
 
Here's my situation:

• I have two PCs and one MacBook Pro - all wirelessly accessing my Airport Extreme router.

• I've been able to connect my PS3 to the Internet but I cannot "see" the PS3 on my Mac (and vice versa). Also, I cannot "see" the PS3 from either PC. I can see each PC from the PS3 but cannot access anything on them.

• I have a Fat32-formatted HD attached to my router that I can access (read/write) from all computers but I cannot "see" it on my PS3.

I'd like to use my PS3 as a media server, but not sure how since I can't access it from my Mac.

Comments?
     
Fresh-Faced Recruit
Join Date: Dec 2008
Status: Offline
Reply With Quote
Dec 12, 2008, 03:23 PM
 
I have everyones answer. It took some digging to figure out, but this is the resolution for ALL of the above problems.

Before I give the answer, I'll first state the problem. Mac producs suck. Sorry if that offends anyone lol. But a Linksys router with a Linux Firmware upgrade (DD WRT) totally rapes the crap out of Airport/TimeCapsule products.

So now that I got that off my chest....
Your answer is: 41952

What does one do with that number, one might ask?
Forward that port for every IP address of every device you wish to communicate with.
That means every computer, every networked hard drive, printer, etc.

This works because the gay ass TimeCapsule doesn't support uPNP protocol - because it's gay. Nuff said. So, to fix this ,forward that port, and you can communicate from/to PS3 from/to any device connected to network... wired or wireless.

I have tested this with my networked hard drive(Not the one on the time capsule itself. Because, once again, mac producs suck wang, so of course, only computers can access the timecapsule hard drive. Pretty damn redundant if you ask me. But no one asked, so I hold my peace and just mumble it under my breath.) as well as my networked printer, and both my Vista laptop and my windows XP desktop computer. I also tried my roomates macbook. It all works. My other roomates Windows O/S Palm/handheld works as well for music and pics. I have not tested iPod or iPhone.

Forward that port, and you guys are all set.
enjoy.
( Last edited by dcyuri7; Dec 12, 2008 at 03:30 PM. )
     
Administrator
Join Date: Apr 2001
Location: San Antonio TX USA
Status: Offline
Reply With Quote
Dec 12, 2008, 06:00 PM
 
Originally Posted by dcyuri7 View Post
I have everyones answer. It took some digging to figure out, but this is the resolution for ALL of the above problems.
.....
Forward that port, and you guys are all set.
enjoy.
Welcome to our forums! I do have to take issue with your assertion that uPNP is the be all and end all of network configuration. In fact, it's an awful security problem if you haven't gone through every device and ensured that someone outside your network can't do anything with your hardware via uPNP.

I'd also watch calling things "gay." Maybe you're not happy with Apple's design decisions, but that doesn't have anything to to with "gay."

Glenn -----OTR/L, MOT, Tx
     
Baninated
Join Date: Dec 2008
Status: Offline
Reply With Quote
Dec 27, 2008, 12:06 PM
 
Thank you Jtrenda33. After 2 days of trying every solution I could find, yours did the trick. I suggest anyone experiencing the "DNS Error" while hooking up to a Mac try this out. Thanks again!
     
Fresh-Faced Recruit
Join Date: Dec 2008
Status: Offline
Reply With Quote
Dec 28, 2008, 10:19 AM
 
guys i hope i can help.

I almost lost hope looking for a solution for the DNS Problem of PS3 and Time Capsule but i found a solution.

I HOPE THIS WILL HELP. For all Time Capsule / AirExpress / AirPort users.

go to https://www.opendns.com/smb/start/device/apple-airport

Follow instructions there..

All IP's, masks, router address, and DNS Sercvers are all there (It's all above the DNS Server Boxes) ready to be input on your PS3 when you're configuring it.

It worked with my Time Capsule and PS3. I hope it will work with yours too.

More power to macnn.com!!!
( Last edited by Kiddomike; Dec 28, 2008 at 01:04 PM. Reason: INSTEAD OF POSTING A QUESTION AND COMPLAINING I FOUND A SOLUTION)
     
Fresh-Faced Recruit
Join Date: Dec 2008
Status: Offline
Reply With Quote
Dec 28, 2008, 01:22 PM
 
Okay so I've been trying to get this thing to work for a while, putting it off and kept coming back to it. Finally I got a game that needed a software update, so i had to get connected to the internet...

I saw all those complicated solutions and thought there should be an easier way, but that's not always true so I tried a few of them. I'm not really presenting any new info here but I just wanted to say which of the solutions worked for me, I guess it might not work for everyone.

By the way I have a cable modem hooked up to my imac, and am using a built-in airport with internet sharing and a WEP key.

The solution that ended up working for me was the one describing how to change "reply_threshold_seconds" in /etc/bootpd.plist from "4" to "0".

At first I wasn't getting an IP address or internet connection when I connected. Then I tried the solution listed above and not only did I not have to go through as many options in the PS3 internet connection setup (didn't ask me about proxy servers, dhcp, etc, i guess it just took the default on those?), but I did finally get an IP address. Now here's the weird part, I still didn't get an internet connection. I tried it several times on the PS3, then ended up deleting the bootpd.plist file and doing the procedure all over again. This time, it was perfect!

So in conclusion, I know it's very possible that one solution won't work for everyone's setup, but I found this to be the simplest solution and it actually worked. But I do recommend you try the whole process a couple times before deciding this one won't work for you, because that's what it took me. I know that sounds stupid and doesn't make any sense, you would think I changed something else in the between takes..i don't think I did but who knows.

It's such a good feeling when a seemingly intractable problem is suddenly solved..
     
Fresh-Faced Recruit
Join Date: Feb 2009
Status: Offline
Reply With Quote
Feb 5, 2009, 07:07 PM
 
jtrenda33, i signed up to this site just so i could thank you for your solution to my 3 day long quest... thank you thank you thank you !!!!
     
Fresh-Faced Recruit
Join Date: Mar 2009
Status: Offline
Reply With Quote
Mar 3, 2009, 06:51 PM
 
Alright, I just signed up here because I am having the same problem and have brought the issue to 3 forums and have had nothing. Here goes

Basically my neighbors have WEP encrypted WIFI network, which I have the pass to, they gave it to me to use. What I want to do is use the macbook to pick up the wifi and then port the signal via a crossover cable to the ps3.

I have done the internet sharing in system preferences. Share from wifi - to ethernet.

The solutions in here are all from a different way of doing this, share from ethernet - to wifi. So basically I am doing the reverse of what is done here.

Here is all of my information I have so far.

copied from terminal >

kevin-jansicks-macbook:~ kevinjansick$ sudo ifconfig en0
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULT ICAST> mtu 1500
inet 192.168.1.1 netmask 0xffffff00 broadcast 192.168.1.255
inet6 fe80::21e:c2ff:fe16:1bb7%en0 prefixlen 64 scopeid 0x4
inet 169.254.126.39 netmask 0xffff0000 broadcast 169.254.255.255
ether 00:1e:c2:16:1b:b7
media: autoselect (1000baseT <full-duplex>) status: active
supported media: autoselect 10baseT/UTP <half-duplex> 10baseT/UTP <full-duplex> 10baseT/UTP <full-duplex,hw-loopback> 10baseT/UTP <full-duplex,flow-control> 100baseTX <half-duplex> 100baseTX <full-duplex> 100baseTX <full-duplex,hw-loopback> 100baseTX <full-duplex,flow-control> 1000baseT <full-duplex> 1000baseT <full-duplex,hw-loopback> 1000baseT <full-duplex,flow-control> none

So, there are two inets... The second one has the same ip as my "outgoing" crossover cable to the ps3.

I just have had no luck at all. To see this problem from start to where I stand right now here is the link to the other forum. http://www.psu.com/forums/showthread...=1#post3938019

I will keep this checked at all times, and will be on here the rest of the night trying to figure this all out. Not much idea what I am doing.

Thanks in advance gurus for all your help!
( Last edited by Madkernel87; Nov 25, 2011 at 03:00 PM. )
     
Fresh-Faced Recruit
Join Date: Mar 2009
Status: Offline
Reply With Quote
Mar 3, 2009, 07:48 PM
 
This is basically what I am trying to do with all the info I have thus far. Please help someone Hell I would be willing to send a check at this point.
( Last edited by Madkernel87; Nov 25, 2011 at 02:59 PM. )
     
Addicted to MacNN
Join Date: May 2000
Location: Santa Rosa, CA
Status: Offline
Reply With Quote
Mar 3, 2009, 10:59 PM
 
Wouldn't it be easier to just buy a WiFi antenna booster for your neighbor's router? The 20% signal you're receiving on the PS3 should jump up quite a bit.

Nobody ever mentions my legendary sexual prowess.
     
Fresh-Faced Recruit
Join Date: Mar 2009
Status: Offline
Reply With Quote
Mar 5, 2009, 04:46 PM
 
hey jtrenda33 does this configuration work if i'm using an external airport extreme? also i may sound like a total dumbass here but which terminal exactly am i entering the first part into? the one that opens when i go into internet sharing?

p.s. for dcyuri7: what's with the whole this is gay and that is gay thing? what are you 12? can we try to conduct ourselves like adults here?
     
Moderator
Join Date: Oct 2001
Location: San Jose, CA
Status: Offline
Reply With Quote
Mar 5, 2009, 05:13 PM
 
Originally Posted by larold74 View Post
hey jtrenda33 does this configuration work if i'm using an external airport extreme? also i may sound like a total dumbass here but which terminal exactly am i entering the first part into? the one that opens when i go into internet sharing?

p.s. for dcyuri7: what's with the whole this is gay and that is gay thing? what are you 12? can we try to conduct ourselves like adults here?
Terminal is the Terminal application in the Utilities folder in the Applications folder.

Steve
Celebrating 10 years and 4000 posts on MacNN!
     
Fresh-Faced Recruit
Join Date: Mar 2009
Status: Offline
Reply With Quote
Mar 23, 2009, 03:05 PM
 
Originally Posted by jeliastam View Post
I got mine PS3 60gb to work with internet sharing on my macbook pro FINALLY. I am only using my built in airport extreme card to do the internet sharing. The router address i used was 10.0.2.1 and then you have to make up and IP address for the PS3 above 10.0.2.200, so like 10.0.2.217 or some number around there. otherwise you just take all the DNS addresses from the PS3 when it is connected directly to the dsl/cable modem. If this isn't as clear as i am tryign to make it, just post some questions and I will try to help you out

+1 worked for me too
     
Fresh-Faced Recruit
Join Date: Apr 2009
Status: Offline
Reply With Quote
Apr 1, 2009, 12:32 PM
 
...
( Last edited by Antirty; Oct 8, 2015 at 08:31 AM. )
     
Fresh-Faced Recruit
Join Date: Nov 2009
Status: Offline
Reply With Quote
Nov 22, 2009, 12:07 PM
 
I'd like to thank Tetsuo_83 for sharing what I wish I had read a year ago. Connection working perfectly. Thank you!
     
Fresh-Faced Recruit
Join Date: Nov 2009
Location: Torrance, CA
Status: Offline
Reply With Quote
Nov 29, 2009, 09:04 AM
 
Thanks to Tetsuo_83 for posting a solution that worked for me! I have an iMac Intel Core 2 Duo sharing internet with my PS3 via the built in airport.

Here is Tetsuo_83's post:

Originally Posted by Tetsuo_83 View Post
Okay, so I know this thread is old, but up to last month nobody had posted a solution to using the internal airport card to share the connection so I said i'd register incase anyone else was googling endlessley to find a solution.

Turn on Internet sharing:
select the network you want to share and share it via airport and give your network a name... set up a 5 digit WEP key if you want protection.

open terminal and type ifconfig en1
This will give you your router number, mine was 10.0.2.1, it will be listed next to the word inet
next type dig, this will give you your ISP's DNS numbers (at the very bottom, next to the word server)

On your PS3 open the network settings, scan for your new network, enter the WEP key and configure the IP manually.

Under IP type the router number but add a digit to the last number, in other words, my router was 10.0.2.1, so I assigned my PS3 the IP 10.0.2.2
use the standard subnet mask of 255.255.0.0
enter the router number you found (10.0.2.1)
enter the DNS numbers found earlier.

MTU = Auto
Proxy Server = Do Not Use
UPnP = doesnt make a difference

and thats it, your done... im using my PS3 with my 3G mobile broadband shared via airport.

EDIT: After a PM I realised I completely left out the Airport settings part.

In Airport settings under TCP/IP select configure IPv4 via DHCP, and under DNS add your ISP's DNS numbers that you found earlier.
     
Mac Elite
Join Date: May 2000
Location: I've moved so many times; I forgot.
Status: Offline
Reply With Quote
Dec 2, 2009, 06:28 PM
 
Yup, that worked for me also. I could connect to the Net just fine; however, my PS3 still wouldn't recognize my media server running off of Playback. Any suggestions?
"My friend, there are two kinds of people in this world:
those with loaded guns, and those who dig. You dig."

-Clint in "The Good, the Bad and the Ugly"
     
Fresh-Faced Recruit
Join Date: Feb 2010
Status: Offline
Reply With Quote
Feb 13, 2010, 08:53 AM
 
Originally Posted by ../ben View Post
Follow the instructions.

Use the PS3 to get all that info... Set up a wired connection, directly between the PS3 and DSL/Cable. Once that's set up and working, go to System Information and, I'm pretty sure, it will have totally different IP and DNS stuff. For example, my IP used to be 10.0.1.16 when it tried to connect wirelessly, and when I did a wired connection, the IP on the PS3 was 72.x.x.x!

Before today, I didn't know that 10.x.x.x wasn't my *real* IP address (it's the one handed out by the Airport once you have a network set up; if you had a LinkSys router, I bet your IP would have shown up as 192.186.1.x instead of 10.0.1.x). I also didn't know what DNS server my ISP was using. Honestly, I'm still not sure! All I know is that when I plugged in the numbers from "Step 2" (namely, the DNS server that shows up in the PS3 System Information when it's wired to the DSL directly), my PS3's wireless connection worked for the first time ever.

So, let's assume that that IS the DNS server used by your ISP (if for no other reason than to have a name for this special little guy). When you go to manually configure the PS3 for the wireless connection, when it asks for an IP address, that very same screen will ask you for router and DNS server numbers. Use the "ISP DNS server" numbers/address THERE!

Everything I know now came from information on the link I posted earlier. I tried going through the entire site there trying to set up Port Mapping, hoping that would work. But it didn't. So I started over from scratch, again. The error I was getting from the PS3 was in regard to DNS stuff, that's where I focused my attention. I knew that if I plugged the PS3 into the DSL directly, it worked. Honestly, I had NO IDEA what I was doing! I have NO IDEA why it worked now, or why it didn't work earlier; as far as I'm concerned, the damn thing should have worked right out of the box! Make no mistake about it, this whole thing is a bunch of crap! But it worked, and so I posted it hoping that it would be helpful. I'm using 10.4.8 as well.
good post man ur not alone.im using meteor 3g dongle internet it connects str8 to the macbook via usb port den connected mac to ps3 with internet wire. i went to"ethernet" on the mac and den shared it with my 3g dongle internet connection den tryed auto setup on ps3.no chance so i tryed the static/manual ip submask dns etc. i went to the terminal window and entered nslookup in the command this is ment to give me my dns address so tryed to use that address in the ethernet and ps3 just changing my ip on the ps3 by a few digts at the end of address.this is were im lost the ps3 succeeds on the ip address in test network but fails on the dns error (no communication with dns server) i asked an I.T guy that works in a local computer repair store he said just get your dns address and manualy put it into the connection and it shud be good to go.can any1 tell me were im going wrong i know im close to getting it connected cuz ive used this type of connection on my old windows xp no bother.the problems just shared the 3g internet with local area connedtion and im in.i cant understand why i cant just do the same thing on the mac.o and when i try the test network on ps3 an error on the macbook pops up saying"another device on the network is using the same ip address as my macbook its says to change the ip address of my mac or the other device so i tryed changing the ip but then the same error pops again and says the same thing as last error.please help im new to macbooks and im nearly sorry i bought the fecken thing is so complicated i think im going get rid of the mac and go back to good old windows xp tryed and trusted no stress
     
Fresh-Faced Recruit
Join Date: Apr 2010
Status: Offline
Reply With Quote
Apr 6, 2010, 10:05 AM
 
I was having trouble connecting my PS3 to my Mac Pro wirelessly through Internet Sharing. I came across this fix and I used it and everything seems to be working perfectly.

I finally got my PS3 to connect to the internet using the built-in airport card. Here is what I did.

Turn on Internet Sharing. If you don't know how to do that then ask me and I will walk you through that as well.
Open Terminal and type this exactly as shown:

cp /etc/bootpd.plist /tmp/bootpd.plist

Hit the Return key. It may seem as though nothing has happened. That's okay.

Turn Internet Sharing off.

Go back to the Terminal window and type:

open -e /tmp/bootpd.plist

Hit the Return key. A file will open in TextEdit. Locate this section of the file, near the end:

<key>reply_threshold_seconds</key>
<integer>4</integer>

+Change 4 to 0 and then hit Command+S to save the file.+

Go back to the Terminal Window and type:

sudo cp /tmp/bootpd.plist /etc

You will need to know the administrator password. If you do not have one set up, then you might need to set one up first. You will be warned that this could be dangerous. I don't know what any of this is doing, but it worked. So if it messed up my computer, I can't tell because everything seems to be working perfectly.

Okay. After you enter the password, hit the Return key.

Turn Internet Sharing back on.

Now. Go over to your PS3 and set up a wireless connection the "easy" way. It said it was checking some network configurations or something like that and then it brought me to the SSID screen. I chose Manual and selected my access point that was already in there from before and then typed in my WEP password. Then I moved on and let it do everything automatically and it worked! Try it out. Let me know if this helps or if I need to clarify something that didn't make sense.
     
Fresh-Faced Recruit
Join Date: Apr 2010
Status: Offline
Reply With Quote
Apr 7, 2010, 09:35 PM
 
my son just bought a ps3 120G - it recognizes my time capsule but want a WEP code. How do I find out what that is - or is there another way around this to connect the two wirelessly? BTW.....tech-savvy I am NOT......
Thanks!!
     
Administrator
Join Date: Apr 2001
Location: San Antonio TX USA
Status: Offline
Reply With Quote
Apr 7, 2010, 10:00 PM
 
Originally Posted by nicholsroadtrip View Post
my son just bought a ps3 120G - it recognizes my time capsule but want a WEP code. How do I find out what that is - or is there another way around this to connect the two wirelessly? BTW.....tech-savvy I am NOT......
Thanks!!
There's only a WEP code if YOU set it. WEP was a predecessor of WPA-although WEP was never really secure, it was used for some time. If your TC does NOT have a WEP encryption key set, you don't need to enter anything. If you have (and this is highly recommended) a WPA or WPA2 key set, then just enter that key when the PS3 asks for a key.

Glenn -----OTR/L, MOT, Tx
     
Fresh-Faced Recruit
Join Date: May 2010
Status: Offline
Reply With Quote
May 3, 2010, 12:13 PM
 
Originally Posted by Tetsuo_83 View Post
Okay, so I know this thread is old, but up to last month nobody had posted a solution to using the internal airport card to share the connection so I said i'd register incase anyone else was googling endlessley to find a solution.

Turn on Internet sharing:
select the network you want to share and share it via airport and give your network a name... set up a 5 digit WEP key if you want protection.

open terminal and type ifconfig en1
This will give you your router number, mine was 10.0.2.1, it will be listed next to the word inet
next type dig, this will give you your ISP's DNS numbers (at the very bottom, next to the word server)

On your PS3 open the network settings, scan for your new network, enter the WEP key and configure the IP manually.

Under IP type the router number but add a digit to the last number, in other words, my router was 10.0.2.1, so I assigned my PS3 the IP 10.0.2.2
use the standard subnet mask of 255.255.0.0
enter the router number you found (10.0.2.1)
enter the DNS numbers found earlier.

MTU = Auto
Proxy Server = Do Not Use
UPnP = doesnt make a difference

and thats it, your done... im using my PS3 with my 3G mobile broadband shared via airport.

EDIT: After a PM I realised I completely left out the Airport settings part.

In Airport settings under TCP/IP select configure IPv4 via DHCP, and under DNS add your ISP's DNS numbers that you found earlier.
I registered just to thank you, Tetsuo_83. Thank you so much.
     
Fresh-Faced Recruit
Join Date: May 2010
Location: Santiago, Chile
Status: Offline
Reply With Quote
May 19, 2010, 03:44 PM
 
Originally Posted by Tetsuo_83 View Post
Okay, so I know this thread is old, but up to last month nobody had posted a solution to using the internal airport card to share the connection so I said i'd register incase anyone else was googling endlessley to find a solution...
Thanks a lot Tetsuo...i was trying to work this for quite some time....
...this is the time of our lives...
Paul van Dyk
     
Fresh-Faced Recruit
Join Date: Jun 2010
Status: Offline
Reply With Quote
Jun 23, 2010, 09:02 PM
 
I hope this thread is still on-going...

PS3 Slim 120GB
Macbook Pro, Leopard
Internet connection: USB broadband which contains a mobile phone SIM card-liked chip.

I've turned on the internet sharing option. However it allows only Ethernet sharing.


I've got the IP address but there are 2 DNS and no Router:



Any help please?
     
Fresh-Faced Recruit
Join Date: Jun 2010
Status: Offline
Reply With Quote
Jun 30, 2010, 11:36 PM
 
I am attempting to connect my 80gb PS3 to the internet through my macbook pro. I have to connect through a verizon internet card (Novatel 740) for internet because I do not have high speed internet in the rural area where I live. I have tried internet sharing via the airport but cannot get it to work. can anyone please advise? Please let me know what info you need from me.

Thanks.
     
Fresh-Faced Recruit
Join Date: Oct 2010
Status: Offline
Reply With Quote
Oct 6, 2010, 08:37 PM
 
I had the same problem as most here. I share my wired internet connection over macbook with my other computers. Today i bought a PS3 and internet via Wireless Lan didn`t work. After surfing hours through the internet I found this thread. And the solution was jtrenda33 `s post
I don´t know what i´ve done ^^ But it worked.
So thank you a lot, you made my day, although the thread is really old.
Maybe someone can tell us, what this terminal commands do.

greetings from Germany
Jan
     
Fresh-Faced Recruit
Join Date: Oct 2010
Status: Offline
Reply With Quote
Oct 13, 2010, 01:10 PM
 
hey guys!!! here the solution:

first step: share your connection normally with the airport
Second step: configure your ps3 like...

Ip adress (ps3): 10.0.2.2
Sub mask: 255.255.255.0
Gateway: 10.0.2.1
DNS: 10.0.2.1

enjoy!
     
Banned
Join Date: Feb 2008
Status: Offline
Reply With Quote
Oct 19, 2010, 08:28 AM
 
This way you can get it to work.

You need to do some simple edits.

Have fun!
     
Fresh-Faced Recruit
Join Date: Oct 2010
Status: Offline
Reply With Quote
Oct 26, 2010, 06:57 PM
 
Originally Posted by hinrgmike View Post
Wow, so I just got my PlayStation 3 and immediately realized getting the wifi connection set up with my Airport Extreme and Mac was going to take some effort so I searched the internet and found this thread. If anyone with an Airport is still having problems, Morsmordre's thread about the Belkin router is essentially correct for the Airport as well, the differences being -

1. Open your Airport Admin Utility
2. Click on "Internet" tab (2nd tab over)
3. Look at "DNS servers" info and use this for primary and secondary DNS info in Playstation (mine was blank, but to the right outside of the boxes, there were two rows of greyed out numbers. I used the 1st line for my Primary DNS and the 2nd line for the Secondary DNS).

That got me connected immediately!

I also configured manually, chose my manual IP address for the playstation. My system is set up on the 10.0.1.X range, and I always pick a manual number that the system will not overwrite ever (which is any number over 10.0.1.200; so for my Playstation I used: 10.0.1.210

Of course the subnet mask is the same as Morsmordre indicated and my primary router is then 10.0.1.1

I used the same selection choices as Morsmordre for the rest as well.

BTW, my connection is cable broadband. The cable router hooked to my Airport Extreme and then that Airport forming an extended network with 2 more Airport Extremes and one Airport Express. I used the MAIN airport extreme to get my info.

Also, make sure if you use WEP, to lookup and use your 'Equivalent Network Password" which you access in the Airport Admin Utiility once you double select and open the base station icon, then chose the "Base Station" drop down box and select "Equivalent Network Password"
Thank you it worked perfectly for me, finally!!!!!
     
Fresh-Faced Recruit
Join Date: Dec 2010
Status: Offline
Reply With Quote
Dec 23, 2010, 09:05 PM
 
After about three days of failed attempts, the PS3 finally recognized my Base Station. I followed the instructions ../ben laid out. It got me closer (IP: succeeded/Internet Connection: failed), but still wouldn't connect. I arbitrarily tried an "easy set-up" after this and whatdya know? The damn thing connected! I have no explanation, but instead offer encouragement. Don't give up. Its worth it even if just for streaming Netflix onto your TV.
     
Fresh-Faced Recruit
Join Date: Dec 2010
Status: Offline
Reply With Quote
Dec 25, 2010, 03:36 PM
 
Originally Posted by Tetsuo_83 View Post
Okay, so I know this thread is old, but up to last month nobody had posted a solution to using the internal airport card to share the connection so I said i'd register incase anyone else was googling endlessley to find a solution.

Turn on Internet sharing:
select the network you want to share and share it via airport and give your network a name... set up a 5 digit WEP key if you want protection.

open terminal and type ifconfig en1
This will give you your router number, mine was 10.0.2.1, it will be listed next to the word inet
next type dig, this will give you your ISP's DNS numbers (at the very bottom, next to the word server)

On your PS3 open the network settings, scan for your new network, enter the WEP key and configure the IP manually.

Under IP type the router number but add a digit to the last number, in other words, my router was 10.0.2.1, so I assigned my PS3 the IP 10.0.2.2
use the standard subnet mask of 255.255.0.0
enter the router number you found (10.0.2.1)
enter the DNS numbers found earlier.

MTU = Auto
Proxy Server = Do Not Use
UPnP = doesnt make a difference

and thats it, your done... im using my PS3 with my 3G mobile broadband shared via airport.

EDIT: After a PM I realised I completely left out the Airport settings part.

In Airport settings under TCP/IP select configure IPv4 via DHCP, and under DNS add your ISP's DNS numbers that you found earlier.
This helped me greatly! I've finally connected, and I'm happier than ever!
Thanks lots! (:
     
Fresh-Faced Recruit
Join Date: Jan 2011
Status: Offline
Reply With Quote
Jan 12, 2011, 06:55 PM
 
To start I have the older PS3. The Airport Express (which is connected to a broadband cable router) which is setup on my iMac. I have carefully gone over all the posts here and the PS3 still can't obtain the IP address.

I can't hook up the PS3 manually as I don't have a 100 foot ethernet cable thus I can't check what IP comes up using that method.

Here is what my setup is at the moment:
WPA2 Personal
IPv4: Using DHCP

IP Address - do I use the one displayed on the Airport Utility Summary or do i use the IPv4 Address 10.0.1.2

Router Address 24.71.140.1 (number from Airport Utility) > > > YET on the Network Preference the Router Address is 10.0.2.1 Which is the correct one to use?

Subnet Mask is 255.255.252.0 (number from Airport Utility) > > > YET on the Network Preference the Subnet Mask comes up as 255.255.255.0 Again I'm not sure which to use?

DNS Numbers 64.59.168.13 / 64.59.168.15 ...Do these look right?

Another question I have is, which password do I use...the Base Station password or my Wireless network password (which both are 8 characters)

Is there anything else that someone can point out or suggest that I may be doing wrong as this is getting beyond frustrating. It's such a grey procedure…Apple can't help, Sony can't help and my internet provider is clueless!
     
Moderator
Join Date: Oct 2001
Location: San Jose, CA
Status: Offline
Reply With Quote
Jan 13, 2011, 02:58 AM
 
Originally Posted by Snerp View Post
To start I have the older PS3. The Airport Express (which is connected to a broadband cable router) which is setup on my iMac. I have carefully gone over all the posts here and the PS3 still can't obtain the IP address.

I can't hook up the PS3 manually as I don't have a 100 foot ethernet cable thus I can't check what IP comes up using that method.

Here is what my setup is at the moment:
WPA2 Personal
IPv4: Using DHCP

IP Address - do I use the one displayed on the Airport Utility Summary or do i use the IPv4 Address 10.0.1.2

Router Address 24.71.140.1 (number from Airport Utility) > > > YET on the Network Preference the Router Address is 10.0.2.1 Which is the correct one to use?

Subnet Mask is 255.255.252.0 (number from Airport Utility) > > > YET on the Network Preference the Subnet Mask comes up as 255.255.255.0 Again I'm not sure which to use?

DNS Numbers 64.59.168.13 / 64.59.168.15 ...Do these look right?

Another question I have is, which password do I use...the Base Station password or my Wireless network password (which both are 8 characters)

Is there anything else that someone can point out or suggest that I may be doing wrong as this is getting beyond frustrating. It's such a grey procedure…Apple can't help, Sony can't help and my internet provider is clueless!
With DHCP, you shouldn't have to enter an IP address, mask, router address or DNS addresses. The PS3 should get all this from the router automatically.

The 10.0.x.x IP addresses are your local addresses. The 24.x.x.x number must be your WAN IP address, the one obtained from your ISP.

Select your wireless network and enter your wireless network password, the one that other machines require to connect to this base station.

Just enable DHCP and do a connection test. It should work.

Steve
Celebrating 10 years and 4000 posts on MacNN!
     
Fresh-Faced Recruit
Join Date: Jun 2011
Status: Offline
Reply With Quote
Jun 17, 2011, 05:59 PM
 
so i have a netgear wifi booster that plugs into my usb, (Ethernet (en5) and mac has the internet sharing so i set it up to share from ethernet en5 to airport....it worked perfectly fine for my ipod i didnt have to type in anything but the ps3 is just to complex. obtains ip address but no network connectivity dns error 807012 or some shit like that. i even tried it with the ethernet cord insteadwhere i share from ethernet en5 to connections usin ethernet. plz hlp tried for months now.....lol i pick up wifi from my friend with the wifi booster
     
Fresh-Faced Recruit
Join Date: Jun 2011
Status: Offline
Reply With Quote
Jun 27, 2011, 10:43 AM
 
I too decided to register simply to thank Tetsuo_83 for ending my 2 day torture in the hands of my PS3. I finally play online with my dear pals without having to beg my PS3 to connect. Once again Tetsuo, I thank you sincerely from the bottom of my heart....all the way to the top! ^o^
     
Fresh-Faced Recruit
Join Date: Jul 2011
Status: Offline
Reply With Quote
Jul 22, 2011, 08:58 PM
 
Originally Posted by jtrenda33 View Post
I finally got my PS3 to connect to the internet using the built-in airport card. Here is what I did.

Turn on Internet Sharing. If you don't know how to do that then ask me and I will walk you through that as well.
Open Terminal and type this exactly as shown:

cp /etc/bootpd.plist /tmp/bootpd.plist

Hit the Return key. It may seem as though nothing has happened. That's okay.

Turn Internet Sharing off.

Go back to the Terminal window and type:

open -e /tmp/bootpd.plist

Hit the Return key. A file will open in TextEdit. Locate this section of the file, near the end:

<key>reply_threshold_seconds</key>
<integer>4</integer>

Change 4 to 0 and then hit Command+S to save the file.

Go back to the Terminal Window and type:

sudo cp /tmp/bootpd.plist /etc

You will need to know the administrator password. If you do not have one set up, then you might need to set one up first. You will be warned that this could be dangerous. I don't know what any of this is doing, but it worked. So if it messed up my computer, I can't tell because everything seems to be working perfectly.

Okay. After you enter the password, hit the Return key.

Turn Internet Sharing back on.

Now. Go over to your PS3 and set up a wireless connection the "easy" way. It said it was checking some network configurations or something like that and then it brought me to the SSID screen. I chose Manual and selected my access point that was already in there from before and then typed in my WEP password. Then I moved on and let it do everything automatically and it worked! Try it out. Let me know if this helps or if I need to clarify something that didn't make sense.
THANK YOU THANK YOU THANK YOU THANK YOU

If I could kiss you through the Internet right now, I would.

I used this tip, and my PS3 finally managed to connect to the Internet. The update is being downloaded as I type this.
It took me over 2 hours to get this working (seriously, two hours), and I find out after reading your post that all I had to do was change a tiny little thing XD

I've connected my PS3 through a hotel's WiFi (terms and conditions don't have anything against what I'm doing, so I'm all good), in a rather sneaky way.

I've connected my MacBook Pro to my hotel's hotspot, clicked the necessary buttons in a browser on my MBP, and connected my PS3 to my MBP through an Ethernet cable.
In the PS3 settings, I chose custom instead of Easy, selected Wired Connection, and set everything else to 'automatic'.

P.S.: What's the best way to get kiss marks off my shiny screen?
     
Fresh-Faced Recruit
Join Date: Jul 2011
Status: Offline
Reply With Quote
Jul 30, 2011, 10:04 PM
 
Ok guys, I found a solution. I faced all those listed above issues. I'm using MBA with PPPoE connection via usb - ethernet adapter. I enabked PPPoE sharing over built in airport.

All you need to do is to connect to your wifi network an iPhone. In tje settings - wifi hit a blue arrow on the right from your network and check all parameters (dns, etc..). After use all of them while manually setting up wireless network on PS3. I had the same address for router, primary dns and sec dns. Just use different IP from the one indicated in iPhone wifi settings. I think you can do the same with any device, not only iPhone.
     
 
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 05:28 PM.
All contents of these forums © 1995-2015 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2015, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2