Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Enthusiast Zone > Networking > Leopard and Airport — no longer automatically joining preferred network

Leopard and Airport — no longer automatically joining preferred network
Thread Tools
Dedicated MacNNer
Join Date: Mar 2005
Location: Atlanta
Status: Offline
Reply With Quote
Jan 6, 2008, 03:47 PM
 
I have a 15" 1.67 Ghz PowerBook and use it at college. This is how it works: Turn on computer. Turn on Airport. Add the wireless name and WEP password (if you do it once, it will always show up next time). Open a browser. Enter your username and password to login.

After upgrading to Leopard, the wireless network name is no longer there and I have to manually click on "Join Other Network" and put in the network name and password every time I open my computer.

When I open up Network Preferences, in the Advanced tab it shows the wireless name in the Preferred Networks but the wireless name still won't automatically show up and I have to manually input it.

Has anyone else experienced this? Is there a fix for it?
     
Moderator
Join Date: Jan 2001
Location: Polwaristan
Status: Offline
Reply With Quote
Jan 6, 2008, 04:06 PM
 
Delete it from the preferred networks, log out, log back in, and then click the airport icon in your menu bar. See if the network shows up (give it a few seconds while airport scans for it). If so, select it and see if it will now allow you to access the network and give you the checkbox to save your password in Keychain.

I also edited your thread title to make it a bit more descriptive.
     
Dedicated MacNNer
Join Date: Mar 2005
Location: Atlanta
Status: Offline
Reply With Quote
Jan 6, 2008, 04:25 PM
 
It didn't work. It doesn't automatically show up after logging in and out.
     
Moderator
Join Date: Jan 2001
Location: Polwaristan
Status: Offline
Reply With Quote
Jan 6, 2008, 04:28 PM
 
ok. There are still some things we can try.

Create a new user, and try to do it while logged in as that new user.

Also: what kind of Leopard upgrade did you do? Upgrade, Archive-Install, or Erase-Install?
     
Dedicated MacNNer
Join Date: Mar 2005
Location: Atlanta
Status: Offline
Reply With Quote
Jan 6, 2008, 07:06 PM
 
I did an upgrade.

I just tried it with the Guest Account that comes with Leopard but it had the same problem. The network name worked manually but after turning airport off and on, it disappeared.
     
Moderator
Join Date: Jan 2001
Location: Polwaristan
Status: Offline
Reply With Quote
Jan 6, 2008, 07:08 PM
 
Why do you turn airport off and on? What if you leave it on & connected, then put your Mac to sleep, then wake it back up? Will it reconnect then on its own?
     
Dedicated MacNNer
Join Date: Mar 2005
Location: Atlanta
Status: Offline
Reply With Quote
Jan 6, 2008, 11:11 PM
 
No, after sleeping, the network name is gone again and I have to manually input in the wireless network name and password every time. Tomorrow, when I'm at school, I'll try to create a new account and try it again.
     
Moderator
Join Date: Jan 2001
Location: Polwaristan
Status: Offline
Reply With Quote
Jan 6, 2008, 11:22 PM
 
My other recommendation, based on it solving a variety of ankle-biting issues, is archive-install — especially so since you did an upgrade. An archive-install is quick and, if the block is checked, preserves your user account and network settings (although in your case, you may want to forgo those).
     
Dedicated MacNNer
Join Date: Mar 2005
Location: Atlanta
Status: Offline
Reply With Quote
Jan 7, 2008, 09:20 AM
 
I created a new account but the same thing happens. I guess I have no choice but try to attempt to reinstall Leopard. When I originally upgraded to Leopard, it wouldn't let me do a archive and install. Everytime I tried, the installer would quit in the middle of the process, so I just upgraded normally.

Anyone else have any other solutions before I reinstall in a few days?
     
Administrator
Join Date: Apr 2001
Location: San Antonio TX USA
Status: Offline
Reply With Quote
Jan 7, 2008, 09:52 AM
 
It does sound like there's something odd going on, but I'd need a lot more info to nail it down. For example, are you only having this problem with the school network? What sort of security are they using? Can you connect to any other wireless network automatically? Are you absolutely certain that your AirPort keychain entry is the right password? Did the school change anything over the break?

When I upgraded my iMac, (archive and install), my settings stayed available and I connected immediately and automatically. I don't think it's got anything to do with the kind of upgrade either, because the same files get copied and at most you should have had to enter your password once in any case. Gotta be something else going on.

Glenn -----OTR/L, MOT, Tx
     
Dedicated MacNNer
Join Date: Mar 2005
Location: Atlanta
Status: Offline
Reply With Quote
Jan 7, 2008, 11:27 AM
 
The problem is only with the school network. Every other network connects normally. The school uses WEP 40/128-bit hex.

The school didn't change anything over the break, because the password still works manually. Also, I wasn't gone over the break, I was still here using the wireless services. It's just when I upgraded to Leopard that it won't automatically connect.
     
Administrator
Join Date: Apr 2001
Location: San Antonio TX USA
Status: Offline
Reply With Quote
Jan 7, 2008, 12:12 PM
 
Dump the keychain entry for your school's network and see if your manual entry sticks. This sounds vaguely familiar...

Glenn -----OTR/L, MOT, Tx
     
Dedicated MacNNer
Join Date: Mar 2005
Location: Atlanta
Status: Offline
Reply With Quote
Jan 7, 2008, 01:02 PM
 
I just tried it and it didn't work.
     
Fresh-Faced Recruit
Join Date: Dec 2007
Status: Offline
Reply With Quote
Jan 8, 2008, 06:16 PM
 
I had a similar problem with a new Macbook a bouple of weeks back, the problem was only on WEP protected networks. The original original thread is here;

http://forums.macnn.com/92/networkin...-remember-wep/

For some reason you need to set the account from System Pref as it wont remember if you select from the airport menu

deleted the keychain from my account, restarted the MB, opened network settings clicked on the advanced tab and filled in the network name and password fields, ticked remember password box and the MB connected to my network.
     
Addicted to MacNN
Join Date: Oct 2001
Location: Automatic
Status: Offline
Reply With Quote
Jan 9, 2008, 10:47 AM
 
A friend of me has an issue with Leopard, I don't certainly know if it is related to Airport… here is how it goes… after installing 10.5 the Macs can't find the PCs over the LAN… he also says Airport is behaving weird asking for WEP and SSID passwords after a sleep-wake up but for what I have read here and there that's either a bug or some kind of expected behavior due to how Wi-Fi works, but my guess is that since he is complaining about it, that didn't happened under Tiger…

Any workaround?, to move files between PCs and Macs sitting over the same desk via a USB keychain is getting silly…
     
Dedicated MacNNer
Join Date: Mar 2005
Location: Atlanta
Status: Offline
Reply With Quote
Jan 9, 2008, 11:28 AM
 
It looks like moving System Preferences to the Applications folder worked. It was previously in /Applications/Utilities. I appreciate the time and effort everyone's put into helping me. Thanks!

edit: It worked that one time and now it disappeared again. I'll try snackhound's method now.
edit2: That didn't work either.
( Last edited by tripletaker; Jan 9, 2008 at 12:28 PM. )
     
Dedicated MacNNer
Join Date: Mar 2005
Location: Atlanta
Status: Offline
Reply With Quote
Jan 9, 2008, 06:42 PM
 
To give an update, I think it's working now. 7 out of 10 times the network appears automatically but once in a while I'll still have to toggle the Airport on and off to get it back.

I think what worked was moving System Preferences to the main /Application folder.
     
Addicted to MacNN
Join Date: Oct 2001
Location: Automatic
Status: Offline
Reply With Quote
Jan 10, 2008, 07:12 AM
 
but what if you already have System Preferences where it belongs? (Apps folder that is…)
     
Dedicated MacNNer
Join Date: Mar 2005
Location: Atlanta
Status: Offline
Reply With Quote
Jan 10, 2008, 07:15 AM
 
I guess you can try what others have mentioned so far. Delete your wireless entry in the keychain and restart. Then try opening System Preferences > Networks and manually add it in and see if it sticks.

Try it on a new account and see if it's a specific account or a system wide thing.

And as a last resort, reinstall Leopard as archive/install.
     
Addicted to MacNN
Join Date: Oct 2001
Location: Automatic
Status: Offline
Reply With Quote
Jan 11, 2008, 12:08 PM
 
Shall try that, thanks.
     
Dedicated MacNNer
Join Date: Mar 2005
Location: Atlanta
Status: Offline
Reply With Quote
Jan 18, 2008, 09:25 AM
 
Funny story. I got a new computer for reasons completely unrelated to the topic and guess what?

I have the same problem with my school network not joining automatically. I've contacted the IT department at school so hopefully they can figure it out.
     
Fresh-Faced Recruit
Join Date: Jan 2008
Location: Canada
Status: Offline
Reply With Quote
Jan 27, 2008, 10:17 AM
 
Just to make thinks more interesting. I have an iMac, new MacBook and an iBook wirelessly connected to my AIrport Extreme. All are in the same room approximately 8 - 10 feet from the router. As well, all are latest version of Leopard. My iMac has never lost its connection to the airport extreme nor has the iBook. They work amazingly well. HOWEVER, my MacBook frequently loses its wireless connection, the airport utility cannot find the airport base station, etc....you get the picture. Spoke with Apple, and it would seem this is a known problem. They had me reset the airport extreme, my network modem, re-do and rename my network - the usual manual based troubleshooting stuff. And about an hour later......no connection. And funny thing is, if I do nothing, sometimes the connection returns all by itself a few hours later and stays connected the amount of time it takes me to get to something important that I am working on and SURPRISE.....no network. The person on the phone mentioned to me that updated 10.5.2 should fix the problem. Has any heard this?
     
Administrator
Join Date: Apr 2001
Location: San Antonio TX USA
Status: Offline
Reply With Quote
Jan 27, 2008, 11:46 AM
 
Apple keeps working on AirPort code to fix drops and "won't connect after sleep" issues. The problem with their approach is that they don't give the users enough information or responsibility.

After the "have you restarted everything" step, I'd have asked you what channel your network was on. Often dropouts are due to "adjacent channel interference." While the conventional definition of adjacent channel interference isn't actually accurate in this situation, the effect is there-a neighbor with a wireless network on the same or an adjacent channel can easily wreck your connection, and you his. A simple move from channel 6 or 7 (where just about all wireless hardware defaults out of the box) to channel 2 or 10 often fixes everything like magic.

Apple doesn't provide enough information in the setup for clients or base stations to get the "I'm not a real network person" audience to consider selecting something other than a default channel, and in helping you troubleshoot on the phone, they don't stress the possibility of adjacent channels being a problem-"do you have any other networks showing up in your AirPort list?"

Rant over-sorry you're having problems. You DID consider changing channels though, right?

Glenn -----OTR/L, MOT, Tx
     
Fresh-Faced Recruit
Join Date: Jan 2008
Location: Canada
Status: Offline
Reply With Quote
Jan 27, 2008, 11:56 AM
 
Feel free to rant all you want. I have been more than frustrated for the past month with this. What concerns me the most, the problem is ONLY with my new macbook.

And no, no one said a thing about channels. And just how do I change a channel? Is the channel change just for the macbook or is it on the base-station for all connections?
     
Moderator
Join Date: Jan 2001
Location: Polwaristan
Status: Offline
Reply With Quote
Jan 27, 2008, 12:37 PM
 
Use a utility like AirMoose - MacUpdate to scan for other wifi points and to see the channels they operate on. Then you can use the Airport Utility to change the channel of your Airport Extreme. Pick a channel that's at least two away from other channels, e.g., choosing channel 5 would mean no one is on channels 4, 5, and 6.
     
Fresh-Faced Recruit
Join Date: Jan 2008
Location: Canada
Status: Offline
Reply With Quote
Jan 27, 2008, 12:59 PM
 
Thanks. I have downloaded the utility and changed my channel. Hopefully this will work.

What concerns me is this only happened on my macbook and not with my ibook or imac. Strange.
     
Dedicated MacNNer
Join Date: Mar 2005
Location: Atlanta
Status: Offline
Reply With Quote
Jan 27, 2008, 01:50 PM
 
The AirMoose app does not find the wireless network I use.

I still have the problem. Hopefully 10.5.2 will fix it because it's a pain to input the network name and password everytime.
     
Fresh-Faced Recruit
Join Date: Jan 2008
Location: Canada
Status: Offline
Reply With Quote
Feb 22, 2008, 08:25 PM
 
Thought I would follow up on this with everyone. I did change the channel and it worked for a few days and now even with the new update to OSX, I am now daily having to reset my airport express to get my macbook back online through airport. What a pain this is.

Any other suggestions on troubleshooting besides rebooting my airport express, resetting the router, changing the channel, etc....
     
Fresh-Faced Recruit
Join Date: Jan 2008
Location: Canada
Status: Offline
Reply With Quote
Feb 29, 2008, 09:42 AM
 
Again, things are getting stranger here with my macbook. Now I am noticing a fantom network popping up in my list of networks.

It has the name of "Apple Network ec6c53"

I have AirMoose running and it NEVER appears in the list of area networks, but it is present and at the top of the list when I select "show networks" and when I select the Airport icon on my desktop on the upper bar.

Anyone????
     
Dedicated MacNNer
Join Date: Mar 2005
Location: Atlanta
Status: Offline
Reply With Quote
Feb 29, 2008, 09:55 AM
 
I would like to say that my problem is still happening and 10.5.2 did not fix it. Also, the IT people at my school cannot solve this issue as well. All the Mac people with Leopard are not happy at my school.
     
Administrator
Join Date: Apr 2001
Location: San Antonio TX USA
Status: Offline
Reply With Quote
Feb 29, 2008, 02:24 PM
 
It's not a problem for "everyone with Leopard", and it's certainly not a problem at my school, so I'm tempted to say "it's your school's issue." With that said, I haven't upgraded my MBP to Leopard yet (this weekend, probably), so I can't say it's not happening at my school at all, so I'll just say that "I have no idea why your school is having this problem.

Glenn -----OTR/L, MOT, Tx
     
Fresh-Faced Recruit
Join Date: Jan 2008
Location: Canada
Status: Offline
Reply With Quote
Mar 1, 2008, 11:22 AM
 
Here is what I have at the moment and hopefully someone can help troubleshoot the problem

I have 3 macs iMac/10.5.2 iBook/10.5.2 and MacBook/10.5.2 all running on my desk wireless connected with an airport extreme base station that is 3 feet away. All 3 macs also have AirMoose running as well.

iMac is connected and the AirMoose scan clearly shows all of the neighbourhood wifi's and shows my network as well. On my system network preferences when asked to show networks, the same collection of networks appear as the AirMoose including my network. Note: this connection never goes down.

iBook is connected and the AirMoose scan clearly shows all of the neighbourhood wifi's and shows my network as well. On my system network preferences when asked to show networks, the same collection of networks appear as the AirMoose including my network. Note: this connection never goes down.

MacBook is connected and the AirMoose scan clearly shows all of the neighbourhood wifi's and shows my network as well. On my system network preferences when asked to show networks, the same collection of networks appear as the AirMoose including my network PLUS some network called "Apple Network ec6c53". What is strange about this is the fact that when the "Apple Network ec6c53" is present in the show networks and not on the AirMoose list, I cannot connect to the base station. What makes this stranger, is when the "Apple Network ec6c53" disappears from the show network listings, I can connect to the base station. I have searched my mac and cannot find ANY reference to the "Apple Network ec6c53".

I will leave the configurations as is should anyone have any suggestions. I have confirmed that all System Network preferences on all machines are identical. And yes, I have done the change channel and please do not ask me to start the shut down the modem, reset the base stations basic troubleshooting stuff. Completely tired of that.

ANYONE!!!!!
     
Registered User
Join Date: Feb 2008
Location: BIrmingham, AL
Status: Offline
Reply With Quote
Mar 12, 2008, 11:09 AM
 
I am having essentially the same problem as the thread starter, only it is with my home network (all Apple Airport devices) using WPA/WPA2. The problem does not occur if I disable wireless security (via the Airport Utility) on my network.

As such, I'd like to "revive" this thread to see if anyone else is havng similar troubles, or if there are any other suggestions.

At this point, I think this problem exists with one of more of the following:

1) The way wireless security is setup under Leopard;

2) The way wireless security is setup in Airport Utility;

3) And/or the way wireless security is setup on the devices themselves.

The problem is likely not a account, keychain, or preferences issue, as it occurs on both my MBP and my wife PB. Again, it only occurs if wireless security is enabled. I suppose it could also be a defect in the Airport Base Station Agent in the login items, but I just downloaded the most recent update (MacNN | Apple updates BaseStation software) for that and the problem still occurs.
( Last edited by tridentinecanon; Mar 12, 2008 at 11:37 AM. )
     
Moderator
Join Date: Jan 2001
Location: Polwaristan
Status: Offline
Reply With Quote
Mar 12, 2008, 04:33 PM
 
Before ruling it out, I'd nonetheless repair the keychain and change your WPA2 password, just to rule it out.
     
Registered User
Join Date: Feb 2008
Location: BIrmingham, AL
Status: Offline
Reply With Quote
Mar 12, 2008, 04:37 PM
 
Cold,

I followed those steps. I actually just got off the phone with Apple a few minutes ago. After speaking with 3 different people, they told me that the problem was being accelerated to one of their engineers. They told me I should be getting an email in about 5-7 days.

I will post when I hear back from Apple.
( Last edited by tridentinecanon; Mar 16, 2008 at 07:10 PM. )
     
Fresh-Faced Recruit
Join Date: Mar 2008
Status: Offline
Reply With Quote
Mar 16, 2008, 01:53 PM
 
I have a powerbook 1.67Hz running 10.5.2 and even the new airport update. I have the same problem as you guys mentioned above. Airport no longer automatically joins the preferred network after wake up from sleep (9 out 10 times). But if I turn off the airport and turn on again, it will find the network back.

I recently found that if I turn off the bluetooth, the automatically joining preferred network problem disappears permanently. So I think this problem is not because of keychain. It has no relation with the airport base or access point either. This problem must relate to how leopard handle the network connections after wake up from sleep state (I don't have this problem with Tiger 10.4).

Now I have to sacrifice my bluetooth mouse to get airport works automatically.
Does anyone has the same experience?
( Last edited by tiger64; Mar 16, 2008 at 02:03 PM. )
     
Moderator
Join Date: Jan 2001
Location: Polwaristan
Status: Offline
Reply With Quote
Mar 16, 2008, 02:13 PM
 
Interesting observation. I keep my bluetooth off all the time on my MBP C2D, because I never use bluetooth, and I never have the reconnect/join problems.
     
Fresh-Faced Recruit
Join Date: Mar 2008
Status: Offline
Reply With Quote
Mar 16, 2008, 03:52 PM
 
Then, what would happen if you turn on your bluetooth. Rejoining/reconnection problem to you also?
     
Administrator
Join Date: Apr 2001
Location: San Antonio TX USA
Status: Offline
Reply With Quote
Mar 16, 2008, 05:45 PM
 
I think it would require that you actually had an active BT connection, rather than just having BT turned on. If the connection is active, there's traffic (in the 2.4GHz band) continually between the computer and the peripheral. If the BT on the computer is just on, it is usually just listening until you tell it to look for something.

On the other hand, I've used Bluetooth to transfer files back and forth with my phone while connected to my school's wireless network and never had a problem. I'll suspect that nobody will have to actually sacrifice a wireless mouse to connect-just turn off the connection with the mouse until the computer connects to the wireless network and then reconnect it once you're online.

Glenn -----OTR/L, MOT, Tx
     
Fresh-Faced Recruit
Join Date: Mar 2008
Status: Offline
Reply With Quote
Mar 16, 2008, 06:04 PM
 
I don't have the problem with the Bluetooth and wireless working together either.
What I am talking about is that airport can not automatically rejoin the wireless after sleep. it requires you to turn off the wireless and turn on again, then it will find the preferred wireless network back.
Now what I found is that with the bluetooth off, I don't have rejoining problem anymore. It doesn't matter if you have a connected BT device or not (I have tried close wireless mouse and keep BT on without any connection). If bluetooth is on, airport can not automatically rejoin the wireless after wake from the sleep state. It's not a very big problem though, since one can use the turn off and on airport method. I can also reconnect my mouse after I get the wireless automatically.
But the thing is I don't have this complication in Tiger 10.4. I just hope this phenomenon will help apple engineer to solve this small bug of automatic rejoining after sleep.
     
Registered User
Join Date: Feb 2008
Location: BIrmingham, AL
Status: Offline
Reply With Quote
Mar 16, 2008, 07:10 PM
 
tiger64:

In Network Preferences, in your location or in a new location, try reordering the Service Order (move Airport to the top). Does this fix your problem? If not, try reordering it under a new location. Does that help?

Sometimes Airport is automatically relegated to the bottom of this list, and when it comes time to automatically join, the search for a connection will timeout before it gets to Airport (which is what many people use primarily). (I know this sounds ridiculous, but this solution has been recommended to me by an Apple technician.
     
Fresh-Faced Recruit
Join Date: Mar 2008
Status: Offline
Reply With Quote
Mar 16, 2008, 07:15 PM
 
tridentinecanon,
thanks, I had tried that reordering before, it did not work. But with bluetooth off, no rejoining problem anymore.
     
Registered User
Join Date: Feb 2008
Location: BIrmingham, AL
Status: Offline
Reply With Quote
Mar 16, 2008, 07:32 PM
 
Originally Posted by tiger64 View Post
tridentinecanon,
thanks, I had tried that reordering before, it did not work. But with bluetooth off, no rejoining problem anymore.
I think we are having similar but different issues here. Whether or not Bluetooth does not affect my Airport automatically connecting (or not automatically connecting).

Out of curiosity, is your current Airport network a secured one?
     
Fresh-Faced Recruit
Join Date: Mar 2008
Status: Offline
Reply With Quote
Mar 16, 2008, 08:47 PM
 
I currently use a secured network (WPA/WPA2). Again, I don't think this automatically connecting issue is related to the setting of access point, because I can use turn-off-and-on airport to get the network back without re-input any password again.

Regarding the bluetooth issue, after I removed my two mouse devices in the Bluetooth preference panel, now I can leave the bluetooth on and airport can automatically rejoin my preferred network after sleep.

I think leopard is doing two things after wake from sleep, looking for bluetooth devices (mouse or keyboard) and wireless network. But it seems that it can not do these two things at the same time. When I have bluetooth mouse in the setting list, it will try to find mouse first, but no time for wireless, :-).
Maybe I should get a duo core macbook pro. Most likely powerbook can not do two things very fast at the same time.
     
Registered User
Join Date: Feb 2008
Location: BIrmingham, AL
Status: Offline
Reply With Quote
Mar 16, 2008, 09:34 PM
 
Originally Posted by tiger64 View Post
I currently use a secured network (WPA/WPA2). Again, I don't think this automatically connecting issue is related to the setting of access point, because I can use turn-off-and-on airport to get the network back without re-input any password again.

Regarding the bluetooth issue, after I removed my two mouse devices in the Bluetooth preference panel, now I can leave the bluetooth on and airport can automatically rejoin my preferred network after sleep.

I think leopard is doing two things after wake from sleep, looking for bluetooth devices (mouse or keyboard) and wireless network. But it seems that it can not do these two things at the same time. When I have bluetooth mouse in the setting list, it will try to find mouse first, but no time for wireless, :-).
Maybe I should get a duo core macbook pro. Most likely powerbook can not do two things very fast at the same time.
Just to be clear, if you disable security on your Airport device, will it reconnect automatically? Mine does - so, for me, it is an issue with the "setting of access point." Apple is looking into this for me. I expect to hear from them this week. I'd be curious to know if you have the same problem.

How many Airport devices do you have? What models?
     
Administrator
Join Date: Apr 2001
Location: San Antonio TX USA
Status: Offline
Reply With Quote
Mar 16, 2008, 10:18 PM
 
This still sounds very much like the famous (or infamous) AirPort Sleep Issue. On some Macs after an update of some kind, the AirPort card no longer reconnects after sleep. It has happened at least since Panther (probably since before then), and it always has the same symptom: the card won't automatically reconnect on waking.

It seems to be due to some sort of signaling NOT telling the AirPort card that the computer is waking up, so the card doesn't know that it's lost track of the network. It thinks the network disappeared and sort of waits for it. There is no known cure, and it can go away as mysteriously as when it appeared.

I had posited that the existence of a Bluetooth connection at the point the computer tries to connect (or more accurately when it should try to connect) might interfere with finding the network because I hadn't picked up on the sleep part of the issue-this is the first "AirPort Sleep" thread I've seen where the title didn't contain the word "sleep." Sorry for not being more helpful.

Glenn -----OTR/L, MOT, Tx
     
Registered User
Join Date: Feb 2008
Location: BIrmingham, AL
Status: Offline
Reply With Quote
Mar 16, 2008, 10:38 PM
 
Originally Posted by ghporter View Post
This still sounds very much like the famous (or infamous) AirPort Sleep Issue. On some Macs after an update of some kind, the AirPort card no longer reconnects after sleep. It has happened at least since Panther (probably since before then), and it always has the same symptom: the card won't automatically reconnect on waking.

It seems to be due to some sort of signaling NOT telling the AirPort card that the computer is waking up, so the card doesn't know that it's lost track of the network. It thinks the network disappeared and sort of waits for it. There is no known cure, and it can go away as mysteriously as when it appeared.

I had posited that the existence of a Bluetooth connection at the point the computer tries to connect (or more accurately when it should try to connect) might interfere with finding the network because I hadn't picked up on the sleep part of the issue-this is the first "AirPort Sleep" thread I've seen where the title didn't contain the word "sleep." Sorry for not being more helpful.
When I called Apple last week, they had absolutely no idea what was wrong.

What is odd in my situation is that this "Airport Sleep" starting happening on two computers in my house - my MBP and my wife's PB - at precisely the same time: right after I got my new TC.
     
Fresh-Faced Recruit
Join Date: Mar 2008
Status: Offline
Reply With Quote
Mar 18, 2008, 09:24 AM
 
Yes, automatically reconnect on waking problem does disappear by disabling the wireless security. But turning off the bluetooth also solve the problem even with the WPA/WPA2 security on. It's really mysterious.
     
Registered User
Join Date: Feb 2008
Location: BIrmingham, AL
Status: Offline
Reply With Quote
Mar 18, 2008, 09:28 AM
 
Originally Posted by tiger64 View Post
Yes, automatically reconnect on waking problem does disappear by disabling the wireless security. But turning off the bluetooth also solve the problem even with the WPA/WPA2 security on. It's really mysterious.


It's a mystery... and a headache.

Are you turning off bluetooth and then restarting? Or, are you simply turning off bluetooth and putting the computer to sleep w/out a restart?
     
Registered User
Join Date: Feb 2008
Location: BIrmingham, AL
Status: Offline
Reply With Quote
Mar 20, 2008, 10:04 AM
 
So the latest firmware updates did not fix this...
     
 
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 11:43 AM.
All contents of these forums © 1995-2014 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2014, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2