Welcome to the MacNN Forums.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

You are here: MacNN Forums > Enthusiast Zone > Networking > Leopard and Airport — no longer automatically joining preferred network

Leopard and Airport — no longer automatically joining preferred network (Page 2)
Thread Tools
Mac Enthusiast
Join Date: Apr 2002
Location: The Great State of Dementia
Status: Offline
Reply With Quote
Mar 21, 2008, 10:37 AM
 
I found a solution that works for me....after the firmware updates, and time machine/airport updates all failed to work, I tried swtching my security on the router from wpa to wpa2 and viola, my mbp now recognizes and connects to the router automatically upon waking or restart. YAY! Hope this helps someone out there.
BTW- I did delete the preferred network, and all the com.apple.preferences related to internet,with all combinations of restarting to boot (ha!) and that didn't even help.After the change, I switched back to wpa just to see what would happen, and it still connects upon waking/restart. Before it was almost like the mac wouldn't remember the network....I mean, it saw my network, but gave me the error "there was an error joining the network"chadsnetwork"". I could only join through network diagnostics, where I was prompted to enter a password, and then told that my network settings had changed and then that my connection was fine. The entry was even saved to my keychain, but for some reason it wouldn't/couldn't access that setting on waking/restart...
fixed now!
( Last edited by Ratspittle; Mar 21, 2008 at 10:43 AM. )
The large print giveth, and the small print taketh away
     
Fresh-Faced Recruit
Join Date: Mar 2008
Location: Birmingham, AL
Status: Offline
Reply With Quote
Mar 21, 2008, 11:23 AM
 
I have had a similar problem--I had been using my MacBook Pro with no problem on my home network until I upgraded to Leopard, and then all of the sudden my network preferences wouldn't save, and I have to reenter my nice long hex key password every time I want to reconnect on waking from sleep. I tried disconnecting the bluetooth, and no luck there, and I also tried changing the settings through System Prefs instead of via the airport menu. Same result.

Please continue to post any possible solutions--I think there are a fair number of people affected by this problem.
     
Administrator
Join Date: Apr 2001
Location: San Antonio TX USA
Status: Offline
Reply With Quote
Mar 21, 2008, 12:00 PM
 
tridentinecanon, check out the OTHER thread on this issue-it looks like Ratspittle has fixed HIS problem, so maybe his approach will fix yours.

Glenn -----OTR/L, MOT, Tx
     
Registered User
Join Date: Feb 2008
Location: BIrmingham, AL
Status: Offline
Reply With Quote
Mar 21, 2008, 01:54 PM
 
Originally Posted by ghporter View Post
tridentinecanon, check out the OTHER thread on this issue-it looks like Ratspittle has fixed HIS problem, so maybe his approach will fix yours.
Thanks for referring me back over there.

I tried Ratspittle's solution, but it did not work.

All my future postings for this will be in the other thread.
( Last edited by tridentinecanon; Apr 3, 2008 at 07:10 PM. )
     
Fresh-Faced Recruit
Join Date: Mar 2008
Status: Offline
Reply With Quote
Mar 21, 2008, 05:58 PM
 
Easy fix worked for me:

Spotlight keychain access and open Keychain Access

Your network should be in both the login and system keychains

Enter both entries and, under the Access Control tab, give all applications access to the password
     
Fresh-Faced Recruit
Join Date: Apr 2008
Status: Offline
Reply With Quote
Apr 29, 2008, 12:04 PM
 
I have been searching high and low for a fix to this and none have worked…until now!

I spotted a fix to this problem that strangely centered on the specific location of the “System Preferences.app”, if other than the standard location of the root of the “Applications” folder. I had in fact moved mine and would NEVER have thought it related to this bug. Hmmm!

If you have moved the System Preferences application (not alias, actual app) to any other location for any reason, your newly joined preferred network will NOT be properly remembered and will NEVER be properly rejoined. Apparently one of the multi-step system procedures involved in properly saving a preferred network assumes the location of System Preferences to be the standard location. Period.

FIX:
1) Move “System Preferences.app” back to “Applications\”.
2) Delete all instances of “Preferred Networks” in “Network Preferences”.
3) Delete all “Airport network password” instances in “Keychain Access”.
4) Restart your Mac.
5) Add/Join applicable preferred network using the Airport pulldown menu or in Network Preferences (as if for the first time). Use “Advanced” in “Network Preferences” to confirm the existence of your preferred network and the correct settings. Use “Keychain Access” to confirm the existence of the applicable “Airport network password” instance and the correct settings.
6) Restart your Mac. The OS should now find your preferred network and join it on its own. Good Luck!

NOTE: Simply moving back System Preferences will NOT suffice. Deleting and re-adding/joining the preferred network is a must after the app has been moved.
     
Fresh-Faced Recruit
Join Date: Jun 2008
Status: Offline
Reply With Quote
Jun 8, 2008, 10:13 PM
 
Thanks JSweeny, that did it for me!
Finally all that time-wasting rejoining of networks at all different locations is over...
:-)
     
Moderator
Join Date: Jan 2001
Location: Polwaristan
Status: Offline
Reply With Quote
Jun 8, 2008, 10:22 PM
 
Moving applications in OS X is generally a bad idea. Good work on tracking down your problems and troubleshooting. Thanks for posting it here.
     
Fresh-Faced Recruit
Join Date: Aug 2009
Status: Offline
Reply With Quote
Aug 21, 2009, 02:07 PM
 
Originally Posted by JSweeny View Post
I have been searching high and low for a fix to this and none have worked…until now!

I spotted a fix to this problem that strangely centered on the specific location of the “System Preferences.app”, if other than the standard location of the root of the “Applications” folder. I had in fact moved mine and would NEVER have thought it related to this bug. Hmmm!

If you have moved the System Preferences application (not alias, actual app) to any other location for any reason, your newly joined preferred network will NOT be properly remembered and will NEVER be properly rejoined. Apparently one of the multi-step system procedures involved in properly saving a preferred network assumes the location of System Preferences to be the standard location. Period.

FIX:
1) Move “System Preferences.app” back to “Applications\”.
2) Delete all instances of “Preferred Networks” in “Network Preferences”.
3) Delete all “Airport network password” instances in “Keychain Access”.
4) Restart your Mac.
5) Add/Join applicable preferred network using the Airport pulldown menu or in Network Preferences (as if for the first time). Use “Advanced” in “Network Preferences” to confirm the existence of your preferred network and the correct settings. Use “Keychain Access” to confirm the existence of the applicable “Airport network password” instance and the correct settings.
6) Restart your Mac. The OS should now find your preferred network and join it on its own. Good Luck!

NOTE: Simply moving back System Preferences will NOT suffice. Deleting and re-adding/joining the preferred network is a must after the app has been moved.
Same problem here. A bunch of ibook g4 (14") laptops with Tiger installed. Upgraded to Leopard (wipe and install) by way of an image and NetRestore.

"Some" come up fine on the first boot with respect to wireless. The rest will not connect automatically. Manual join works fine but upon reboot it will not auto-connect. System Prefs has never been moved. "Some" worked upon reboot after the above steps. "Some" I have to go through 3 or 4 iterations of manual joins, reboots, and then they start auto-connecting. I never saw this problem with 10.4.x; not until 10.5.
     
 
Thread Tools
Forum Links
Forum Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Top
Privacy Policy
All times are GMT -4. The time now is 04:54 PM.
All contents of these forums © 1995-2014 MacNN. All rights reserved.
Branding + Design: www.gesamtbild.com
vBulletin v.3.8.8 © 2000-2014, Jelsoft Enterprises Ltd., Content Relevant URLs by vBSEO 3.3.2