MacNN Forums (http://forums.macnn.com/)
-   Alternative Operating Systems (http://forums.macnn.com/alternative-operating-systems/)
-   -   MacBook CPU 100% issues with Power in XP Bootcamp-Was "PowerBook..." (http://forums.macnn.com/104/alternative-operating-systems/329302/macbook-cpu-100-issues-power-xp/)

 
trappedatuf Mar 5, 2007 12:57 PM
MacBook CPU 100% issues with Power in XP Bootcamp-Was "PowerBook..."
I just got my MacBook (13.3" white) on Thursday and I love it.

I installed Boot Camp and got my Windows XP running great on it! I went to bed last night and everything was great with the machine but I wake up this morning and the CPU is pegged at close to 100%. I went to task manager to see what process was the culprit so I could fix the problem but the process 'system' was at around 40% and there was all the others adding up to the 100%. This is odd as usually one run-away process will be at 99% so you know it's the offender.

So I restarted the system several times with it still running at 99% CPU useage. I can still do stuff (albeit slower) so I stmbled on the fact that under Power Options the battery had "unknown" amount of charge even though it was plugged in and full. I tried to mess with those settings but this must be the issue.

Has anyone had issues with the Power Options or Battery causing their Macbook with XP running on it (through Boot Camp) to use 99% of the CPU all the time?

I am in OSX now typing this and OSX works just fine. Please help!

PS: I understand OSX is designed for the Macs and that Boot Camp and XP are not 'officially' supported so please let's not turn this into an "i told you so" XP vs OSX debate. I have a serious problem and have to get started with work this Monday morning so your help is deeply appreciated. :-)
 
trappedatuf Mar 9, 2007 01:03 AM
Ok guys, well later that day I was really LOSING MY MIND cause my XP system was still pegged at 100% CPU utilization. Then I noticed the battery indicator had (unknown) as the percentage even though I know it had a full charge. I figured something must be wrong there.

I rebooted into OSX and everything worked fine there so then I booted back into Windows and everything was good again.

It happened to me again today and the trick worked again. I remembered I needed to post here so it might help someone else in the future.

So no one has had this problem? Can anyone tell me what's happening because I'd really like to know how to solve this so it doesn't happen in the future. :confused:
 
andybezaire Mar 16, 2007 05:30 PM
disable the battery driver
hi.

i found that if i disable the battery driver, the cpu goes down to 0% and everything works like normal.

except - you can't see the battery status and don't have any idea how much charge you have left. i think windows thinks you are on ac power instead of battery, so the power management might use the ac power profile.

i don't have osx to boot to to see if that will temporarily clear up my problem. i'm stuck here and would like to get my battery status back. any ideas from anyone out there?

andy
 
trappedatuf Mar 16, 2007 07:07 PM
Well I guess you just totally reformated to WinXP, so I'm not sure of another fix other than booting into OSX and I guess NO ONE else has had this issue? It seems odd that no one else would have had this issue though.

Can you tell me exactly what you disabled when you say "I disabled the battery driver"? Maybe I can fool around with mine and try and help you out.
 
cblanchi Mar 17, 2007 01:17 AM
Hi,

This is sad but I am really glad that other people are having this CPU at 100% problem, I was really starting to wonder if I was the only one with this problem.

I started working on my MacBook Pro in November and since then have encountered the same problem 3 times. (Every time, acrobat reader 8 somehow found a way to get installed on my machine. Not sure if the two are related but it make me wonder). The first time, I re-installed XP. Yuck. At least none of the files were lost, just all the software licenses, configs etc.

The second time, I had an Acronis file backup. Acronis does not support image backup on the bootcamp partition and the boot disk cannot find a keyboard so the restore complain a lot about not being able to overwrite files. In the end I managed to damage some of my drivers by doing an Acronis restore that did not completely take. XP was still bootable, clearly not all devices were functioning but the CPU was now down to its normal levels :) ( The video driver at that point was clearly the default device driver)

I re-installed the bootcamp drivers and that took care of the problem.

Clearly, killing / un-installing the faulty driver(s) is step one of the solution, re-installing the boot camp drivers is the second. The problem seem to be doing step 1 properly.

This 3rd most recent time, I figured I would de-install the drivers and re-install them. That did not work since de-installing the drivers and rebooting did not get the CPU load to decrease. At this point re-installing the boot camp device driver is not really possible under those conditions because the install takes forever and when it actually tries to talk to the devices, it never seems to make progress, probably because of the flood of interrupt calls that seem to be happening as the result of the faulty device driver. I had to re-install XP again!

The trick would be to somehow force the install of the default XP drivers for all devices, reboot and then install the bootcamp drivers again. I have not found any such a utility.

Resolved to at least avoid the dreaded re-install solution, I used copycatX to make a image of the XP bootcamp partition and it seems that this could be used to make a full image restore of XP under boot camp. This product is simpler than other solutions to do the same thing.

Today, installing Acronis 9.0 corrupted my XP to the point where I could not even boot in safe mode. I was hoping the restore would now work but the only problem is that although all the files seem to have been properly restored but there is an issue with the boot sector as XP cannot find any of its Dlls. User error, a work in progress?

This is the new second front on the battle to platform stability for which I am also looking for solutions!

Christophe
 
andybezaire Mar 17, 2007 01:29 AM
disabling the battery driver
control panel->system->hardware->device manager
look in your computername in 'batteries'

microsoft acpi-compliant control method battery

right click on that and select disable.

the cpu should drop from 100% down to near 0%.

for me, enabling the driver brings the problem back again.

i have windows xp home.

hope this was detailed enough. if not, ask and i'll post more. thanks

andy
 
severan Mar 29, 2007 09:58 PM
Hi guys,
I am having the exam same issue, and my friend in the office as well. Definitivelly looks like something wrong with ACPI
have you guys found a work around ?

thanks

sev
 
silver Mar 30, 2007 01:29 AM
Hi All-
Has anyone tried using the new bootcamp drivers released yesterday? Did the drivers solve the power management issue causing the cpu to skyrocket? Also anyone else notice the crazy fan activity. Simple things like typing in Word or surfing the internet causes the MBP to heat up almost to the point of being unbearable.


silver
 
trappedatuf Mar 30, 2007 03:14 AM
I just installed the new 1.2 drivers and I am going to have to wait and see. I hope it fixed it, but I was happy enough because it fixed my touchpad not working from resume issues!!!

Silver: No, the fan works ok for me. Every now and then the fan kicks on high but it seems like just a normal response to cool the system down from heavy processing.

Severan: The workaround I use is this: I hibernate Windows when it starts pegging the CPU (it will still do this albeit slower than normal). Then I just hold down the alt (option) key when I restart my laptop and choose to boot into the Mac OS. Then I play in there for a second (it's kinda like having a fun time at recess for us Windows users) and then I restart and it boots me back into Windows, right where I left off with everything working fine. This ALWAYS works for me and should work for you too.

Earlier in this post AndyBezaire noted that disabling the battery driver in the Harware Manager would work, but I never have gotten Windows to be responsive enough to try this when it goes to peging the CPU. It's always too slow and I can never get to disable the driver because the CPU is already at 100% and struggling.

My way works for me all the time and this has only happened about 4 or 5 times since I bought my MacBook about a month ago. Hopefully this thread will die because the new drivers fixed this issue but if it doesn't post back here and let us know!
 
severan Apr 3, 2007 09:42 PM
Guys,bad news the issue is still there even with the 1.2 drivers.
I am trying to find a way to reset the ACPI when the problem occur, I let you know if I find anything...

Sev
 
Unseelie Apr 5, 2007 01:38 PM
Perhaps a silly question, but when you see your machine spike to 100% CPU utilization, which process is it that's pegging?
 
severan Apr 9, 2007 03:10 AM
right so its no process in particular, its basically the Kernel. I use process explorer and I am sure of it.
 
ghporter Apr 9, 2007 09:07 AM
Ok, I had to read this whole thread to get a grasp on what's going on.

First, why did you title it anything about "PowerBook" when you're talking about Boot Camp? PowerBooks use non-Intel processors and cannot run Boot Camp. That was headache number 1.

Now, you mention that you're having this issue with a MacBook. Not a MacBook Pro. There's a whole different forum for MacBooks-this one is for MBPs and PowerBooks.

Third, we ALSO have a forum set up to help folks with OSs other than MacOS. It's called the Alternative OS forum. That's where Boot Camp + XP questions are supposed to go.

Now my problem is this: do I rename the thread to reflect that you're talking about a MacBook? Probably. Do I move the thread? Definitely. WHERE? I'm not sure that this has anything to do with which computer you're running, and it definitely is related to running XP on a Mac. So I'm going to rename it to reflect that we're NOT talking about a PowerBook, and I'm going to move it to the Alternative OS forum. I will make sure there's a link to follow so you won't lose track of this one.

I wonder how I managed to miss this way back in March...
 
trappedatuf Apr 9, 2007 09:31 PM
ghporter: Sorry for the confusion, I created the thread and I think I was so distraught about my MacBook having these issues that I didn't properly name it and such. I have no clue why I said Powerbook, lol!

Just an update to all: I have been using the new BootCamp 1.2 drivers and since then have had NO issues, I hope this is because the drivers work but severan said he is still getting the problem with his 1.2 drivers so it might just be that I haven't been hit yet.
 
texr Apr 16, 2007 02:54 AM
Same issue - worse problems now
I had this same issue with my MBP (about 4 times - also with the latest Boot Camp 1.2). This last time it happened, I really got my system into trouble and need help to get it working again. Here are the details:

For me, suspend would work, and allow the system to cool down a bit. I would then resume and try to shut the system down. Shutdown would get almost finished, but then hang with a black screen and a cursor.

I had power mapped to hibernate, so holding power wasn't going to work without triggering hibernation first. Hibernation from thist state actually worked, however when resumed there was nothing I could do still. I tried booting into OS X, and wanted to try loading parallels, hoping it would say hybernation was invalid or corrupt and allow me to boot fresh. Unfortunately it would always try to boot the hybernated system and just lock up - I couldn't find any way to prevent it from doing so.

So I switched back to boot camp and resumed the hibernated state, then just held down the power button to kill it (which triggered hibernation and killed it *while writing the hyber-file*). I thought this would just make it corrupt and allow me to boot fresh again. Unfortunately it also somehow corrupted my core OS files and my OS install was hosed at this point.

After this, I tried starting it in target disk mode to restore the files manually from another PC. I then rebooted the MBP and lo and behold my windows install was really screwed now. It just went straight to a black screen and froze. (black screen of death?)

I tried to connect with target disk mode again, and now my PC can't see the disk anymore. The first time, it showed the disk properly with each partition in the Disk Management console. Now it just shows one "Removable Disk" with no media present!

I have an image (Acronis) that I could restore files from, but it looks like I've lost my only avenue to do that.

Does anyone know what happened to my target disk mode and how to fix it?

Thanks,
-Tex

PS. Sorry for the lengthy post...
PPS. Also sorry for the switch in topic to a problem with target disk mode. Should I post that question somewhere else?
 
texr Apr 17, 2007 05:44 AM
Fixed my problem (sort of)
So I finally restored my system. I found out that if I uninstalled the device and reboot after connecting it in target disk mode, it would work again the next time I connected it *one time*. So I was able to do this a number of times, eventually restoring my windows install from my backup image (but not able to restore the full image).

Of course, this won't necessarily fix the original 100% CPU problem. But at least I have a working system again.

-Tex
 
uruiamme May 3, 2007 10:39 PM
I tried some Microsoft "not regression tested" hotfixes on my MacBook Pro Core 2 Duo. I think that fixed it for me. Take a look PEOPLE and see what program is running hot in Task manager. On my computer, it was EXPLORER.exe which caused me a lot of trouble. I have been messing with Windows for over 10 years, and this was a difficult one to crack. I hope it's fixed now. I had done some System Restores, uninstalled some automatic updates, and all sorts of things. Then a day after I used the "not regression tested hotfixes" my MBP works fine. I did reboot into Mac OS X once, maybe that helped a little?
 
trappedatuf May 7, 2007 08:23 AM
Just a note guys... as andybezaire pointed out early in this thread, it's the "microsoft acpi-compliant control method battery" driver that is causing the issue. I don't know why but this driver messes up and then pegs the CPU. If you can go to Control Panel > System > Hardware Manager and then disable the driver the CPU goes back down and you can use the system again. The problem is sometimes the system is just too unresponsive to be able to disable the driver. Anyone know of a quick way to disable the driver?

My method of fixing the lockup: Everytime I had an issue I would hibernate Windows, then boot into OSX and just shut down and boot back into Windows and that apparently would 'refresh' or 'fix' the battery driver and everything would work fine. This should work for everyone as booting into OSX apparently resets something and makes the battery driver work again.
 
tofferr May 15, 2007 10:33 AM
trappedatuf,

I believe you are right, that it is the battery driver. I will certainly try that once the problem repeats. I too have seen good results from booting to Mac OS X and then going back to Windows. I too would love to know if there was a command line way to disable the battery driver.

On a similar note, does anyone know what disabling the driver does? Ie, could we just leave it disabled 24-7?

We have been discussing this same problem (with less success) in this Apple thread:

Apple - Support - Discussions - 100% CPU Use ...

Thanks,
Chris
 
johncornfield May 15, 2007 09:52 PM
100% CPU and disc corruption
I have been having very similar problems as toffer from the bootcamp forum but also drive problems which proved to be fatal for my drive, however I did mange to retrieve my data using another macbook pro and disc warrior, a more detailed description can be found here, Apple - Support - Discussions - My Boot camp experience and a few ...
and the toffer's thread.
Apple - Support - Discussions - 100% CPU Use ...
there is definitely a pattern emerging, do any of you experiencing this problem have skype running on the XP partition?

John
 
johncornfield May 16, 2007 05:29 AM
This is certainly geting more interesting, this battery ACPI driver is an interesting angle, last night just after posting my reply I put the machine to sleep by closing the lid with at least 50% battery remaining on the XP meter, it did go to sleep cos all the lights went out, this morning when I tried waking it up it wouldn't, except this time it was cold, and I had to connect the mains charger to wake it up, it resumed windows fine and is working normally.

If I disable the the battery ACPI driver will the battery still be maintained correctly or is there a risk of damaging it?

I have been rifling through the event viewer to see if anything is a miss there, I have found a couple of events in the system events that I don't like the look of, the first one is an ACPIEC error that has occured several times, this is the detail info from event viewer,
Event Type: Error
Event Source: ACPIEC
Event Category: None
Event ID: 1
Date: 11/05/2007
Time: 09:56:13
User: N/A
Computer: MACBOOK
Description:
\Device\ACPIEC: The embedded controller (EC) hardware didn't respond within the timeout period. This may indicate an error in the EC hardware or firmware, or possibly a poorly designed BIOS which accesses the EC in an unsafe manner. The EC driver will retry the failed transaction if possible.

I have also been getting a lot mote BTHUSB errors every time the machine wakes up from hibernation, this is the details again
Event Type: Error
Event Source: BTHUSB
Event Category: None
Event ID: 17
Date: 10/05/2007
Time: 12:50:55
User: N/A
Computer: MACBOOK
Description:
The local Bluetooth radio has failed in an undetermined manner and will be unloaded.

Is anyone else getting these errorrs in the event viewer?

It seems to me that there is a little more work to do for apple with the bootcamp drivers, I guess that is what a public beta is.
 
johncornfield May 16, 2007 09:54 PM
Next episode

I have stopped my machine from going in to standby and set the hibernate timer to 5 hours, now I am getting the 100% CPU regurlarly so I can observe the problem while the machine is still awake, I disabled the ACPI battery control in device manager and it didn't stop the 100% CPU reading so I took the battery out and the system idle immediately went to 50% and within a minute it climbed back to 90 %, put the battery back in and it immediatly went to 100% CPU so I took the battery out and went back to 99% system
idle put it back in and straight back to 100% CPU, the machine is at 100% CPU as I am writing this.
Conclusion 1 is the battery driver is causing the high CPU usage, still haven't found the trigger, I haven't discounted the skype connection as a trigger yet, as it is always running. I will try with skype not running tomorrow.

Anyone who has this problem can you try removing the battery to see if it stops the 100%CPU, I will have to post this quickly as my putor is getting very hot.

I have just removed the battery again and the system idle has immediatly gone up to 99% and the fan is slowing down, I just have to be careful not to knock the power plug out, great idea the magnet but a bit vulnerable when there is no battery.

I still haven't found a link to my drive corruption, maybe this is connected to repowering the system after crashing out of windows, or there is still a macdrive/AVG issue to be resolved, I will try this next week when I have had a chance to clone both partitions.

Anyway I feel there is definite progress with the 100% CPU issue, I think there was a reply earlier in this thread that suggested removing the battery, should have taken it to heart more.

Try it out anyway.

John
 
yggdrassil May 24, 2007 04:51 AM
This may not work for everyone, but I found a reasonably simple solution to my 100% CPU problem. Simple as in the fix, not the stupid amount of time if took to figure it out. Like most in this thread my CPU use was not tied to an individual process (thus either Trojan or Virus most probable) but spread out through all processes and both cores. After a while I noticed that the battery monitor didn't work, and also remembered that I inadvertently hard booted into OSX just before the problems started.
So, the solution for me was simple. Reboot setting up bootcamp to bring up OSX, reboot from OSX via bootcamp back to Windows XP, and the problem has not been seen since.

K

Edit: Left the MBP on over night and found it at 100% the next morning. The same trick worked again. DS!
 
zamnut6 May 28, 2007 09:35 PM
I just wanted to relay my experience with this problem

I have a Compaq tc4400. It also has given me an issue where I get 100% CPU usage. The % CPU is shared among various tasks - notably the services task. When I unplug the laptop's power my CPU usage goes to a normal 5%. Of course this is quite a pain because I have an old battery and it doesn't last very long off AC power.

A number of things I have noticed:

I have an older battery - I think that ACPI is involved - especially since AC power removal solves the problem.

When I insert 2 RAM sticks the CPU usage goes to 100% constantly - one stick is better but still pretty bad.

When my PC goes to standby and then out of it - the problem miraculously goes away - at least with the one stick of RAM - havent tried it with 2.

I have looked all over the web for a solution - none of the updates from Microsoft work (no surprise). I have tried Update agent updates, KB896256-v4, KB918005-v4, KB927891-v3 and have XP sp2. I also tried disabling the Microsoft ACPI-Compliant Control Method Battery without success.

Interesting problem - it seems to be a hardware and software interaction that is causing it. It involves memory, battery power and the OS and/or drivers. I will be getting a new battery soon - i suspect that will improve things.

The bottom line is that I have a working computer now that I have changed the power settings to have the computer go into system standby after a few minutes of idle (actually I only needed to have it go into standby once). I have been problem free all day now with AC power. I have been pulling out my hair for a week now - I am very glad to be rid of the problem.
 
zamnut6 May 28, 2007 10:11 PM
One other thing. Severan mentioned using Process Explorer. It was an excellent suggestion - you can download a free copy at:

Process Explorer for Windows v10.21

Its quite a cool tool - it gives quite a bit more detail than the task manager.
 
candypants May 31, 2007 03:22 PM
I've been having this problem with my macbook as well.

I've found that if you suspend the ACPI.sys thread in the system process (using process explorer) you can make your system usable again. This happens so regularly that it is the first thing I do when starting up in winxp.
 
gpesci Jun 2, 2007 01:48 AM
There is hotfix from Microsoft that solves this problem
Hi, I have a 17" powerbook pro, and I had the same problem. I found that the ACPI was consuming all the CPU. Disabling the ACPI driver fixed the problem. But, I found a Microsoft mandatory hotfix for dual core CPU not automatically downloaded with Windows Update. You can check this site for more information. After installing the hotfix, everything worked fine again.
Regards.
 
Cold Warrior Jun 2, 2007 11:29 PM
Damn, validation is required to download that hotfix.
 
ghporter Jun 3, 2007 09:37 AM
...And damn has Microsoft made its Validation process a pain! I had to download and run a plugin and then a utility to validate my genuine, authentic, true blue copy of XP to get this stupid file...Which may be available here if things work as they should... Or here on Intel's Japanese site (I don't read Japanese, but "KB896256 hotfix" is there in English)... And Googling "KB896256 hotfix" will probably be helpful too.
 
tofferr Jun 4, 2007 03:53 PM
That hotfix seems closely related... but, it just talks about performance problems... I wish they said specifically that it fixes a problem of consuming 100% CPU. For now I'm going to not install this hotfix and keep an eye on this thread and see what comes from it.

BTW, yesterday I had this problem again and I confirmed that I could stop it by disabling that driver... then reenabling it brought it back again.
 
ghporter Jun 4, 2007 06:15 PM
Quote, Originally Posted by tofferr (Post 3396244)
That hotfix seems closely related... but, it just talks about performance problems... I wish they said specifically that it fixes a problem of consuming 100% CPU. For now I'm going to not install this hotfix and keep an eye on this thread and see what comes from it.

BTW, yesterday I had this problem again and I confirmed that I could stop it by disabling that driver... then reenabling it brought it back again.
Why would MS say that this fixed a problem with the ACPI driver when they don't' say there is a problem with that driver? That would be admitting that they had a problem, right? Instead they can "enhance performance" and dodge that bit of responsibility.
 
gpesci Jun 5, 2007 04:22 PM
They say that Windows XP is not designed for two or more processors, so they found a bug in the way the ACPI driver detects when there is no activity.
I know that they are not very clear in the way they say what problem they fix, but I understand this because I work in a software company too.
Believe me. I installed the hotfix and problem stopped!
 
yggdrassil Jun 11, 2007 04:53 AM
It's also worth pointing out that the solution above will only work with the latest version of bootcamp. There are new Intel drivers in there that solved (I think) the problem for me. Did everything described above (and more) and still had the 100% CPU problem, but after installing the new Boot Camp drivers the problem has gone away.
 
aldvmaster Sep 13, 2007 12:34 AM
MBP installed with BootCamp 1.4 and WXP SP2 updated
Hi...

bad news is that the 100% CPU came back just now with my MBP C2D fleshly installed with BootCamp 1.4 against the WXP SP2

I had to go to Process Explorer's system/properties and suspend the ACPI.SYS thread as described and the CPU utiliization dropped to normal.

i then tried the "UPDATE: Windows XP Hotfix KB896256 Version 4 (From Microsoft)" .. but the system can't shutdown or reboot which is stuck at the blue screen.

after reboot, CPU 100%..

help!
 
bodef Oct 12, 2007 05:51 PM
Work around solution
Found a "work around" solution.

I am on BootCamp 1.4 and Windows XP SP2 with hotfix KB896256, and the 100% CPU problem still exists.

To reproduce problem:
  • Run with the battery in place and plugged in
  • In "Power Option Properties", set both the "System standby" and "System hibernates" to at least 2 hours
  • Don't touch the computer for 2 hours
To recover:
  • Reboot into Macintosh HD and reboot back to Windows
To prevent the problem with a "work around" solution:
  • In "Power Option Properties" set the "System standby" to at most 1 hour :)
 
bodef Oct 16, 2007 03:29 AM
Sorry to say that the proposed "work around" solution doesn't prevent the 100% CPU problem completely - it only seems to minimize the probability of it occuring. :(

The shorter you set the "System standby" delay, the less you are exposed to encounter the problem - I'm currently running with 30 minutes.
 
maczor Nov 12, 2007 07:15 PM
Has anyone with this problem tried installing Bootcamp 2.0 (the version that comes with Leopard). Does this fix the issue?
 
zamnut6 Mar 12, 2008 07:18 PM
I found something interesting that might be relevant. Recently I had all of the symptoms expressed above on my TC4400. None of the windows updates helped. When I had this problem earlier (see above) going in and out of standby fixed the problem. This did not cure my recent tangle with this problem, however. I finally did figure out what was causing the issue. My cat had chewed through my adapter power cable. Even though the battery was charging properly with the adapter, I found that this was the cause of my computer going to 100% cpu. Replacing the adapter with a new one cured the problem completely. Apparently, the adapter was not quite properly working and windows reacted poorly - the only sign it gave me was pegging the cpu cycles. The problem is similar to what is described above in that it involves the way windows deals with power. Hope this helps someone.
 
crazyBrit Mar 13, 2008 11:41 AM
Leopard Drivers
I have been having this problem forever too. I am using the Leopard drivers. However, yesterday, I reinstalled them, and so far, so good. Anyone else having this problem with the Leopard drivers?
 
ghporter Mar 14, 2008 08:17 AM
It's not "Leopard drivers" really, it's "the Windows drivers that come with Leopard". That's no subtle difference-Windows drivers are both crucial and sometimes finicky. And interestingly enough, you won't always get a warning/error if you try to install a driver and it doesn't properly install. Crazy, I think that may be what happened to you: the first time not all the drivers installed successfully and Windows didn't notify you of their failures. When you install a driver, it's a good idea to go into the Device Manager and make sure that there isn't some orphan device with a sad little "!" next to it, indicating that hardware is detected but isn't working because of a lack of a driver.
 
Goon Apr 7, 2008 02:17 AM
Same problems
Well I installed the Bootcamp 2.0 drivers for windows, and every now and then, the fan decides to go on, and the CPU goes high in usage, and I see System up. I don't see any ACPI usage.

I reinstalled the drivers several times. I was wondering what would happened if I uninstalled bootcamp then reinstalled it?
I don't want to format and restore everything, that and I'm still using Tiger, but my friend let me have his driver's CD since he wasn't using Windows.

Is the battery meter suppose to be active. Was it narrowed down to this problem?
 
ghporter Apr 7, 2008 07:24 PM
Welcome, Goon!

Please explain what you mean by "uninstall bootcamp". Once you're partitioned, have XP installed and have the Mac drivers installed, Boot Camp itself, as a utility, is pretty much irrelevant. You can use it to delete that Windows partition, but otherwise you don't need it.

If you're talking about removing the Boot Camp-supplied Mac drivers, that's another thing entirely. I'm not certain whether I've installed the BC 2.0 drivers on my 2.0GHz Core Duo MBP, so I can't actually comment on what is causing what. But there is ZERO interaction between Windows and OS X when you're booted into Windows, so it's highly unlikely that anything about the drivers that came with Leopard causing any difficulty for you.
 
Goon Apr 8, 2008 01:57 AM
Thanks for the welcome!

Yes, I understand OSX Bootcamp and Windows have nothing working together.

I actually uninstalled the Bootcamp Drivers that came with Windows, and reinstalled them. I ended up doing repairs, and so far nothing has come up, but I also added in another variable, which uninstalled my Kaspersky Antivirus. I had Symantec running the other time, and so far no problems too. Forgot to mention about the AC thing without the battery meter.

Ugh, I never had problems like this before, and the Macbook is a little over a year old.
Idledefinitely runs up to 100%

----
On another note:

My wireless on OSX doesn't work. It works the first few minutes. XP connects fine and I get my connection, so it's not the router. Is there any way to remove the Parallels Network thing? I wonder if that's bothering it. Ethernet works, and the Firewire connection through my PC doesn't work any more either. Any sort of way to repair OSX, without having to do an Erase and Install?

Sorry for the change in topic. :p
 
Goon Apr 18, 2008 09:28 AM
This works for me.
I don't think it was the anti-virus software at all.

My Macbook was running fine, with the AC Battery disabled. It would fan up at night, but it was only temporary. After enabling it the other day, it would start using more computer process and I couldn't run anything, so it's been off for me now, and working great!

As for the OSX thing, I ended up having to take out those Network additions from Parallels. :p
 
clindh Oct 28, 2008 06:52 AM
Another work-around
When I suspect my computer is getting bogged down by this issue I start up "Process Explorer"
If no process but "Deferred Procedure Calls" shows a high load number it's always this battery issue.

- Remove the battery (the CPU load dissappears instantly)
- Hibernate (or shutdown)
- Remove the power cord from computer
- Press the ON-button for many seconds (say 10)
- Reattach power and battery and start up - problem gone

This resets the SMC : http://support.apple.com/kb/HT1411
It works for me at least and is a little quicker than booting into OSX for a while.
 
All times are GMT -4. The time now is 12:59 PM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2015, vBulletin Solutions, Inc.


Content Relevant URLs by vBSEO 3.3.2