MacNN Forums (
-   Alternative Operating Systems (
-   -   Cannot install XP - "This disk does not contain a Windows XP-compatible partition" (

Matthew Attoe Oct 31, 2009 09:03 AM
Cannot install XP - "This disk does not contain a Windows XP-compatible partition"

I'm in the middle of reconfiguring my Mac Pro and one of the things I wanted to do was use a Seagate 1.5TB drive as my boot drive.

I wanted to have 3 partitions on it: Snow Leopard / Music / Windows

Now it seems I have 2 issues - the first is that officially I can't have 3 partitions and still install Bootcamp / XP (although there seems to be various ways around this).

The second issue is that i can create a 200GB Bootcamp partition but I can't get XP to install.

Basically, I partitoned the 1.5TB drive into one big 1.5TB GUID partition. I installed Snow Leopard on to this partition and updated to 10.6.1.

I then used BootCamp to create my 200GB XP partition. So far so good.

I boot up from my XP SP3 disc and the Windows Setup all seems to start correctly.

As I proceed through, i can see my 200GB BootCamp partition (it says BOOTCAMP <FAT32>) but when I press enter to install on this partition I get another screen appear saying that Windows Xp needs to write some files to this disk and that "This disk does not contain a Windows XP-compatible partition".

Previously, when I've installed XP/BootCamp I get an option to reformat the partition as NTFS but I never even get this far.

I even booted into XP from another XP/Bootcamp drive and formatted the partition to NTFS, but when I then try to install on the partition I still get the same "This disk does not contain a Windows XP-compatible partition"

I've spent the last 5 hours trying to sort this - does anyone have any ideas? Please? Really, really please? :)

Thanks in advance,

ghporter Oct 31, 2009 09:20 AM
You need to tell the XP installer to format the partition before installing. This is because, while Boot Camp "marks" the partition it makes as being formatted with either FAT32 or NTFS, it doesn't actually format it.

I would not format a partition that large with anything but NTFS. FAT32 is not that flexible, and while it can theoretically handle an 8 TB partition (max), the "slack" or unusable space between files at even 200GB would be around 50%-you'd have only 100GB of usable space. NTFS does not have this limitation.
Matthew Attoe Oct 31, 2009 09:43 AM
Hi ghporter.

That my problem - I don't get the option to format the drive - I don't get that far.

As soon as I select the drive by pressing ENTER, this is when I get the error message. From memory, the option to format the drive is on the next screen, but I just don't get that far :-(

Any other ideas?


ghporter Oct 31, 2009 10:31 AM
There could be an error on the install disc. The Installer is notoriously poor at handling disc errors, as MS chose to use a optical drive driver that was basically universally compatible-but has almost no error handling capabilities. While it may be good that it can handle CD drives older than most users, they miss out on hardware error detection and correction, which is very helpful. I'd use Disk Utility to image the install disc, then burn a copy-imaging and burn software, in general, have far better error handling and correction capabilities than the installer's driver, making it possible for the user to make a usable copy of an unusable original. It's worth a shot. Sorry to say that's all I have...
Matthew Attoe Oct 31, 2009 11:02 AM
Thanks for the pointers - I appreciate it.

I did wonder about the install cd so i even tried my sp2 cd which I'd used before - but same problem there too.

I'm going to try another 1.5TB drive I have spare and see if that works.

Thanks again,

Matthew Attoe Oct 31, 2009 03:30 PM
OK - I worked it out!!! I can't believe what it was either!!!

I had an IDE hard drive installed in one of the optical drive bays. It was THIS drive that Windows was complaining about - not the drive I was trying to install to!!! Poxy Windows.

Unplugged this drive and it's all installio-a-go-go at last!!! Finally!

Thanks again,

ghporter Nov 1, 2009 11:59 AM
That's really weird, but I'm glad you got it sorted out.
justmetoo Nov 15, 2009 01:41 PM
OK here is some fresh news on this problem, at least I haven't read of anyone else trying this to overcome the bootcamp partition format problem.

I had a miserable time getting a fresh Snowleopard bootcamp3 partition to install XP Pro JUST so I could jumpstart a Win7 64 bit 'custom upgrade/clean install. The problem was exactly as above, I was never given the blue screen option to format the partition to NTFS, the install would continue, and on reboot would just get that black error screen requiring a hard shut down.

I deleted the partition a few times and started over, completely wiped the drive at least 2 times times, and kept banging my head against the wall because I had successfully used that OEM XP Pro install disc several times before for bootcamp *beta* installs. I had read that others got around this bc format problem by using a different XP install disc, but that was not an option for me.

SO this is what I did. I still have an old drive with OS 10.4 Tiger and bootcamp beta laying around. I used Superduper to clone it to my new harddrive, set the date back to 2006 (so bootcamp beta would work) and created a partition to install XP. It worked first time, gave me the NTFS format option, the whole bit, next to effortless...

THEREFORE, I strongly suggest there is a bug on the Apple side within bootcamp 3 that was not there during the beta stage!
All times are GMT -4. The time now is 04:18 AM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

Content Relevant URLs by vBSEO 3.3.2