MacNN Forums (http://forums.macnn.com/)
-   Applications (http://forums.macnn.com/applications/)
-   -   Transmit 4 - Mount drive file caching issues (http://forums.macnn.com/82/applications/421539/transmit-4-mount-drive-file-caching/)

 
dereko Aug 29, 2010 02:02 PM
Transmit 4 - Mount drive file caching issues
I love the new transmit 4. I was all ready to purchase it but..

The part I use the most is the mount remote location feature.

It seems to be perfect for editing files on my development server with
my text editor.

My problem is that lately i've noticed a few times at some point when
i open a file it is showing me an old version of the file. As if its
cached what was in the file the last time it was open. So I'm
accidently overriding files on my sever. In my case I often use git
to update the files on the remote server. When I do this and try open
the file with any text editor (I've tried a few) it displays an old
version. If i go to the remote server directly it shows the correct
one.

This is a major issue because I can no longer trust that the file I
open is actually the contents of the file and worse I can override the
newer version with this incorrect information when I save.

Can you tell me if this is a common issue and do you have any
suggestions on how to solve it?
 
Thorzdad Aug 29, 2010 03:39 PM
Have you tried asking Panic directly and seeing what they say? Seems to me if this is an issue that is keeping you from purchasing, they will be more than happy to help you.
 
dereko Aug 29, 2010 04:14 PM
That's precisely what I did :)

I just wanted to put it out there and see if anyone else is having a similar issue.
 
SleepyJay Aug 2, 2012 01:13 PM
Two years of suspense... What did Panic answer?

jason.
 
nicottrell Sep 18, 2012 05:07 AM
I'm currently having a very similar (identical?) problem with the current version of Transmit against a Linux server. I've reported to Panic and they say that it's a known issue they are working on. I hope it won't take another 2 years to get a fix out there :(
 
litzastark Mar 13, 2013 12:42 PM
I'm having the same issue, and it's almost enough to make me want to return my new Mac and go back to Win or Linux; I can't find a speedy, reliable way to mount external drives, which is a major part of my workflow.

nicottrell, did you discover any solution or get any response from Panic? I wrote to them as well but haven't heard anything.

There doesn't even seem to be a way to force-reload a file/directory/server; the "Refresh Finder" option in the menu doesn't appear to do a thing. I haven't been able to get updated files except by restarting my computer (!) since I seem to be unable to unmount the drive.
 
mduell Mar 16, 2013 12:57 PM
Try MacFusion instead; it's free and Free.
 
All times are GMT -4. The time now is 12:59 PM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2016, vBulletin Solutions, Inc.


Content Relevant URLs by vBSEO 3.3.2