MacNN Forums (http://forums.macnn.com/)
-   Applications (http://forums.macnn.com/applications/)
-   -   iPhoto won't connect to Photostream (http://forums.macnn.com/82/applications/497550/iphoto-wont-connect-to-photostream/)

 
gradient Jan 26, 2013 12:04 AM
iPhoto won't connect to Photostream
Running Mountain Lion.

I created a new user and wanted to migrate my iPhoto library over to it. Just did a simple copy. Everything works fine except that I can't connect to Photostream with this new user.

I've tried logging out of iCloud and deleting the iCloud keychain entries, the logging back in but that didn't help.

I opened up console and see that I'm getting the following errors when iPhoto tries to connect:

__________________________________________________ __________

2013-01-25 7:34:26.918 PM iPhoto[43647]: Timeout launching photo stream agent

2013-01-25 7:34:26.941 PM com.apple.AppSandboxSMLoginItemEnabler[43658]: FAILURE: Failed to open property list at file://localhost/private/var/db/launchd.db/com.apple.launchd.peruser.504/overrides.plist for reading. (The operation couldn’t be completed. No such file or directory)

2013-01-25 7:34:26.950 PM com.apple.AppSandboxSMLoginItemEnabler[43658]: FAILURE: Failed to write property list at file://localhost/private/var/db/launchd.db/com.apple.launchd.peruser.504/overrides.plist. (The operation couldn’t be completed. No such file or directory)

2013-01-25 7:34:26.956 PM com.apple.AppSandboxSMLoginItemEnabler[43658]: FAILURE: Could not repair overrides database: 0x2

2013-01-25 7:34:26.966 PM com.apple.AppSandboxSMLoginItemEnabler[43658]: FAILURE: Failed to open property list at file://localhost/private/var/db/launchd.db/com.apple.launchd.peruser.504/overrides.plist for reading. (The operation couldn’t be completed. No such file or directory)

2013-01-25 7:34:36.918 PM iPhoto[43647]: Timeout launching photo stream agent

__________________________________________________ __________

504 is the UID for my user, so I went and looked in launched.db and sure enough there isn't a file there for my user (though there are 18 other ones).

Am I on the right track? Any ideas what to do next to sort this out?

Thank you!
 
gradient Jan 28, 2013 03:39 AM
Huh, suddenly today it started working - I decided to try enabling photostream again and it connected. Went and checked launcehd.db and now there's a peruser.504.....no clue what happened but I guess I'll take it!
 
Spheric Harlot Jan 28, 2013 02:16 PM
My iPhoto had difficulty on January 26th, as well. Last synched photo from Photo Stream was from the 25th (early a.m. US time).
Worked fine again yesterday evening (27th).
 
All times are GMT -4. The time now is 08:31 PM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.


Content Relevant URLs by vBSEO 3.3.2