MacNN Forums (http://forums.macnn.com/)
-   Classic Macs and Mac OS (http://forums.macnn.com/classic-macs-and-mac-os/)
-   -   Can't boot from OS9 (http://forums.macnn.com/64/classic-macs-and-mac-os/120242/cant-boot-from-os9/)

 
caleach Aug 25, 2002 12:34 PM
Can't boot from OS9
recently I decided to do some Spring cleaning on my G4/450 and went through the pricess of salving all the files I needed, etc. I then did a reformat using the OSX cd and then tried to install OS9. Well, I guess I should have done the reformat from the oringinal OS cd that came with the computer and worked my up from there. The problem is that no matter what key combinations I use I cannot get the computer to boot from either the original software CD or any other bootable OS9 cd.

I tried goiong back to scratch and erasing the HD again and starting all over. I erased the HD making sure to check the "install OS9 drivers" and then didn't follow through on the OSX install. I then tried to go back and reboot using the original cd so that I could attempt to start from scratch. But no luck.
Currently I have only OSX installed, it seems to be working ok but anytime I need to run a diagnostic from my Norton Utilities disk I can't because there's no OS9.

Any ideas?
 
Cipher13 Aug 26, 2002 08:31 AM
What exactly happens when you try to boot from an OS9 CD?

Shut down the machine, open it up, and down near the bottom PCI slot, there'll be a little black button near the battery. Press it a few times and try again.
 
caleach Aug 26, 2002 12:55 PM
can't boot from OS9
Well, it seems to be going through the normal startup routine and then hangs up for a while and instead of the happy mac computer coming on the screen it just spits out the cd.

I will give you suggestion a try.

I am also thinking of adding another HD anyway to the computer so maybe I'll just load OS9 on that one.
 
kentuckyfried Aug 27, 2002 04:09 PM
Re: Can't boot from OS9
gawddamn, I'm glad to see somebody addressing this issue.

I have the same damn problem but as yet I have no answers from anybody yet.

I was considering reformatting the hd using my OS X cd's and making sure the "install OS 9 drivers" box is clicked on (I'm rather sure it was on last night but I dozed off a little during the installation process).

Yeah...it's frustrating. Here's what happens:

on the OS 9.2.1 cd...I try to install on a partition, but then I get this message that says, "cannot install on this machine, see documentation for details." Ummm...OK, whatever, the documnetation says that it's perfectly OK to install on any machine.


And then...I poppsed in the OS 9.2 cd....hell...even the ibook won't start up from this cd, the folder with the blinking "?" shows up and the computer can't start up from that cd.


WHAT ON EARTH IS GOING ON?!! I've never had problems installing 9.2.x like this before.




Quote
Originally posted by caleach:
recently I decided to do some Spring cleaning on my G4/450 and went through the pricess of salving all the files I needed, etc. I then did a reformat using the OSX cd and then tried to install OS9. Well, I guess I should have done the reformat from the oringinal OS cd that came with the computer and worked my up from there. The problem is that no matter what key combinations I use I cannot get the computer to boot from either the original software CD or any other bootable OS9 cd.

I tried goiong back to scratch and erasing the HD again and starting all over. I erased the HD making sure to check the "install OS9 drivers" and then didn't follow through on the OSX install. I then tried to go back and reboot using the original cd so that I could attempt to start from scratch. But no luck.
Currently I have only OSX installed, it seems to be working ok but anytime I need to run a diagnostic from my Norton Utilities disk I can't because there's no OS9.

Any ideas?
 
kentuckyfried Aug 27, 2002 07:42 PM
Well, I've formatted using the 0S 9.2.1 cd and made 3 partitions:
4 GB, 6 Gb, and 9 GB.

I tried installing 9.2 and 9.2.1 (each cd) once onto the 4 GB one but with no success. Very odd results for a blank HD.

Anyhow, I'm just going to worry about getting 10.2 onto the 6 GB. After that, I'll try to install 9.x onto the iPod perhaps and then drag and drop the whole thing onto the 4 GB partition.

*sigh*
 
kentuckyfried Aug 28, 2002 01:39 PM
OK, I GOT IT!!!!!
The big revelation came late last night.

For some bizarre reason, I couldn't get OS 9.x to install even after booting from a cd. My theory is that the 700 mhz ibook requires the newest full version of 9.2.2...which is NOT included with OS 10.2
Trying to install any other earlier version may not be possible, at least not in a direct fashion. I'm not certain about this.


But anyhow, back to the solution:

I tried copying the system folder from my tower to the ibook...and then tried starting classic. This didn't work.


However, when I copied that same startup folder onto my iPod...I could start classic! Suddenly it became possible to run the installer from the OS 9.2.1 cd...so that's what I did and it worked out fine. *sigh*


To recap:

1. Find some kind of external drive, (or possibly just any second hd
that doesn't have OS 10.2 from which you booted up from).
2. Make sure it has a working system folder on it. A direct drag and drop is OK.
3. Go into OS 10.2's system preferences and select that system
folder as the one to use to start classic.
4. Start classic mode.
5. Insert the 9.x cd and install OS 9.x onto either (1) A partition that's on the same HD as where you have OS 10.2 or (2)
the same HD (?) even if you didn't partition it.


The easiest way is to go with some sort of external HD to startup classic mode. You're then free to install 9.x anywhere.


Sounds kind of confusing but mail me if you're stuck.
 
kentuckyfried Aug 28, 2002 01:41 PM
Re: Can't boot from OS9
Hey Cal,

Did you find the solution yet? I figured how to fix it, please see your thread under "OS 9" for details. Mail be back if you require...
I didn't write the greatest of explanations.

-- Jason



Quote
Originally posted by caleach:
recently I decided to do some Spring cleaning on my G4/450 and went through the pricess of salving all the files I needed, etc. I then did a reformat using the OSX cd and then tried to install OS9. Well, I guess I should have done the reformat from the oringinal OS cd that came with the computer and worked my up from there. The problem is that no matter what key combinations I use I cannot get the computer to boot from either the original software CD or any other bootable OS9 cd.

I tried goiong back to scratch and erasing the HD again and starting all over. I erased the HD making sure to check the "install OS9 drivers" and then didn't follow through on the OSX install. I then tried to go back and reboot using the original cd so that I could attempt to start from scratch. But no luck.
Currently I have only OSX installed, it seems to be working ok but anytime I need to run a diagnostic from my Norton Utilities disk I can't because there's no OS9.

Any ideas?
 
caleach Aug 28, 2002 11:35 PM
can't boot from OS9
I've just read all the posts and really appreciate that someone is actually taking the time to address this, as an earlier reply had noted.

I haven't checked for the button yet, as soon as I finish this I'll shut down and check it out. The only problem now is I don't want to have to redo everything. In the meantime I purchased a Western Digital 100 gig drive to install. I am going to try that and install OS9 on that drive and see what happens.

I hope that I can install on that drive while having started up the normal way in OSX on the main drive.

I'll keep you all posted.

Steve
 
caleach Aug 29, 2002 01:40 AM
Can't boot from OS9
Well, I tried pressing the little black button a few times and restarting, nothing new, still can't use any earlier OS disks.

I also installed the Western Digital 100 gig and OSX wanted to initialize it under OSX. When I pursued that option and the information for the HD it showed up as only 31 gigs. Go figure, so I'm going to return that to Fry's tomorrow.

I'm back to square one. I do have an external QUE! M3 external Firewire drive which I could load OS onto from my TI PowerBook but I can't get this drive to always show up on the desktop in OS 10.1.5

Don't know what to do now.

Steve:confused:
 
kentuckyfried Aug 29, 2002 01:28 PM
Re: Can't boot from OS9
It's OK to startup from you computer running OS 10.2....

It's only afterwards...when you want to startup classic....that startup folder should be on a separate hard drive from where you have OS 10.2 installed (either internal or in your case, that external western digital would've worked fine).

In fact...like I might've mentioned, I used my iPod of all things to start classic. Worked like a charm at around 1:30 a.m., I was happy.

The easiest solution might've been Apple including the full OS 9.2.2 disk (that's my only explanation right now as to why I could install from the cd-rom after I had booted from it...that part was driving me nuts).




Quote
Originally posted by caleach:
Well, I tried pressing the little black button a few times and restarting, nothing new, still can't use any earlier OS disks.

I also installed the Western Digital 100 gig and OSX wanted to initialize it under OSX. When I pursued that option and the information for the HD it showed up as only 31 gigs. Go figure, so I'm going to return that to Fry's tomorrow.

I'm back to square one. I do have an external QUE! M3 external Firewire drive which I could load OS onto from my TI PowerBook but I can't get this drive to always show up on the desktop in OS 10.1.5

Don't know what to do now.

Steve:confused:
 
kentuckyfried Aug 29, 2002 01:35 PM
Re: Can't boot from OS9
(deleted repeat post)
 
fredi Sep 23, 2002 02:59 AM
Sounds like you may have "Open Firmware Password" enabled in OSX.
Open Firmware Password is a security feature that prevents booting to any other volume other than that chosen in the start up disk application. To see if this is true in your case, download Open Firmware Password.app from apple's web site, and disable the password feature. Or start up from your OSX disk (by choosing it in your startup control panel/app) and go to the menu bar (File menu?) and disable the password feature from there.
I ran into the same problem on my ibook and, for me, disabling the OFP fixed the "problem" for me.
 
All times are GMT -4. The time now is 10:37 AM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.


Content Relevant URLs by vBSEO 3.3.2