MacNN Forums (http://forums.macnn.com/)
-   Classic Macs and Mac OS (http://forums.macnn.com/classic-macs-and-mac-os/)
-   -   DVD Player 1.3 on a B&W G3 in Mac OS 9.2.2 (http://forums.macnn.com/64/classic-macs-and-mac-os/123836/dvd-player-1-3-b-w/)

 
JCS Sep 17, 2002 10:28 AM
DVD Player 1.3 on a B&W G3 in Mac OS 9.2.2
Is anyone here able to watch DVDs in Mac OS 9.2.2 using the DVD decoding hardware that Apple shipped with DVD-ROM equipped B&W G3s? I have such a machine, and I used to be able to watch DVDs just fine using the hardware decoder on my OEM Rage 128. But I can no longer get this to work under 9.2.2. Here's my tale of woe, as posted to Apple's discussion groups at:

http://discussions.info.apple.com/We...15@.3bba39c5/1

---

I have a revision 1 B&W G3/400 with a DVD-ROM drive and ATI Rage 128 video card with DVD decoding hardware, both exactly as they shipped from Apple. I have been watching DVDs in Mac OS 8 and 9 for years with no problems, and with full hardware acceleration. But when I recently tried to watch a DVD, I got an error dialog claiming that "Apple DVD Player cannot open because the required hardware was not found." You can see the dialog at the URL below:

http://www.ati.com/support/images/MACDVD%20ERROR.GIF

I tried rebooting with my extensions set to "Mac OS 9.2.2 Base" and "Mac OS 9.2.2 All", but still got the same error. As far as I can tell, I'm running the correct versions of all the required software. The relevant files are listed below:

System Folder:Extensions:

Apple CD/DVD Driver 1.4.7
ATI Driver Update 2.0.4
ATI Graphics Accelerator 5.4.9
ATI MPP Manager 1.2
ATI Rage 128 3D Accelerator 6.3.5
ATI Resource Manager 3.0.5
ATI 3D Accelerator 5.0.4
ATI Video Accelerator 4.8.5
DVD Decoder Library 1.3
DVD Region Manager 1.1
DVD Video Interface 1.0

Apple DVD Player:

Apple DVD Player 1.3
DVD Navigation Manager 1.3
DVDRuntimeLib 1.3

I have a Mac OS 9.2.1 CD and a Mac OS 9.2.2 updater disk image. The 9.2.1 CD won't let me install anything on top of 9.2.2, and re-running the 9.2.2 updater did not fix the problem. I used TomeViewer to check the individual file versions and sizes from the 9.2.1 CD and 9.2.2 updater, and everything seems to match up. I can watch DVDs in Mac OS X on the same Mac, so the hardware doesn't seem to be damaged.

I've searched the web, but all I can find are "easy" fixes like "you need DVD Player 1.3, not 2.7" and "make sure you have your ATI extensions enabled" and "the video card has to be in the 66MHz slot." I've got all of that stuff set up correctly, but still get the error dialog. What am I missing? Please help!

---

The only answer I've gotten so far is that 9.2.2 simply doesn't support hardware DVD decoding on my machine, but that seems crazy! There must be some B&W G3 owners out there running 9.2.2 who are able to use their OEM Rage 128 DVD decoding hardware...
 
All times are GMT -4. The time now is 07:10 AM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.


Content Relevant URLs by vBSEO 3.3.2