MacNN Forums (http://forums.macnn.com/)
-   Classic Macs and Mac OS (http://forums.macnn.com/classic-macs-and-mac-os/)
-   -   OS 10.2 install causes OS 9 internet problem (http://forums.macnn.com/64/classic-macs-and-mac-os/132181/os-10-2-install-causes-os/)

 
rheinhard Nov 16, 2002 03:09 PM
OS 10.2 install causes OS 9 internet problem
(I also posted this note in the OS X forum, but since it also relates to OS 9/Classic I thought I'd put it here as well. Sorry for the redundancy...)

I have encountered an annoying problem that I have been unable to find any reference or solution to online, and wondered if anyone else had encountered it. After recently installing Mac OS 10.2, I noticed a new problem had appeared when I later booted into OS 9. (I keep OS 9 around for some applications I haven't had the $ to upgrade to OS X versions yet, and because I play "phone tech support" for my parents and one or two other friends who are nontechnical types and have older Macs that can't run OS X - and in order to be able to understand what they're doing it helps to be able to look at an OS9 desktop).

Anyway, I found that after the install, OS 9 developed a weird problem with Internet dialup. All my Remote Access dialup settings were unchanged, and I could establish a modem connection which the system claimed was successful. However it seems as if the system can no longer actually route packets through the connection or something... Whenever I try to go to any URL in any web browser (I tried Netscape and IE, to be sure it wasn't unique to only one of them), or do a remote UNIX terminal login (using secure shell with the "NiftyTelnet" app under OS 9), I get an error message that the remote server cannot be found or the name is unknown, or something similar.

I have re-entered my ISP information into the Remote Access control panel, just to be sure that wasn't the problem. And I can easily see that when I use the exact same dialin info when I switch back to OS X, I connect and have no such problem.

I did notice when the OS 10.2 install was running it said something about modifying things in my OS 9 system folder to be more compatible with Classic mode under OSX. I have no idea what these modifications were and whether they are connected to this problem. But since my OS 9 connection worked fine with the same ISP info before the OS 10.2 install, my best guess is that these changes had something to do with my current problem.

So, has anyone else encountered this problem. and hopefully know of a solution that will allow me to succesfully do name lookup and packet routing after successful modem dialup in OS 9? Any help would be appreciated!
 
rheinhard Nov 19, 2002 02:53 AM
(Crossposted to OS X forum)

I finally figured out what was causing my problem with Internet dialup
under OS 9 after I did the OS 10.2 install. The installation process
did say something about making internet function better in Classic
mode. My Appletalk Remote Access controls with my dialin settings were
unchanged, however this evening for the first time I got an alert about
not having PPP selected in the TCP/IP control panel (odd I never got
this warning before when experiencing my problem). Checking TCP/IP
controls, I found it was configured to connect via Ethernet only with
Manual routing configuration. The problem was these options couldn't
be changed! I found this was due to a new setting in the
Configurations menu (Command-K) for TCP/IP for "Classic". I don't think
this was there before. When I switch the Configuration menu to "Setup
PPP", saved the setting, and redialed, things worked fine.

So now I'm curious, if I reboot under OS X without switching TCP/IP
back to "classic" configuration, will this cause a problem using
TCP/IP connections in classic mode?
 
All times are GMT -4. The time now is 02:48 PM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2015, vBulletin Solutions, Inc.


Content Relevant URLs by vBSEO 3.3.2