MacNN Forums (http://forums.macnn.com/)
-   Classic Macs and Mac OS (http://forums.macnn.com/classic-macs-and-mac-os/)
-   -   ActiveX (http://forums.macnn.com/64/classic-macs-and-mac-os/218749/activex/)

 
Langdon Jun 30, 2004 11:28 PM
ActiveX
What is it and how do I install it so I can use google mail in OS9.1?
 
Eriamjh Jul 1, 2004 06:50 AM
It is PC only and does not exist for OS9.
 
Krypton Jul 2, 2004 04:20 PM
Google mail doesn't (necessarily) use ActiveX - Safari and Firefox are able to load the site fine, and neither support ActiveX.

Maybe it tries to use ActiveX if you are using IE.
 
Big Mac Jul 7, 2004 02:50 AM
ActiveX is a major security risk, so much so that MSN's The Slate magazine actually recommended that Windows users switch to Firefox. As others have stated, Safari is officially supported by gmail.
 
chalk_outline Jul 29, 2004 03:20 AM
I used gmail on OS 9.1 with Mozilla 1.2.1 until the other night when I deleted the ActiveX extension. After that it stopped working. But it worked last night for a few minutes. Now it doesn't. Maybe they are tweaking the code over in google HQ or something else is screwy.

And when gmail loads you get the red loading rectangle and just end up with a blank page. I checked the source on that page and found...

<title>Gmail</title><noscript>Javascript is disabled in your browser. Gmail requires Javascript to be enabled in order to operate.<p>To use Gmail, enable Javascript by changing your browser preferences.<p>After enabling Javascript, <a href=/gmail>try again</a>.</noscript><script>var fs_time=(new Date()).getTime();var testcookie = 'jscookietest=valid';document.cookie = testcookie;if (document.cookie.indexOf(testcookie) == -1) {top.location = '/gmail/html/nocookies.html';}document.cookie = testcookie + ';expires=' + new Date(0).toGMTString();var agt = navigator.userAgent.toLowerCase();if (agt.indexOf('msie')!= -1 && document.all) {var control = (agt.indexOf('msie 5') != -1) ? 'Microsoft.XMLHTTP' : 'Msxml2.XMLHTTP';try {new ActiveXObject(control);} catch (e) {top.location = '/gmail/html/noactivex.html';}}</script><frameset rows='100%,*' border=0><frame name=main src=/gmail/html/loading.html frameborder=0 noresize scrolling=no><frame name=js src=/gmail?view=page&name=js&ver=e148456b67e168d9 frameborder=0 noresize></frameset>

With the relevent part being: {top.location = '/gmail/html/noactivex.html';}

Let me re-install IE and see if that gets back the ActiveX extension. If it does I will post it..

Oh, and javascript is enabled. I think that is my pop-up blocker at work.
 
King Bob On The Cob Aug 2, 2004 01:05 AM
Enable JavaScript...
 
All times are GMT -4. The time now is 05:38 AM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2015, vBulletin Solutions, Inc.


Content Relevant URLs by vBSEO 3.3.2