MacNN Forums (http://forums.macnn.com/)
-   Classic Macs and Mac OS (http://forums.macnn.com/classic-macs-and-mac-os/)
-   -   OS 9.2 and Linksys Router/DHCP (http://forums.macnn.com/64/classic-macs-and-mac-os/225633/os-9-2-linksys-router-dhcp/)

 
MichaelTalis Aug 25, 2004 12:12 AM
OS 9.2 and Linksys Router/DHCP
I have a Powerbook G3 running OS 9.2, and I'm trying to get it to work with my Linksys router. (The router is connected to the greater world via Verizon DSL.) The router acts as a DHCP server and works just fine with my Windows XP machine. But for some reason I cannot get my Powerbook to gain an IP from the router. I have the Mac's TCP/IP settings set to DHCP, but it doesn't connect to the Internet and just returns an IP of 169.254.xx.xx and the wrong subnet, etc. (I realize that 169.254.xx.xx is a fallback IP for Macs, so that this really means nothing.) I've reinstalled the operating system -- no luck. I've trashed Open Transport and TCP/IP preferences -- no luck. I've tried to just arbitrarily establish manual TCP/IP settings for the mac, such as IP of 192.168.1.104 -- no luck. And I'd be more than happy to change any settings on my Linksys router, but I can't figure out what would help the Mac.

I've read a lot of these forums around the Internet, and people seem to have had a number of problems with DHCP in OS 9.2, but most of the problems stem from the Mac communicating directly with the Cable/DSL modem OR how to drop an IP and gain a new one. No one seems to have had this problem, which surprises me and makes me wonder what I'm doing wrong. I thought DHCP was supposed to be easy! If anybody has any ideas, PLEASE let me know. I'd really appreciate it. Thanks. :brick:
 
fiesta cat Aug 25, 2004 01:24 PM
Re: OS 9.2 and Linksys Router/DHCP
DNS Settings? A long time ago I had to plug in the DNS settings my cable modem was pulling from the ISP in a Mac. My last router, I didn't have to do anything on my end to get it to work.
 
deboerjo Aug 28, 2004 11:22 AM
Are you sure the Ethernet cable you're using is the correct type and isn't bad? It almost sounds like the Mac isn't seeing the router at all, 'cause I've never heard of any kind of problem like you're having. DHCP usually is plug'n'play.
 
All times are GMT -4. The time now is 05:41 PM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.


Content Relevant URLs by vBSEO 3.3.2