MacNN Forums (http://forums.macnn.com/)
-   Classic Macs and Mac OS (http://forums.macnn.com/classic-macs-and-mac-os/)
-   -   USB Zip Tools not working with OS 9 (http://forums.macnn.com/64/classic-macs-and-mac-os/43869/usb-zip-tools-not-working-os/)

 
thndrdan88 Dec 3, 1999 10:51 AM
USB Zip Tools not working with OS 9
Has anyone else upgraded to Mac OS 9 and then noticed that the tools for the USB Zip drive no longer work. A friend of mine here at work said he upgraded and then couldn't use the Zip Tools. I decided to try it at home myself and it wouldn't work for me either. It says that it can't find a Zip drive connected to the computer. Now he and I can mount Zip disks but we can't use the tools to format or passcode the disks. We tried to call Iomega but they we're as suprised as we were that it didn't work with OS 9.

Can anyone else verify this for us or is it just happening to myself and my friend. Is there any updates that anyone knows about that will fix this.

Any help would be appreciated.

Scott <aka Thunder Dan>
 
fleshhorn Dec 3, 1999 03:39 PM
Check their site, and/or Versiontracker, not long ago they came out with new tools/drivers.
 
newsmac Dec 9, 1999 06:34 PM
I've got tools v 6.2.3 & OS9, works great, (although my zip is built-in) Just used it the other day to reformat a bunch of pee cee disks i found on clearance sale. no problems . but would recommend bumping up memory slightly to make it run faster. New drivers were released about a month ago. Good luck
 
Parrish Dec 11, 1999 06:53 PM
newsmac:

I can't find the update you're talking about. The version of the tools software that OS9 installed in my utilites folder is 6.2.3, and it doesn't work. I downloaded Iomegaware 2.1, installed it, and it doesn't work. Would you offer more details, please?

P--
 
tke918 Dec 13, 1999 04:24 AM
Parrish,

I think, newsmac is talking about his internal zip drive, not USB zip drive.

I believe that there is no zip tools software for (at least my system) iMac DV, MacOS9, and a USB zip drive YET!
 
Norman Dec 13, 1999 11:13 AM
Unfortunately I have the same problem: iMac Rev B, 233 MHz. I installed the international English edition of Mac OS 9 over the US edition of OS 8.6. I tried the remedies suggested by you and others in this forum, to no avail. Additionally, I have found that as of late the system freezes upon starting, before getting to the splash screen, and it seems to be prevented by disconnecting the Zip Drive before turning on the computer.
 
zac4mac Dec 17, 1999 10:08 AM
sounds similar to the problem I'm having with my girlfriend's iMac 333. I have an 8500 and 7500(both SCSI) with zips and a jaz on OS9 and no problems. on her iMac tho, i have an adaptec SCSI-->USB converter and 2 things: it doesn't provide term power, so i have to have a scanner connected for the iMac to see it. Mounting is sporadic and the system will not boot if the zip is on...not too impressed with USB so far.
 
vidimac Dec 24, 1999 08:59 AM
Thndrdan88,
Have you solved your problems with the usb zip yet? I'm interested in purchasing the iomega zip250 drive and installing os9 on my imac dv.
Have you download the latest usb drivers that apple posted this week ? Have you downloaded the latest drivers from iomega? Let me know if your usb zip problems are resolved and how you did ita
 
dbogdan Dec 24, 1999 09:05 PM
I thought I had the same problem as you when I installed OS9 on Dec 3, 1999. It was a clean install, but upon bootup, the Iomega Zip Drive icon would appear with the dreaded X through it (not the X of Mac OSX fame, mind you, but the dreaded "it's not loaded" X of all previous OS fame... LOL).

Well, here's what I did to alleviate/solve the problem...

Using Apple's Extension Manager (or Conflict Catcher if you use it - CC *should be confirmed* as OS9-compliant before you go with me on this one...). Uncheck - yes! I said "uncheck" the Iomega Zip Drive Extension that has the familiar "I" logo with it. Apple OS9 installs a set of "generic" or "universal" USB Zip drivers upon installation and they recognize the Zip/Jaz/Clik drive(s) just fine. They're to be found a bit later in the listing under the "USB drivers" listings. There are several of them, for 100 Zip, 250 Zip, and Clik drivers. Keep all of them checked and you should do just fine...

At first, I, too, could mount the drives, but couldn't do anything with them using Iomega's Zip Tools. That is, until I re-installed the ZipTools Software over OS9 from the original Iomega CD. Now I can do everything with them that I always have... Password protect, do drive-copy, reformat, etc.

I, too, thought I was screwed in the OS9 migration path, but was delighted to find that the software path wasn't as rough as I first thought. By the way, the version of software I use for my Iomega Tools is from the Iomega CD that came with my USB drive (Iomegaware version 2.1). Although I can't 'splain it exactly, it seems that re-installing the software after I installed OS9 solved my problem. :-)

I hope my anecdotal input has helped you or anyone else out there. I'm running on an original revA iMac with 96MG RAM.

iMac rules!! Long live the iMac!!!



------------------
 
Gregory Jan 4, 2000 03:14 PM
Internal ATAPI 250 Zip, BW/G3, Iomega driver 6.0.6 part of OS 9, Tools 6.3.1.

The rest of the Iomega software is not OS 9 and is a crap shoot, with Apple and Iomega trying to solve USB problems mainly for iMacs - tons of messages on Iomega web forum for Mac products.

They claim zero support for the 250 ATAPI (Iomega) which kind of burns me, works fine anyway. (100MB Zip cartridges are slow as molasses and 250's are acceptable if not 20MB/sec).

------------------
Gregory Youngs
gregorya@kdsi.net
 
gMan Jan 12, 2000 05:25 AM
This is absolutely rediculous. I'm having very serious problems because I'm unable to reformat ZIP disks into PC format (something which the ZIP Tools program can do). There's no way I'm going back to OS 8.6 (but I've sure thought about it!). Why can't Iomega get their damn act together and release a version of their software that works with OS 9, just like all the other companies have. I'd expect better from them.
 
mkrad Jan 12, 2000 12:04 PM
Does anyone know if Ioware update 2.1.1 solves the Tools-OS9 incompatibility problems? The driver is the only thing I have installed (with extensions OFF)from this download and it seems to have taken care of the iMac shutdown/restart problem I was having before - but I would like to use Tools for formatting, etc. Just a little gunshy after my dismal experience with the old version.
 
gMan Jan 13, 2000 06:15 AM
There's a 2.1.1 update? The latest version on the site is 2.1. Where is it available from?
 
joeaux Jan 13, 2000 04:01 PM
You know, I've posted this about 1000 times and it seems that no one is listening. Here goes. DO NOT USE THE IOMEGA SOFTWARE!! PERIOD. You don't need it to use your USB Zip drive. PERIOD. The only thing it does is screw up your OS and give you that silly little 'zip' icon for the disks. Big deal. Now comes the "but I can't format PC disks". Or "but I can't format a zip disk to Mac if it's a PC format". Bull. Think! You can format PC if you have "File Exchange" Control Panel on. This will allow you to format PC zips. To format PC zips to Mac zips just disable the "File Exchange" CP. Then reboot. Stick the disk in. MacOS won't know what it is 'cause File Exchange is turned off. After you format, turn it back on. I do this at least 5 or six times a day. I KNOW that it works. Again, you don't need the Iomega software. It is 100% unnecessary!
-joe-


------------------
iMac (Lime 266 OS 9), iBook (Tangerine 300 OS 9), SE/30 (Platinum 16 OS 7.5.5)
 
gMan Jan 19, 2000 02:44 AM
joeaux: well explain to me, then, what the hell I'm doing wrong.

as far as i can tell, the Iomega software is off. There are no iomega drivers present in the system folder.

When I mount a zip disk, though, it still appears with it's Zip icon, and when you select "Erase Disk" it will only let you select Mac OS Standard or Extended.
 
joeaux Jan 20, 2000 03:58 PM
I'm gonna have to eat humble pie here. I found a flaw in my logic. I do this all the time. But one thing that I don't do is to format Mac disks to PC format if they are ALREADY in Mac format. OS9/File Exchange makes the assumption that if it's already in Mac format that's what you want. I can format PC->Mac, Mac->Mac, but NOT Mac->PC. I've spent the last hour or so trying to figure out a way to do this. I can't. I have to use my PC to format to DOS then use it in the Mac. Then the mac will let me format it as DOS. This is the only way. I still stand by my original comment about Iomega Tools. They suck. They are unstable. They screw up your OS. My recommendation now is to format the zips that you want as DOS on a DOS machine. Then use them on your Mac. Again, humble pie doesn't taste too good!
-joe-


------------------
iMac (Lime 266 OS 9), iBook (Tangerine 300 OS 9), SE/30 (Platinum 16 OS 7.5.5)
 
joeaux Jan 20, 2000 06:28 PM
Alright! It looks like I don't have to eat humble pie after all. I KNEW I was doing this somehow. After screwing around with this for hours, it looks like it's something very simple. I'm still not 100% sure but here's what I THINK is going on. If the zip disk that you put in the drive was last formatted using the Iomega tools, you cannot format it in DOS format using standard MacOS! These Iomega formatted zip disks have a reported size of 95.7 Megabytes (when you go to format them). The ones that are formatted with MacOS have a reported size of 96 Megabytes (either Standard or Extended). If the disk size is reported as 96 Megabytes you will find that THERE IS ANOTHER DISK TYPE selectable in the format popup. And guess what it is. "DOS 96 Meg"!! As far as I can tell all you have to do is format them as standard MacOS disks. Then format them again. It should work. I'll keep at it and post again later with more info. I knew I was doing this WITHOUT the Iomega garbage or a PC.
-joe-


------------------
iMac (Lime 266 OS 9), iBook (Tangerine 300 OS 9), SE/30 (Platinum 16 OS 7.5.5)
 
joeaux Jan 20, 2000 06:49 PM
Ok. Here goes. To format a disk as type DOS, first eject all zip disks. Now turn off the "File Exchange" control panel (more on this later). Next put the zip disk you want to format as DOS in the zip drive. Format it as "Mac OS Standard 96 MB". Next eject the disk. Now turn on the "File Exchange" control panel. Next put the zip disk you just formatted as type Mac OS in the drive. Now when you go to format it you'll see a third type of disk, "DOS 96 MB". It's the size that's screwing up the MacOS and it's ability to format a zip as DOS. If it's a zip disk and it's not 96 Megabytes, it won't format as DOS. Go figure. I wrote two small AppleScripts to turn "File Exchange" on and off. Just paste the following two scripts into the Script Editor and save the first one as "File Exchange On" and the second one as "File Exchange Off". That way you don't have to restart the Mac to turn the Control Panel on and off! Works like a charm for me. Make sure to save them as "compiled scripts".

tell application "File Exchange"
set PC file system enabled to true
quit
end tell


tell application "File Exchange"
set PC file system enabled to false
quit
end tell

Whew! Lotta work but I think I got it right now. Let me know how it goes!
-joe-


------------------
iMac (Lime 266 OS 9), iBook (Tangerine 300 OS 9), SE/30 (Platinum 16 OS 7.5.5)
 
JGuidroz Jan 22, 2000 09:06 PM
I don't understand why people would want to format PC zip disks to mac format. Macs can read both PC zips and mac zips. So what's the problem with using a PC zip with a mac? That's what I do. I bought an interanl zip drive, and I have no problems whatsoever with iomega tools.
 
Thumannator Jan 23, 2000 02:23 AM
Okay, everyone go easy on me. I've read through this entire discussion and have tried many of the solutions listed here, but am unconvinced that the problem is solved.

I too have had some problems with my USB Zip 250 drive and my Rev. B 233 iMac running under OS 9. I seemed to have cleared up the problem, but am still a little uncertain. For about the last week or two, when I would start up my Mac, more often than not, the system would freeze just before loading the control strip to the desktop. I tried several trouble-shooting options. At first, it seemed that unplugging the drive before starting up helped. However, I had a similar system freeze when awakening the computer from sleep mode (at this point I had plugged the drive back in). In fact, a few times, after waking up, the control strip disappeared?!?

Eventually, I reinstalled the Iomega software, but disabled the Iomega Driver. Disks will mount, and I am able to use the Iomega tools! Eerie! Not quite sure how this is working. Maybe someone can explain it to me. Still, I was getting a system freeze on start-up about 50% of the time.

Now something new I tried today had to do with the "Apple Audio Extension." I'd heard it was causing others grief and I determined that I don't need it as it is intended for USB sound devices, of which I have none (if I've misunderstood the purpose of this extension, and need it, someone please tell me so). I turned that extension off, and so far I have had no more system freezes...

...So far! I'm not convinced I've solved the problem, so I'm seeking advice from others.

Thanks for any help,
"The Thumannator"
 
gMan Jan 24, 2000 06:18 AM
I'm also not convinced that this problem is solved. I tried the thing with the reformatting, but even with file exchange off I am unable to format a disk as "Mac OS Standard 96 MB" it will only allow "Mac OS Standard 95.7 MB".

What I am annoyed about is that Iomega seem to be taking no interest in this problem at all. It's not as if it's only happening to one person. I emailed them and they simply instructed me to download the 2.1 update, which I have done. It dosen't help at all.

I intend to follow this up with them...
http://forums.macnn.com/cgi-bin/frown.gif
 
rleatherwood Jan 24, 2000 07:20 PM
It seems that some of you are confusing the Iomega Driver Extension with needing it for USB version of the zip drive. This is false. The Iomega driver extension is required for SCSI and IDE drives only. The current version of Iomegaware is 2.1.1 and can be found on www.versiontracker.com. According to Iomega, disable you extensions before installing the software. Also, I suggest the people with the USB zip disk, install ONLY the USB software (do a custom install, select Iomega Tools, USB drivers).
 
joeaux Jan 26, 2000 10:21 AM
I'm sorry that you're having problems. I just don't understand. I don't use the Iomega junk at all and I format both PC and Mac format. I don't have any experience with the Zip250 though, I have a USB 100. As far as Iomega caring, well, remember the COD problem. They didn't 'care' until they were forced to. And that took forever.
-joe-


------------------
iMac (Lime 266 OS 9), iBook (Tangerine 300 OS 9), SE/30 (Platinum 16 OS 7.5.5)
 
gMan Jan 29, 2000 04:36 AM
Well, well, well!

I downloaded the 2.1.1 update, and what do you know? The problem has gone away.

The update installs a new version of the USB Iomega drivers in the Extensions folder. It seems that earlier versions are incompatible with OS 9.
When an earlier version of the driver was installed, OS 9's built in USB Mass Storage Driver took over instead. This allowed you to mount disks, but Tools couldn't find the drive because it wasn't using Iomega's drivers.

This update dosen't appear on Iomega's site, nor do I see any reference to it in the support area. I wish they'd get their act together.
 
chagelst Nov 14, 2002 06:21 AM
Quote
Originally posted by dbogdan:
At first, I, too, could mount the drives, but couldn't do anything with them using Iomega's Zip Tools. That is, until I re-installed the ZipTools Software over OS9 from the original Iomega CD. Now I can do everything with them that I always have... Password protect, do drive-copy, reformat, etc.

------------------
This was a great post and it really helps me out. Did you first uninstall the ZipTools softwarew, then reinstall over OS9 from the original Iomega CD? Or did you just simply reinstall over the ZipTools you have on your system already? THanks for the feedback....
 
ThinkInsane Nov 14, 2002 07:08 PM
Holy old threads Bat Man! I was a little confussed as to why every responder was listed as a guest, even though they are all members. Them I noticed the last post was almost three years old.

So, chaglest, getting an answer to your inquiries from dbogdan may not be so easy, as he/she probably has no recollection of this thread at all.
 
All times are GMT -4. The time now is 11:01 AM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.


Content Relevant URLs by vBSEO 3.3.2