MacNN Forums (http://forums.macnn.com/)
-   Classic Macs and Mac OS (http://forums.macnn.com/classic-macs-and-mac-os/)
-   -   OS 9 won't shut down/restart... sometimes (http://forums.macnn.com/64/classic-macs-and-mac-os/44021/os-9-wont-shut-down-restart/)

 
birdman Sep 14, 2000 05:50 PM
OS 9 won't shut down/restart... sometimes
I have an iMac DV (the 1999 version) with OS 9.0.4, and it still won't shut down or restart sometimes. It's not just after a crash, or after running a certain program; I can't notice any pattern to it. I'll go to Special: Shut Down, and it will just sit there, doing nothing. The seconds keep ticking away on the menubar clock. I go to Special: Shut Down again, and it says "The command could not be completed, because you have already selected Restart or Shut Down. Please wait for your computer to finish Restarting or Shutting Down."

Funny -- if it were actually restarting or shutting down, it shouldn't LET me do anything! Including selecting Shut Down from the Special menu again! The system is still fully active; I can run programs and do whatever, I just can't shut down or restart. Several times I just let it stay on all night, since the kind message assured me that the computer would eventually shut down. Guess what, eight hours later it still hadn't done it.

Oh, I should mention that this has been happening since I got the iMac out of the box. This is nothing new to me. I just hate having to do a hard restart (pressing the button on the side of the iMac) every time it does this. I have to cross my fingers every time I want to restart or shut down, HOPING that it will DO WHAT IT'S PROGRAMMED TO DO!!!


On a slightly related note, I heard that the first multiprocessor G4's were delayed because they would crash instead of waking up from sleep. Funny, my iMac has been doing that since I got it, yet Apple didn't recall mine. It appears, however, that OS 9.0.4 has corrected this for me.

-birdman
 
wlonh Sep 15, 2000 02:00 AM
what have you done to attempt a fix of this issue? i am asking because i am kinda methodical and would like to know what you have done so far...

but humor me, try zapping the NVRAM... this is different from zapping the PRAM in that you must zap NVRAM by using the option, command, P, and R key combo from a powered down condition (coldstart) as opposed to a PRAM zap which is done with the same key combo but from a restart (warmstart)... so zap NVRAM by holding down those keys as you startup from a powered down condition and hold them down until you hear three consecutive 'startup chimes' then let up on the keys and let the Mac startup, you will then need to reset a few control panels like you would when zapping the PRAM

no big deal.

(and have you tried searching the fora using some likely keywords?)
 
WDL Sep 15, 2000 07:46 AM
This has worked for others:

1. While shut down - unplug ALL USB devices, including the keyboard/mouse. Startup by the button - after startup is completed, plug in the keyboard/mouse - then try a few shut downs and startups (not restarts) to see if it's working.

2. Continue shutting down, then adding one more USB device at a time, to isolate any culprits.

USB conflicts are causing bizarre problems that often don't appear to be USB related at first glance.

Let us know what happens.

WDL
 
birdman Sep 15, 2000 09:41 AM
wlonh -- I haven't tried anything yet, because I'd never seen a problem like this before. What exactly will zaaping the NVRAM do?

I can try either solution suggested here, the only thing is that since this doesn't happen ALL the time, I won't really know if it's fixed until it happens/doesn't happen again! But I can try these two things and see what happens.

Thanks,
birdman
 
All times are GMT -4. The time now is 01:49 AM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2016, vBulletin Solutions, Inc.


Content Relevant URLs by vBSEO 3.3.2