MacNN Forums (
-   Classic Macs and Mac OS (
-   -   mac startup problem... (

fourstarcltv Sep 16, 2000 03:15 AM
mac startup problem...
evening all,

i am having some trouble with the startup of my g3/233 (os 9.0, 96megs ram, 20 gig ata hdd) and it has got me stumped.

i have my drive partitioned into three parts, one partiton of which holds the systems software and utilities. i have to use my external cdrw drive for cd access as my internal cd drive is no longer working, and every time i start up my machine it simply wont boot and will sit at a blank screen, however if i boot the computer with my os 9 cd in the cdrw drive, the drive will read the disc and then the startup (from the hdd) will proceed perfectly.

this really has got me stumped so any help will be greatly apprecited !!

Cipher13 Sep 16, 2000 03:26 AM
First of all, update to OS 9.04 if at all possible.
You don't have USB so we can't blame it on that either... unless you have it through a PCI card...
So, if you boot with the CD in the drive, but not OFF the CD it loads fine?
Those symptoms sound really familiar, but I can't put my finger on it...
Have you got the system volume selected in the Startup Disk control panel as the startup disk?
And what do you mean by blank screen? Black, or the grey screen?
Have you scanned the HD for damage?
If I interpreted what you said correctly, you can start up off the HD only when the OS 9 disc is in... can you eject it once you've started up?
This is quite strange... should be fun figuring out the prob (not for you I'm sure...).

fourstarcltv Sep 16, 2000 03:37 AM
i'm downloading the 9.0.4 update now...

- i've run 'disk first aid' and verified/repaired all three partitions
- yes, i have the disk with the system on it selected in the startup control panel
- the screen is just black, with the power light 'orange' (as opposed to green when it is on)
- and yes, i can start off the hd only when the os 9 disc is in. and i can eject it once the startup is complete.

i'll let you know how i go with 9.0.4... thanks for your help

Cipher13 Sep 16, 2000 04:45 AM
Can you eject the disc during startup?
Thats is a very strange problem indeed...
I've got a feeling it could be to do with the IDE chain - your HD is on the same chain as a malfunctioning CD drive, no?
Take the CD drive off the chain. Stick in another HD if at all possible. Just temporarily. Or better yet, a working CD drive...
I don't think it could be a malfunctioning keyboard only letting you boot when the CD drive is in...
What happens when you hit power?
Does the computer chime?
Ah, ok, idea!
What about the monitor? Can you hear the HD being read when starting up?
What if the software to use the monitor is present on the OS 9 CD, but not the HD...
What kinda monitor is it?
Can you hear the OS 9 CD being read during startup?
Can you startup with any other CD in the drive (if so, that rules out a ROM virus - although I don't know whether the computer I am assuming you have has a flash ROM, and I don't know of any ROM virii that exist for a Mac)...
What comp are you running?
I've been assuming beige G3... Tower or Desktop? (Just so I can visualise the problem).
Or is it an upgrade?
Virtual memory on?
So, try starting up from another CD, one without a system, and one with one (but not OS 9), and the CD with the software for your monitor.
A lot of this may seem unethical and strange to other users reading this, but y'all bare with me, k?

fourstarcltv Sep 16, 2000 06:44 AM
ok, i've tried out a number of your suggestions and here are the results:

- i've updated to 9.0.4, still the same problem
- i think you may be on the money in relation to the problem being with the ide chain because even if there is no cd in the drive, holding 'c' while starting up, it will boot from the hard drive, however if i dont hold down 'c', it sits at the black screen with no hdd activity.
- i tried taking the internal cd drive off the chain, still the same problem. however, the internal cd drive now works (my g3/233 rev. a doesn't support slave drives unfortunately)
- the monitor is a graphite applevision 17
- my mac is a beige desktop g3/233
- virtual memory is on

sounds like some sort of ide chain problem??

again, thanks for your help !!

TheSkeptic Sep 16, 2000 12:25 PM
If the external CD drive is SCSI make sure that its id is NOT 0 or 7. Those IDs are reserved for the system and the computer will not work properly if those ID's are used.

fourstarcltv Sep 16, 2000 04:06 PM
i've just booted with the scsi cdrw connected and scsiprobe 5.2 shows that the external cdrw is using id 4 and the startup disk is id 7.

a screenshot of the scsiprobe window is available here;

we're getting there your help is greatly appreciated !!


fourstarcltv Sep 16, 2000 07:20 PM
just something futher which i noticed while experimenting with setups this morning, i have disconnected the internal cd drive and replaced it with another 4gig hdd, i disconnected the external cdrw drive also and restarted....

same problem, dark screen and the mac doesn't start up, however if i boot with the 'c' key help down it boots fine, even though there is no cd drive connected at all???

is the mac thinking the hdd is a cd drive?


Cipher13 Sep 16, 2000 07:35 PM
I think you're on the money there - switch around the physical position on the chain of the 2 devices and see how it goes.
Also muck around with master/slave/single modes.
Take all other devices out and set the 20 gig on SINGLE mode.
The 20 gig is set as master isn't it?
Before doing that, you may want to back up anything important...
Oh yeah, and install the system on that 4 gig drive. See whether if there is a valid system on both it will still boot - try these 3 things, after putting a system on the 4 gigger:

1. Boot with the 20 gig selected in the startup disk cdev
2. Boot with the 4 gig selected in the startup disk cdev
3. Boot with NO drives selected in the startup disk cdev. Then, when it eventually boots, see which drive it chose...


[This message has been edited by Cipher13 (edited 09-16-2000).]
fourstarcltv Sep 16, 2000 07:42 PM
i have connected the 4gig hdd to the computer by taking the connections from the back of the internal cd and connecting them to the 4gig hdd.

maybe if i install os 9 onto the 4gig drive it will run off that?

Cipher13 Sep 16, 2000 07:42 PM
my g3/233 rev. a doesn't support slave drives unfortunately

I'm thinking maybe your IDE controller is stuffed...


[This message has been edited by Cipher13 (edited 09-16-2000).]
Cipher13 Sep 16, 2000 07:44 PM
Originally posted by fourstarcltv:
i have connected the 4gig hdd to the computer by taking the connections from the back of the internal cd and connecting them to the 4gig hdd.

maybe if i install os 9 onto the 4gig drive it will run off that?

Yeah, thats what I meant to do. Sorry for not being clear.
Also, try swapping the positions of the two drives - unplug both, and put them in each others places, then try. Before you put a system on the 4 gig.

Re. the above suggestions, make sure you bless the System Folder on the 4 gig drive.


[This message has been edited by Cipher13 (edited 09-16-2000).]
fourstarcltv Sep 16, 2000 10:45 PM
well, the problem has been solved, i zapped the PRAM and updated the hdd drivers and it now boots without any problems

a huge thanks to cipher13 and reader50 for all their help !!

anne arkee Sep 18, 2000 04:38 PM
similar issue, with a g4/350sawtooth. os 9.0.4 128Mram 2 10GB harddisks, 1 4GB harddisk. system pauses at startup after first (IDE/ata) drive mounts, for about 10-15 seconds, then mounts other drives. no aliases in servers folder...can't find TIL's related. starting up extensions off, there is no delay. with other experiences noted here, it must be netowrk issue. but with 9.0.4, isn't this the latest rev of OT? and the
anne arkee Sep 18, 2000 04:43 PM
sorry i believ i was a bit off topic, couldn't remember where i saw certain posts... pls excuse
anne arkee Sep 18, 2000 07:19 PM
figured it out, deactivate the OpenTPTSNMPlib and SLPplugin extensions!
All times are GMT -4. The time now is 03:20 AM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

Content Relevant URLs by vBSEO 3.3.2