MacNN Forums (http://forums.macnn.com/)
-   Classic Macs and Mac OS (http://forums.macnn.com/classic-macs-and-mac-os/)
-   -   File won't "trash" (http://forums.macnn.com/64/classic-macs-and-mac-os/44387/file-wont-trash/)

 
singpro Mar 13, 2000 12:00 AM
File won't "trash"
I have a file on my iMac (OS 8.6) that won't go away when trashed. I get an error -127, and won't throw it away. Norton says the file has numerous B-tree and catalog problems. Tech Tool says it's fine.

When I go to Norton Disk editor and inspect the file, it's not locked. But I also cannot edit *any* file on the hard drive. Not that one, not any of them. The file has a data fork and resource fork size of something over 2k; but when I try to trash it, I'm told it's something like 3.9 meg.

How do I throw this thing (it's a corrupted AOL Instant Messenger installer) away? The disk (a 6 gig HFS+) is fine, according to current versions of Norton & TechTool. I've never had anything like this in over 10 years of Mac use.
 
cteselle Mar 13, 2000 12:20 AM
One thing that I have tried before, not necessarily with your problem, was to create an empty file, name it exactly like the file in questions, and then throw into the folder that contains your original file.

You should then be able to delete the file you just copied over...

no guarantees though, and your mileage may vary...

good luck!

------------------
Promote Chicken Randomness
 
lycaon Mar 13, 2000 07:08 AM
You might want to check out this thread at MacFixIt regarding Tech Tool's TrashCache: http://www.macfixit.com/ultimate/For...ML/000345.html
 
Art D Mar 13, 2000 05:20 PM
singpro,

It sounds to me like the directory (specifically the Catalog or Extents file) on your hard disk has been damaged. You mentioned "TechTool". I assume you have "TechTool Pro".

If so, use TechTool Pro to completely "rebuild" the directory. You'll need the newest version (2.5.3) and you can't perform that function on the startup drive. You'll have to start from another drive or from your TechTool Pro CD.

If you're unfamiliar with how to do this, here's how:
1) Launch TechTool Pro
2) Under the "Interface" menu, choose "Expert".
3) In the choice of panels, to the left, choose "Vol. Structures".
4) Select your hard drive and click on the "Rebuild Volume" button.
5) Click the "Run" button.
6) Allow TTP to rebuild and replace the directory.

Hope this helps,

Art

[This message has been edited by Art D (edited 03-13-2000).]
 
singpro Mar 13, 2000 06:50 PM
Art D:

I do have TechTool Pro 2.5.3; but it's via an update to a 2.0.1 CD. I'll create a startup Zip and try your suggestion.

BTW, I did try the suggestion to try copying a file with the same name into the same folder. Didn't work; but that is a cool way to fool the system, if possible.

I'll update here when I get a minute to try this.
 
madra Mar 22, 2000 08:08 AM
try the utility 'file buddy'. you can view the contents of any disk including all invisible [eg. desktop] files. then just 'delete' the desktop 'trash folder'. in effect throwing the bin into the bin. surreal! but it works!
 
Simon Kornblith Mar 22, 2000 04:04 PM
You can try stuffing it with DropStuff with Delete Originals After Stuffing ON. I know this sounds strange, but it works msot of the time. You can then delete the stuffed file.

------------------
Simon Kornblith
Computer Consultant
Programmer
 
AusRob Mar 23, 2000 01:35 AM
Have you tried just holding down the option key when selecting "Empty Trash" from the menu. It deletes everything in the trash without a warning message.
 
singpro Mar 23, 2000 01:44 AM
I have tried using the option key while "trashing" the file, and it doesn't work. I've also tried using Tech Tool Pro to rebuild the directory as Art suggested, and that didn't work.

Tech Tool and Norton say the drive is fine (media scan), both say the B-tree is messed, then after running the utilities, both say they have fixed the problems... until I run them a second time. Then they say I still have a problem, and the pesky file still won't trash.
 
wlonh Mar 23, 2000 05:15 AM
ok, now i am starting to think virus. seems there's been some users having virus trouble lately http://forums.macnn.com/cgi-bin/frown.gif

have you scanned your HD with an antiviral utility?

 
singpro Mar 23, 2000 09:38 AM
I scanned the machine with Norton AntiVirus v.5.0 (I haven't updated it since last August though). The scan was performed by starting up from the AntiVirus CD. It checked clean.

Where's a good Mac virus info board? I'll check that too.

 
wlonh Mar 23, 2000 09:57 AM
NAV 5.0 most recent virus definitions update file:
HERE

info on virii, etc:
HERE
 
Jeep2000 Mar 23, 2000 10:04 AM
Have you tried starting up from CD and emptying the trash while using another startup disk? I have had that work with a stubborn file before.
 
Art D Mar 23, 2000 01:53 PM
Hi again singpro,

Well, for what it's worth, I still think there's damage to the directory. Disk repair utilities are not always able to fix this sort of thing. The utility that is supposed to be the best is Alsoft's "DiskWarrior" ( www.alsoft.com ), but I've never used it so I can't speak from experience.

I hate to say it but you might end up having to reformat the hard disk. Apple has a TIL article (#8198) related to untrashable files that implies this possibility. It can be found at:
http://til.info.apple.com/techinfo.nsf/artnum/n8198

Best of luck with this annoying problem,

Art
 
Feathers Mar 25, 2000 03:21 PM
Stupid Question but I assume file sharing is off and it's not a shared file or volume?
 
yanokwa Mar 27, 2000 05:25 PM
diskwarrior(www.alsoft.com) works 10x better than norton and tech tool combined. try that one first. i would also try the starting up from cd...
 
singpro Mar 27, 2000 08:57 PM
Good suggestions. In answer to some of them; no, file sharing is not on. Yes, I did try trashing after starting up from a CD. I don't have Disk Warrior, and haven't needed it... well, maybe until now.

I'll try the Anti-Virus download, and check the Virus URL suggested above. Reformatting does sound like a possibility. I'll also check the TIL article.
 
Cipher13 Apr 1, 2000 02:38 AM
A -127 error is an error with the Systems file structure - surprisingly, the best thing I can think to do is leave the file alone. As it is, the file is in a corrupted area. If you delete it, there is no guarantee that the corruption will go away. Leave the file alone, and it will sit on the corrupted area, not allowing any other file to be put in the corrupted area. Its your best bet, other than formatting your HD.
The file should not do any damage...
Hope that helps...
 
Gabriel9 Apr 3, 2000 05:30 AM
I didn't successed in deleting several files on different Macs under French OS 8.6 and 9 : one couldn't be unlocked, another was an empty folder without name and other files were normal. I also got error -127 a couple times. And I found no virii on the comps.
I used Dropstuff (with "deleting the original") to stuff the undeletable items and it was a complete success each time.
 
singpro Apr 6, 2000 09:59 AM
And the winner of the "Trash the Untrashable File" Derby is...
Disk Warrior!! I bought the CD, booted from the CD and ran the utilty, and it rocked. The file is gone, and everything seems fine. Even Norton says the drive is in good shape and error free.

Moral: Norton Utilities is good; TechTool Pro is really good, but Disk Warrior won this one.

Thanks for all the really good suggestions. I'm sure they'll come in handy in the future. http://forums.macnn.com/cgi-bin/smile.gif
 
exa Apr 9, 2000 02:53 PM
for your information, Norton Disk editor can't open any files on an hfs+ volume (only hfs)... it is not included on their latest version which has hfs+ support for disk doctor...
 
PatrickF Apr 20, 2000 08:41 AM
Exa, you're wrong. NDE is not installed on the disk by default but it exists on the Norton CD.
http://www.macfixit.com/ultimate/For...ML/000001.html
Quote
There are two editors now, one for HFS and one for HFS+. They can be found on the Norton CD in this path: Norton Utilities Folder:Norton Tools:Tech Support Tools.
http://www.macfixit.com/ultimate/For...ML/000039.html
Quote
NDE Lite is no longer Lite with 5.0. It's not NDE +, and it's HFS + compatible. So far, it looks good under OS 9.

 
All times are GMT -4. The time now is 11:24 PM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2015, vBulletin Solutions, Inc.


Content Relevant URLs by vBSEO 3.3.2