MacNN Forums (http://forums.macnn.com/)
-   Classic Macs and Mac OS (http://forums.macnn.com/classic-macs-and-mac-os/)
-   -   Chooser (http://forums.macnn.com/64/classic-macs-and-mac-os/44407/chooser/)

 
Barney Mar 9, 2000 02:47 AM
Chooser
posted 03-09-2000 01:49 AM            
------------------------------------------------------------------------
iMac Rev. A (all necessary updates)
96 Meg Ram
Mac OS 8.6
Internet Explorer 4.5
Outlook Express 5
Epson Printer 740
For some reason I can't select a printer port in my chooser. I only have the 740 in the chooser. Everything is connected properly. I know the printer is operating properly because I ran tests on it unconnected to the computer. Then I did the following:

1) I trashed every preference that I felt was remotely connected to my problem. e.g. Epson prefs; printer prefs; finder prefs; and appletalk prefs (which I never use anyway). That effected no change.

2) Rebuilt the desktop and zapped the pram. No effect.

3) Used Disk First Aid, Tech Tool 1.1.9, and Tech Tool Deluxe from AppleCare. Everything checked out O.K. Any ideas, anyone?
 
wlonh Mar 9, 2000 03:11 AM
turn off AppleTalk, and/or reassign its port

and maybe switch background printing on/off
 
Barney Mar 9, 2000 04:04 AM
Thanks, wlonh, but I had done all that. That was part of all the other things I did.
 
Adam Silver Mar 9, 2000 04:18 AM
Try removing all Epson Print Class files and restarting.
 
Barney Mar 9, 2000 06:16 AM
Adam! THAT WORKED! Can you explain why? My forehead is humbly touching cyberground before you. Thank you, thank you. What I did at first is what you recommended. I removed the Epson Print Class Extensions, restarted and tested it, and I had my printer port selected and I printed. Then I reinserted them and again no printer port. This time instead of removing them I disabled them. Worked fine again. Do you think I should actually trash them? Or is it ok to just leave them disabled? Thanks, again. Barney

[This message has been edited by Barney (edited 03-09-2000).]
 
Adam Silver Mar 9, 2000 07:21 AM
Apple has included built in drivers for USB printers for quite some time. (All you need is an icon in the Chooser.) The Epson drivers are problematic. You can safely trash the files.

This also applies to Iomega's USB Zip drivers and Imation's USB SuperDisk drivers.
 
Barney Mar 9, 2000 01:33 PM
Adam, I disabled the Imation Superdisk drivers, and tried using the unit. It didn't work. I did the disable, restart, and re-enable, restart, two more times. Everytime my Superdisk drivers were disabled, the unit would not operate.
 
Adam Silver Mar 9, 2000 02:40 PM
Do you have Apple's USB Mass Storage drivers in your Extensions folder?
 
Barney Mar 9, 2000 03:47 PM
No, I don't have USB Mass Storage drivers. Are they something I should have or should not have?
 
Adam Silver Mar 9, 2000 09:26 PM
They should be there. You can download the latest version at:

http://asu.info.apple.com/swupdates.nsf/artnum/n11418
 
Barney Mar 9, 2000 11:15 PM
Well, Adam, you did it again. I downloaded USB Mass Storage, installed it, removed all the USB Driver extensions you referred to, and everything I have plugged into the USB ports is working great.
 
palws Mar 12, 2000 03:10 AM
Adam Silver Thanks!!! http://forums.macnn.com/cgi-bin/smile.gif
Barney told me to come see this
thread,And boy am I glad.Now everything
is working great!
Bill http://forums.macnn.com/cgi-bin/smile.gif
Thanks again!
 
All times are GMT -4. The time now is 03:03 PM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2016, vBulletin Solutions, Inc.


Content Relevant URLs by vBSEO 3.3.2