MacNN Forums (
-   Classic Macs and Mac OS (
-   -   TCP/IP slower than Appletalk (

Mark B Nov 8, 1999 02:45 AM
TCP/IP slower than Appletalk
Hi there. this is my first post to the bbs so be gentle!!

I have seeked the answer to this question for some time now, so I hope some of you out there might be able to help. I have tried Apple direct, their bbs and others but to no avail.

I have setup now quite a few Appleshare IP servers (running on new G3 and previous mac's) from v 5 up to 6.2 and all display these symptoms.

when you allow 'tcp' on the server the file transfer times slow right down until the whole transfer grinds to a halt. The workstations in the offices are running 8.1 upto 8.6 all with the latest appleshare client. The network is 10/100 (each site has a different brand of hub so I can't blame the hubs for the fault). When I turn tcp off on the server then the file transfer times are good. (1.5mb per sec).

I did an installation last week of a G3 server and turned tcp on to see what would happen. All the clients are beige G3's with the latest appleshare client running 81 to 8.6 mixture. When they write to the server is goes through at a blinding rate, but when you pull the file off it takes an age.

what's going on here? Are their hubs having difficulty filtering the IP packets? Is there a problem with the server? The server is running 8.6 with IP6.2.

Any help would be appreciated.

pieman Nov 8, 1999 08:26 AM

I had a similar problem that was on 2 Macs and a crossover cable. The problem actually turned out to be a file sharing one (i.e. it wasn't set up properly or something like that, now it works a dream). That was with Appletalk, but the symptoms sound the same.

Is 802.3 checked in the TCP/IP control panel ethenet setting. If it is, try taking it off and make sure whichever it is, that all of the machines have the same setting. As far as I understand, 802.3 is an older and slower version of the ethernet (is protocol the right word to use here?) whatever, it's older, more compatible and slower but your set up sounds like it doesn't need that safety net.

Good luck
teknodav Nov 8, 1999 10:18 AM
Hello Mark,

What you've described is a classic ongoing problem with a solution that was covered in the <a href="">AppleShareIP Mail List</a> for over a year. You don't describe the type of ethernet cards you are using for 100base-T. If you use Asante, you are in luck, use the control panel to select the middle bullet "Turn off NWay, use Half-Duplex Mode."

Your solution lies there. And if you aren't using 100base-T for your network, don't use TCP/IP for ASIP -- you'll only get the speed you want when you use CAT-5 cabling and 100base-T Ethernet. Avoid full duplex unless you can certify a CAT-5 network.

RichWF Nov 8, 1999 02:31 PM
Hello Mark,

Try the following: Open the TCP/IP control panel and change the user mode to Advanced, then click Options... , if Load only when needed is checked make sure you deselected it. With these settings TCP/IP should give roughly double the performance of AppleTalk.

myersm1 Nov 8, 1999 09:37 PM
Could I be seeing the same thing when trying to print via TCP/IP? If I use this option when setting up a networked printer on our intranet, the spooled document takes ages to get to the printer. It is transferred in small chunks, very slowly. I often get a crash.

lombard G3, either OS 8.6 or 9.
Mark B Nov 9, 1999 02:29 AM
I am visiting the customer tomorrow and will do the following:

Install the Apple Duplex tool on the b/w G3's and then alter the software settings on their Asante cards in the beige G3's.

I'll post my findings soon.

All times are GMT -4. The time now is 12:56 AM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2016, vBulletin Solutions, Inc.

Content Relevant URLs by vBSEO 3.3.2