MacNN Forums (http://forums.macnn.com/)
-   Classic Macs and Mac OS (http://forums.macnn.com/classic-macs-and-mac-os/)
-   -   login unexpectedly quitting (http://forums.macnn.com/64/classic-macs-and-mac-os/45209/login-unexpectedly-quitting/)

 
mhencin Mar 28, 2000 01:52 PM
login unexpectedly quitting
I have been having this problem for sometime, and am now frustrated enough to talk about it! I have multiple users and more often than not login will quit. It closes all my open apps, and I am forced to restart. I seem to have this happen more when I am connected to the Internet, but not always.

Any thoughts or suggestions?

Mike


Mike
 
Bball672 Apr 2, 2000 10:07 PM
I have the exact same thing happen to me. I absolutly hate it. http://forums.macnn.com/cgi-bin/frown.gif I would also like to know how to fix it.

Norm
 
Paul Crawford Apr 3, 2000 11:41 AM
Hi all:

There are several apparent causes of this problem, but one common factor seems to be an extension conflict.

See some of the related posts in this forum -- e.g., Mac OS 9 Sucking Up Too Much Memory And Log-in Errors? -- or over in MacFixIt's Mac OS 9 forum -- e.g., Virex 5.9.1 and OS9.

Regards,

--Paul
 
Bball672 Apr 3, 2000 02:18 PM
Well, first of all I don't use Virex. Secondly, I need multiple users to be on because I often have guests come to my house and I want to make sure they can't mess up my computer. Is there any way where I can keep multiple users on without having the "login unexpectingly quit" error?
 
wlonh Apr 3, 2000 03:06 PM
http://forums.macnn.com/cgi-bin/Foru...ML/000299.html
http://forums.macnn.com/cgi-bin/Foru...ML/000447.html

and for more on this, search the MacOS 9 forum for keywords 'multiple users'

[This message has been edited by wlonh (edited 04-03-2000).]
 
Bball672 Apr 3, 2000 07:42 PM
Wlonh, neither of those forums helped out AT ALL. They discussed other problems like setting up desktop pictures and themes for multiple users. Neither of the forums you sent links to had anything about the "login unexpectingly quiting" error. Please if anyone has a solution or part of a solution to this problem, please post it as soon as possible. And please MacNN bring this forum to the attention of others by addressing it as one of the forums that people should look at, at your start page. Thanks in advance. Norm
 
wlonh Apr 3, 2000 08:59 PM
well pardon me!!! i BRIEFLY looked at the threads i posted referrals to and it seemed that there were good tips for using multiple users...

I DID TAKE THE TIME TO SEARCH FOR SOMETHING
and it seems i wasted my time... so sorry

maybe you can use your OWN time to search,
like the Apple Tech Info Library, etc

[This message has been edited by wlonh (edited 04-03-2000).]
 
Bball672 Apr 3, 2000 09:23 PM
Listen, I apoligize. I've been having a real bad day. Please forgive me. I would like this problem solved as soon as possible. Thanks in advanced. Norm
 
Paul Crawford Apr 4, 2000 03:11 AM
Hi again Norm,

We all realize that this problem is very frustrating, but do try to bear with us. Neither Wlonh nor I ever meant to imply:- "here's a URL to *the* post that will tell you how to fix the problem once and for all". As I said before, the deeper issue is that this symptom can have many different *apparent* causes. If you go back to the first post that I mentioned, you'll see that even though one user said that the symptom occurred with a 'Base' extensions-set, many third-party extensions were also listed as possible culprits (e.g., CharisMac, Keyspan, CUSeeMe). Actually, even a 'Base' set can contain third-party extensions (such as Iomega's), or third-party contextual menu items, control strip modules or fonts (if your extensions manager doesn't explicitly handle them); although, in that one user's case, the problem may also have been due to corrupt system software or preference-files.

As Wlonh indicated, there are also many other libraries and forums which discuss this and other issues. For instance, there is Apple's Tech Info Library (which has, e.g., an article on Login quitting due to AppleShare problems). Also, there is Apple's very own Mac OS Discussion Forum, with tons of posts (rants, raves and everything in between). You could try searching in those sources for additional clues.

In other words, the sheer variety of apparent causes implies that there is no single "quick fix" that will necessarily work for everyone. As you may know, the Mac OS doesn't currently implement rigorous memory protection ("walling off" programs from each other); this is especially true of the global, system-wide extensions which give us so much added functionality but which can also wreak so much havoc. Similarly, there isn't too much built-in protection against corrupt system software or preference-files. Fortunately, most of these issues will be resolved in the eagerly-awaited Mac OS X.

If you want a more "definitive" bottom line, here's the best that I can offer:- Try running with the 'Base' or 'All' extensions-set (also manually excluding any third-party contextual menu items, control strip modules or fonts, if necessary), and see if the symptom still occurs. If it doesn't, then you have an extensions conflict; if it does, then try the standard troubleshooting procedures -- e.g., trashing certain system preference-files (Finder, Apple Menu Options, etc.), toggling Virtual Memory on/off, zapping the PRAM, performing a true clean-install, disconnecting devices before startup (USB, SCSI, etc., depending on your machine), and so on.

Finally, just to put things a little in perspective, my household has been running Multiple Users (4 Normal users + 1 Limited user) on my beige G3/266/128MB for several months now, and I'm pretty sure none of us has ever encountered this particular 'Login unexpectedly quit' problem [yes of course, like everyone else, we've had other problems with MU, but that's another story :-)].

Good luck,

--Paul

[This message has been edited by Paul Crawford (edited 04-04-2000).]
 
thndrdan88 Apr 4, 2000 12:00 PM
I was wondering if anyone that was having this problem had updated their Multiple User. Apple has an update at http://asu.info.apple.com/swupdates.nsf/artnum/n11567 that I think would be very helpful. Once I updated, most of my "login unexpectedly quit" problems stopped. Hope this helps some of you out.

Scott
 
ilash Apr 4, 2000 12:18 PM
I don't know what causes the problem with Login, but I do know that sometimes the Login file becomes corrupted, especially after a crash in my browser. An easy fix is to drag the Login onto ResEdit, which will then launch and repair the file.

The corruption happens about 50% of the time after a crash in Internet Explorer. I've gotten to where I check the file for corruption by dragging it to ResEdit just in case it needs repairing after every crash or forced restart.

The file corruption may not be related to the problems that you are having with Login, but it might be a good idea to check this file with ResEdit.
 
Scott_H Apr 4, 2000 02:33 PM
Hi,

I have this problem. Never found a solution short of a reboot. It never happens when the "owner" logs in only "users". Thank god I set my wife up with the owner account!

I don't think it related to memory as my largest unused block is always nice and high when it happens.

I'm not sure if I have the update above but will check when I get home.

When I fist set up MU it did it alot and them seemed to calm down over time.

I think that's all I have to add right now.

[update]
I though I should mention that I'm running on a Rev C iMac with 96MB of RAM and VM set to 97MB.[/update]

Scott H.


[This message has been edited by Scott_H (edited 04-04-2000).]
 
Bball672 Apr 4, 2000 05:33 PM
Well, in my case. Thanks to the update thndrdan88 gave me. The "login unexpectingly quiting" error almost never happens anymore. http://forums.macnn.com/cgi-bin/eek.gif Thanks thndrdan88! http://forums.macnn.com/cgi-bin/smile.gif Thanks MacNN! http://forums.macnn.com/cgi-bin/biggrin.gif Thanks MacNN moderators, administrators, and webmasters! http://forums.macnn.com/cgi-bin/biggrin.gif Esspecally thanks to all of you who have read this forum and replyed! http://forums.macnn.com/cgi-bin/biggrin.gif It still happens once IN A LONG while, but not much anymore. In fact, only once in the past 7:37 hours:minutes. In which 7:37 hours:minutes ago I read what thndrdan88 said. While it happened before three times per hour. Again, thanks everyone. http://forums.macnn.com/cgi-bin/biggrin.gif Norm
 
Paul Crawford Apr 5, 2000 04:17 AM
Hi again Norm,

Great news! Well, at least now you have one less problem to worry about, right? ;-)

BTW, MacFixIt recently reported that a newer Macintosh Manager 1.3 update will be released soon. Hopefully, it will include a fix for the Appearance-related bugs that some people have been experiencing with the MM 1.2.4 update.

Regards,

--Paul
 
Ster May 2, 2000 08:58 PM
it's baack!
i'm setting up a lab w/ 17 iMacs, using Mac Manager 1.3 (latest version), being served from AppleShare IP 6.3.2
i initally set up one 'base' machine, and then used Apple Network Assistant to copy the hard disk to a few of the other machines. (ANA rocks, btw!!!)
i then used those machines as seeds for ANA, so i could have multiple machines being setup at once.
nine are now up and running, but one has the 'login unexpectedly quit' error. unfortunately, simply logging in anyway DOES NOT work! it starts talking to the server, but then kicks back out to login, and the error pops back up. i believe it let me get into system access, though...
anyway, i'm going to try to manually re-install Mac Manager 1.3 on that particular machine tomorrow.
i'll keep you all informed,
-ster

p.s. - i'm a luck s.o.b.: you may recall my thread a few months back about setting up a bunch of iMac DVs; with these new DVs for this lab, i'll have set up 36 iMac DVs w/ 128MB RAM each. plus three g4 workstations, and g4 ASIP server. WOW! :-) -s
 
All times are GMT -4. The time now is 06:32 AM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2015, vBulletin Solutions, Inc.


Content Relevant URLs by vBSEO 3.3.2