MacNN Forums (http://forums.macnn.com/)
-   Classic Macs and Mac OS (http://forums.macnn.com/classic-macs-and-mac-os/)
-   -   CarbonLib 1.3.1 --Can't Delete Any Files!! (http://forums.macnn.com/64/classic-macs-and-mac-os/45331/carbonlib-1-3-1-cant-delete/)

 
bbreen May 12, 2001 02:10 PM
CarbonLib 1.3.1 --Can't Delete Any Files!!
http://forums.macnn.com/cgi-bin/confused.gif Wow. I am really puzzled. I downloaded CarbonLib 1.3.1 and I cannot drag anything to the trash. I am operating a G4 w/OS 9.1. It was working fine until I did a Software Update and had it install this update. To verify the problem I started up from an external drive using the CarbonLib 1.2.5 in the System Folder. It worked fine and items could be dragged to trash. I tried again on the internal drive with 1.3.1--same problem. I then replaced CarbonLib 1.3.1 in my internal drive's system folder with 1.2.5 while booted on the external drive. I re-started and it the internal drive now works fine again (can drag items to trash). In effect, with CarbonLib 1.3.1, I could not delete ANY file! I've been using Macs a long, long time, and I am not aware of any setting I can change with 1.3.1 to successfully delete items. Maybe my brain went south today. Thanks for any assistance; I'd like to use the newer CarbonLib 1.3.1.

Barry
bbreen@lightspeed.net
 
runningdog May 12, 2001 04:03 PM
i've read at www.macfixit.com that Drag & Drop support has been affected by Carbon 1.3.1. But i'm running the update and i'm not experiencing the problem you're having or any Drag & Drop related problems. Must be some extension conflict.
 
rosssanford May 12, 2001 11:22 PM
I have the same problem on a G4-533 (work) and iMac DVSE 400 (home). I wish I knew what the problem was, but downgrading the Carbon Lib fixes the problems for me.

Good Luck...
 
bbreen May 12, 2001 11:37 PM
http://forums.macnn.com/cgi-bin/wink.gif Yes--thanks. I replaced CarbonLib and am using 1.2.5, and it works fine. I looked at the new Apple TIL #106302, but that only addresses some conflict with Applescript and having the "dialect folder within the Scripting Additionas folder in the Systems folder. I tried removing that abnd using CarbonLib 1.3.1 but had the same problem as before. At any rate, I'm sure Apple will hear lots on this one. And, not everyone is having the drag and drop problem so its weird (but a lot of folks are).

Barry
bbreen@lightspeed.net
 
bbreen May 13, 2001 01:10 PM
In following some of the other bulletin board traffic on this issue, I noticed some folks reporting that this MAY be a conflict with True Finder Integration and that removing TFI from the control panels folder enabled CarbonLib 1.3.1 and the drag/drop to function properly. Haven't tried that yet, but will.

Barry
bbreen@lightspeed.net
 
zos May 14, 2001 11:51 AM
I had the same problem the other day after installing 1.3.1 and ended up using the old 1.2.5 installer I had and reverting.

This isn't limited to the trash, it's all about drag and drop. I couldn't move anything into any other folder. I could however use command-delete to move things to the trash, thus bypassing drag and drop.

I've got True Finder Integration on my computer at home and I'll try disabling it when I get home from work. They're saying on MacFixit that it's curing the problem.
 
zos May 14, 2001 12:52 PM
On Macintouch they're reporting quite a few more possible issues that are making me think I may just stick with 1.2.5:

Quote
Drag-and-drop and Apple Data Detectors problems seem to be the predominant issues with Friday's release of CarbonLib 1.3.1, but other problems have surfaced:

* [R. D. Bridges] "CarbonLib 1.3.1 appears to break Action Menus' capability of dragging objects into the menu bar. The menus remain functional, only the drag ability seems to be broken. Returning to CarbonLib 1.2.5 immediately restored drag capability into the menus."
* [Paul Mackey] "The new Carbonlib 1.3.1 also seems to conflict with Apple Data Detectors for, when they are loaded, the system [freezes] at startup while loading the Finder. Turning off Data Detectors in the Extensions Manager solves the problem. This has happened to me on two machines: A Powerbook Bronze 400 and a Power Mac 5500/250 with a Sonnet upgrade card."
* [Michael Zelner] "I installed the CarbonLib 1.3.1 update on a beige Power Mac G3 running OS 8.6. After restarting, I could no longer run the Application Switcher -- when I tried to 'tear off' the Application Menu, I got an Apple error message that the 'MPLibrary could not be found' (even though the Multiprocessing API Library extension was still installed). I reinstalled CarbonLib 1.2.5 and upon restart the Application Switcher menu reappeared automatically."
* [Tim Ballering] "I installed the Carbonlib 1.31 and Slot Loading iMac Firmware updates today. Everything was fine until I tried to print from Quicken 2000 to a Brother 1240 printer. It will now only print if you manually launch the Brother print monitor. There are wide spaces between the words of the longhand amount. The machine also no longer will share the printer using USB Printer Sharing Control Panel. Printing from all other applications seems to work as normal."
* [Owen Borstad] "I updated CarbonLib ... and the next time I used Entourage, I could no longer drag and Drop messages into my folders. I can still drag them to the desktop, but to move them to folders, does not work. This was the only thing that got updated, and it (Entourage & moving messages) works fine still over the network on another computer."
* [Peter Kaufman] "On my G3/266 running OS 9.1, CarbonLib 1.3.1 would freeze my Kensington 2-button mouse every time I booted. The freeze would happen just as the Desktop appeared. Reverting to CarbonLib 1.2.5 solved the problem."
There are also some people reporting on MacFixit about an extension related to N2MP3 breaking drag & drop with CarbonLib 1.3.1.

This stuff all makes me wonder if Apple bothers testing their software at all anymore. Incompatibility with some 3d party software is acceptable but when it's conflicting with their own software and as many 3d party software as it is...

It's the same thing with their OS X testing. Seems like they're just throwing things out the door now.
 
All times are GMT -4. The time now is 07:27 AM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.


Content Relevant URLs by vBSEO 3.3.2