MacNN Forums (http://forums.macnn.com/)
-   Classic Macs and Mac OS (http://forums.macnn.com/classic-macs-and-mac-os/)
-   -   Missing SW...help!?!? (http://forums.macnn.com/64/classic-macs-and-mac-os/45626/missing-sw-help/)

 
allensis Dec 31, 1999 07:49 PM
Missing SW...help!?!?
I have at least 3 different apps that tell me they cannot run without one or another files that start with "InterFaceLib..."

Any help would be appreciated. Like where I can get this sw.

Here are some of the file names that have come up:

"InterFaceLib--"
"InterFaceLib--tA5"
"InterFaceLib--tNextEvent"
"ThreadsLib--OTInetGetInterfacLibInfoOT"

Thanks,

joe
 
Gregg Dec 31, 1999 09:14 PM
Those are extensions. They need to be in your System folder's extension folder. Perhaps you didn't know what they were and threw them out? Try reinstalling the apps you're having trouble with. If there's a custom install, just install the extensions.
 
allensis Jan 2, 2000 01:50 AM
OK, now what? I can't find which app these would belong to, so I can't retrieve them.

Does anyone have them that they could email to me via a zip file or something?

Thanks!
 
Gregg Jan 2, 2000 08:19 AM
Just go ahead and reinstall the applications that are giving you the error messages. If these extensions are associated with those apps, the extensions will be installed automatically. If they're not, I'd be surprised, but that means I don't know the answer either. It won't hurt your files to reinstall the applications, but it might give you two copies of the application's folder. I'd throw out the one that was already installed, and keep the new one.

P.S. Have you done a search, with Find, on the names of those extensions? Perhaps they are in the Extensions(Disabled) folder, or hiding somewhere else. If you find them that way, just move them into the extensions folder and restart. Then you don't have to reinstall anything. Make sure they show up in your Extensions Manager, and are checked.

[This message has been edited by Gregg (edited 01-02-2000).]
 
allensis Jan 2, 2000 02:40 PM
Reinstalling the apps will not work, as these error messages come up when I run the app the first time.

It may be associated to the fact that they are downloads and how stuffit (5.1.3) expands them I don't know.

They are not on my system, I have done the search, and thus they are not disabled.

I am just looking to find them, if someone has them in their system, can you help me get them too?

Thanks, joe.
 
drewman Jan 2, 2000 03:36 PM
Those extensions look like ones incorporated directly into the System file. Do you have a recent backup of your system file? Try that and if you don't, try reinstalling your system software.

drewman
 
allensis Jan 2, 2000 04:36 PM
I have already performed a VERY clean install of OS8.6 on a newly formated hard drive, to no avail.

Thanks...joe
 
josntme Jan 2, 2000 10:13 PM
What Apps are you talking about that want these extensions?

------------------
You do not really understand something unless you can explain
it to your grandmother."
- Albert Einstein
 
allensis Jan 3, 2000 12:23 AM
One of them is a flashrom updater from villagetronic for my MP850 graphics card. It is at:

ftp://ftp.villagetronic.com/pub/mac/MP850/MP850UpdateV1.3.hqx

The other is a shareware game called skittles2, which I know everyother mac user is thouroughly enjoying right now, except myself and one other iMac/OS9 user.

I am on a PM6500 OS8.6/96MB ram, clean install of course.

hmmm...
 
oscar Jan 3, 2000 02:36 PM
Looks like you need the Apperance Manager, and OpenTransport. Try intalling these and Lemme know.

------------------
-See Yea!
 
josntme Jan 3, 2000 04:24 PM
If you did a clean install, then the missing extensions and control panels are in your previous system folder. Just drag them to your present system folder and restart.

------------------
You do not really understand something unless you can explain
it to your grandmother."
- Albert Einstein
 
allensis Jan 4, 2000 09:31 PM
Well I think I have solved the problem.

By redoing what I had already tried. A clean install of system 8.6, though this time I made sure to boot the computer from the 8.5 CD and run the install from there.

I then went ahead and installed the 8.5.1 upgrade and then the 8.6 right on top of it. I also installed the latest version of my modem software, GeoPort 3.1.3. And did the latest Open Transport upgrade. Stuffit came with either the system sw or the new install of IE 4.5 28 bit. and it seemed to work fine.

After all this the files I had been failing to use worked, of course after I downloaded them again assuming the first time was corrupt.

So now it seems to be back to normal. Thanks for all the help.

 
mike one Dec 10, 2001 06:11 PM
nothing like bringing back a dead thread but:

my new ibook gives me this error occasionally:
" the application (itunes, imovie, dvd, etc. etc...) couldn't open because the file "interfacelib" could not be found (#-2xxx)" {where xxx are 3 numbers i can't remember at the moment.

i reinstalled os 9.2.1 it worked fine, for 1 day. then bang all over again. restarted and the comp worked! what in the name of a$$ is this error.
it is not an extension because on the 4 macs i have access too, all with os 9.0 or greater, none of them have anything closely named.

hmm just when i gave up on X, now i'll have to go back :p

any thoughts how to prevent this?

TIA,
mike one
 
All times are GMT -4. The time now is 03:47 AM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2016, vBulletin Solutions, Inc.


Content Relevant URLs by vBSEO 3.3.2