MacNN Forums (
-   Classic Macs and Mac OS (
-   -   Screwed up again..... (

redeew May 20, 2001 11:42 PM
Screwed up again.....
Here`s one of those things I should know.But,because I bought this machine (Performa 6320/OS8.1) used,I have no manual to fall back on so I`m turning to ya`ll .
I rebuilt my desktop and all my program icons disappeared.
What`s going on and what`a I do????

Caution; slow typist at work
reader50 May 21, 2001 12:43 AM
Run Disk First Aid on your partition(s) to check for disk damage. Apple has tested Disk First Aid 8.2 with OS 8.1. However, I seem to remember using Disk First Aid 8.6 successfully under OS 8.1 as well. Maybe I'm dreaming, but the link is there anyway.

Once any disk damage is repaired, use the free TechTool to rebuild your desktop file on all partitions. If your desktop file has become corrupted, a normal rebuild may not fix it. TechTool backs up the Finder lables & comments, then deleted the desktop file. This forces the Finder to create a clean new desktop file. After which TechTool restores the label & comments stuff. TechTool will also let you check your System file for corruption, another possible source of the missing icons. Note that you should reboot afterwards for any and all changes to take effect.

[This message has been edited by reader50 (edited 05-21-2001).]
redeew May 21, 2001 12:41 PM
Like I said,I should of already known all this but......

Caution; slow typist at work
redeew May 21, 2001 04:08 PM
I ran DiskFirstAid and the only problem it found was with icons.I rebuilt the desktop and I`m still missing my icons.

Caution; slow typist at work
reader50 May 21, 2001 10:52 PM
If the custom icons were damaged, the above repair steps will have fixed any disk damage. TechTool Pro might be able to fix the custom icons themselves, but TTP is commercial software. And it might just fix things by deleting the damaged icon file. Seems like you will have to get the custom icon for each application from the application's source, like the install disk. Open the Get Info on the good icon, click in the icon in the Info window, and Copy. Then Get Info on the icon-less app, click in the Icon space of the Info window, and Paste.

Or, you could delete the old application and copy it fresh from the install disk. Or reinstall on install disks that do not allow such a simple copy.
reader50 May 22, 2001 03:49 PM
Not thinking fast enough here. Trash the Finder preferences file, and the Mac OS preferences files, then reboot. Corruption in these prefs files are known to produce some very odd behavior.

About the missing icons, what exactly are you still seeing? I have been assuming that after rebuilding all the desktop files that you get generic application icons instead of the correct custom icon for each application. If the icons actually remain invisible (only the name showing), then there is likely damage in the Finder, System file, or System Resources file. Boot from CD or a differnt partition, and replace those three.
redeew May 22, 2001 05:02 PM
The names are there but the icon is an AppleScript icon.
Any idea as to what I did or didn`t do to cause this???

Caution; slow typist at work
reader50 May 22, 2001 07:52 PM
AppleScript icons on all of your applications? I've never seen that one before, sorry. The possibilities I am thinking of involve damaged system files (listed above), corrupt File Exchange prefs file, or a virus. That last seems unlikely, viri are such a non-issue under the Classic Mac OS. You can try Disinfectant anyway, it's free.

What happens when you double-click on one of the application, er, AppleScript icons? If the Script Editor launches, it's probably a file mapping problem. You could drag the File Exchange prefs file to the desktop & reboot. If that doesn't fix it, you can boot from CD and move the prefs file back, replacing the new one that would have been created. Dragging the prefs file back in a live system folder is just asking for a corrupted file. You could also trash the Script Editor (normally in /Apple Extras/AppleScript/) & rebuild the desktop again, then see what application launches on a doubleclick.

If the correct application launches when double clicking on those AppleScript icons, it really is an icon problem of some sort. And I've about run out of ideas, it may be time for the AppleScript gurus to jump in. If nothing helps, post your problem in the Developer/AppleScript Forum. They may have seen this before.
redeew May 22, 2001 10:45 PM
I guess it`s an AppleScript icon (a hand writing on paper).
I`ve ran everything I`ve got trying to figure this out. Most everything works when I click`em but I am having troubles with some of them.I can`t open anything with TexEdit (error 5699:what the hell is that?) and all the folder icons that "I" put in are still there.
And I`m still finding other "problems" so basically I`m about ready to try the "fist through the screen remedy".
I`ve used:TechTool and DiskFirstAid which both say that everything`s fine. And no viruses (Virex).

Caution; slow typist at work

[This message has been edited by redeew (edited 05-22-2001).]
DocWest May 22, 2001 11:24 PM
Sounds like just a generic App icon to me...

but i still dont have any idea on how to fix the problem.
acur128 May 23, 2001 12:18 AM
like docwest says, it does sound like the generic app icon... most often caused by a messed up desktop db. if you haven't already, you may want to, as reader50 pointed out, try a desktop rebuild with TechTool, which completely removes the old db (you can save it first with the save button, but it doesn't seem like you'd want to go back to it anyway). i've had that happen many a time on my performa (but never on my pismo!), that is lost the app-specific icons, and rebuilding after trashing the files with TechTool always brought the icons back. you could also try making the files visible with FileBuddy, ResEdit, etc., or even do a Sherlock search for invisible files, and trash the dektop database files (the ones you'd be looking for are "Desktop DB" and "Desktop DF"). If the system's ok, they'll always be recreated on the next startup. But first, i'd try TechTool 1.2.1 (link above) if you haven't already, or even again if you have. If it doesn't work, must be something funky with the system, which hopefully a clean install would correct.
reader50 May 23, 2001 12:29 AM AppleScript Icon (the Script Editor, actually) Generic Application Icon

I agree now, it does sound like generic application icons. If replacing system files, trashing prefs, rebuilding the desktop(s), and running repair utilities do not help, it's time for a clean reinstall.
redeew May 23, 2001 01:09 AM

Your right about it being a generic app. (it looks close though)
I`ll try another rebuild (but I ain`t counting on it).
In case nothing else works,any good icon tools out there?

Caution; slow typist at work
posthumanus May 23, 2001 04:45 AM
this has happened to me with the generic icons: after a while it magically disappeared. here's the thread FYI:
redeew May 23, 2001 09:03 AM
Rebuild didn`t work. Looked everywhere,no DDB or DDF (?).Now she`s starting to act slugish and hangs.
I`m going to try a clean install when I get off work today and see what happens from there.
And here`s something new (atleast to me),Every now and then my cursor turns into a box with a "X" in it.?

Caution; slow typist at work
redeew May 26, 2001 01:13 AM
Originally posted by redeew:
Here`s one of those things I should know.But,because I bought this machine (Performa 6320/OS8.1) used,I have no manual to fall back on so I`m turning to ya`ll .
I rebuilt my desktop and all my program icons disappeared.
What`s going on and what`a I do????

Well I finally got it fixed.And it was so simple too..
All I had to do was: reinstall OS 8 and OS 8.1 (and it only took two try`s),reinstall Earthlink (atleast I got a couple of updates out of it) and I`m still trying to get some of my memory back ( I`ve gotten back about 100mg. out of 250 I lost).And it`s only taken me three days.
I like to think of it as a learning experiance.Sorta like learning about electricity when you were four and you found out that paper clip in your hand "will" fit in that little hole in the wall.
Thanks everybody for your help..

Caution; slow typist at work
reader50 May 26, 2001 01:36 AM
Originally posted by redeew:
... Looked everywhere,no DDB or DDF (?) ...
Sorry, should have replied to this earlier. The Desktop DB and Desktop DF files are at the root of each partition and are invisible. You can make them visible using ResEdit to edit the File Info for them. You would turn off the Invisible flag.

The easy way to see them is by opening a Netscape window, and dragging your HD icon into the Netscape window. This is also one of the few ways to see & get into the Temporary Items folder, which the OS usually pretends isn't present, and that you cannot make visible at all.
redeew May 26, 2001 09:50 AM
NOW he tells me.
Cipher13 May 26, 2001 10:35 AM
Originally posted by redeew:
NOW he tells me.
Hey, try and sound a little greatful, even if you don't mean it, ok?

AIM: Cipher1387
ICQ: 48111606
redeew May 26, 2001 04:03 PM
Well I do appreciate everyboy`s help,it`s just that your timings a little off.

Caution; slow typist at work
reader50 May 26, 2001 05:09 PM
Easy, people. I'm not offended. At least the problem got solved, and that's the important part.
redeew May 27, 2001 02:35 PM
The #*&%## thing did it again.
First thing I did after it happened was to run TechTool and it reported no problem so I did a rebuild.No help.
Next I run Disk First Aid " everything`s ok"
So I trash desktop df & db and restart.
It worked.
Now all I wanna know is what caused it???

Caution; slow typist at work
reader50 May 27, 2001 03:09 PM
The most common cause was a system crash while the Finder was writing to the Desktop files.
redeew May 27, 2001 05:55 PM
It did crash on a startup.I`ve been chucking out all kinds of duplicate files.

Caution; slow typist at work
All times are GMT -4. The time now is 04:07 AM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2016, vBulletin Solutions, Inc.

Content Relevant URLs by vBSEO 3.3.2