MacNN Forums (http://forums.macnn.com/)
-   Classic Macs and Mac OS (http://forums.macnn.com/classic-macs-and-mac-os/)
-   -   Open Firmware boot problems (http://forums.macnn.com/64/classic-macs-and-mac-os/46489/open-firmware-boot-problems/)

 
bradoesch Jun 24, 2001 12:31 AM
Open Firmware boot problems
Hi all!

I've got a really big problem this time (at least I think I do). My iMac was sitting there with the gray screen (at startup), and was just stuck there (I must have restarted and left, and hadn't noticed that it didn't start up). Also, the hard drive wasn't spinning. So I tried the restart commands on the keyboad (forgot about control-command-power, grr). Anyway, they would restart the machine, but the hard drive wouldn't spin, and I didn't get any further than the gray screen. So, I bit my lip, and pulled the power cord. I put it back in, then pushed the power button. What a nice surprise for me when it started to boot, because it went right into Open Firmware (a scary place IMHO). It says boot failure, and that is because of an invalid checksum. I can type "shut-down", and that works. But when I type, "mac-boot", there is this smaller version of the Mac OS logo, then a flashing question mark. Not the typical flashing question mark that looks friendly, it's a smaller on that I've never seen before. Then underneath, there is this message:
/pci@f2000000/@d/mac-io@7/ata-4@f000/disk@0:9,\\:tbxi

I've tried booting from my original 8.6 CD, then the OS 9 CD, with no success. Nothing seems to work. I unplugged everything except for the keyboard and mouse (well, network cable is still in there. . .). I zapped the PRAM a few times, no success. Recently, I installed the TechTool Pro 3.03 update (err, the most recent one, I might have those numbers wrong). I've done everything I know of, and I'm stuck. I'm typing this on a PC, and *not* having fun doing it :confused:
Here is my computer:

iMac DV 400MHz
384MB RAM (128 + 256)
Mac OS 9.1

If more information is needed, just ask or email me. Thank you in advance for your help.
 
Cipher13 Jun 24, 2001 09:40 AM
Pull your network cable, pull your RAM. Keep only the original RAM in there, then do the following. If it doesn't work, do it with only the OTHER RAM.

Try booting.
If no go:

1. Remove all power for 2 minutes. Try booting.

If no go:

Repeat 1.
Reset the PRAM by hitting the CUDA switch or removing the PRAM battery. I have no idea where its located on your iMac but it will require some disassembly. Boot. Hold the option key down if it doesn't work the first time.

Could you get a picture, like a photo, of this strange System Icon? Does your computer make a strange sound at startup? These tones can give clues as to the problems. If they still do that nowadays, that is.

I'm thinking a corrupt ROM (that icon leads me to believe this, mostly).

Try this and report back.

[ 06-24-2001: Message edited by: Cipher13 ]
 
bradoesch Jun 24, 2001 10:25 AM
Well, what do ya know? I tried to boot it up this morning, and it acted like nothing had happened. Booted right up.
When the Finder loaded, though, there was a sound manager error, and it said that sounds had been disabled. The window isn't new to me, it's done that before. I simply restart has always fixed the problem.
Here is a
MacFixIt Forum Page that has a situation that is very similar to mine (different machine, etc., but the same problem and error messages).
Hopefully if it does this again, I can push that button and it might fix things. I believe I can access the button through the little door that lets me get at the RAM.
Sorry 'bout the photo. But if this problem comes back again, I'll use my camcorder to take a still for everyone.
Thanks for the help!
 
All times are GMT -4. The time now is 12:23 AM.

Copyright © 2005-2007 MacNN. All rights reserved.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2015, vBulletin Solutions, Inc.


Content Relevant URLs by vBSEO 3.3.2